netcat with -c flag

Bug #145594 reported by Rodrigo Rivas Costa on 2007-09-27
2
Affects Status Importance Assigned to Milestone
netcat (Debian)
Fix Released
Unknown
netcat (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: netcat

Docs say that netcat can use the -c flag to execute a command using /bin/sh, but this only works in the server side, not the client.
Here, -c behaves like, -e, that is, using exec.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 RC or later?

Changed in netcat:
status: New → Incomplete

It looks like it have been solved in the Debian package. Quoting the
changelog:
        netcat (1.10-33) unstable; urgency=low

          * Cleaned up sh-c.patch, removing duplicated code and fixing
        -c behavior for outgoing connections (Closes: #365632)

I've tested it in 8.04 and 8.10 and it works well now.

Regards.

Changed in netcat (Ubuntu):
status: Incomplete → Fix Released
importance: Undecided → Medium
Changed in netcat (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.