netcat-openbsd prints verbose message “Connection to ...” to stdout

Bug #519210 reported by Stefan Haller on 2010-02-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
netcat-openbsd (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: netcat-openbsd

Netcat should log this message to stderr instead.

Reproducible with this version of netcat:
ii netcat-openbsd 1.89-3ubuntu1 TCP/IP swiss army knife

Stefan Haller (haliner) wrote :

This patch should solve the bug.

Changed in netcat-openbsd (Ubuntu):
assignee: nobody → Stefan Haller (haliner)
status: New → Fix Committed
Stefan Haller (haliner) wrote :

According to https://wiki.ubuntu.com/MOTU/Contributing it would be better to set the status to confirmed and to assign nobody.

Changed in netcat-openbsd (Ubuntu):
assignee: Stefan Haller (haliner) → nobody
status: Fix Committed → Confirmed
StefanPotyra (sistpoty) wrote :

oh, it's in main, so you'd need to subscribe ubuntu-main-sponsors instead of ubuntu-universe-sponsors. However I'm just looking at it, debdiff looks good, I'm doing a test-build and will upload it if everything is ok. Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netcat-openbsd - 1.89-3ubuntu2

---------------
netcat-openbsd (1.89-3ubuntu2) lucid; urgency=low

  * Log "Connection to ..." messages to stderr (LP: #519210)
 -- Stefan Haller <email address hidden> Tue, 09 Feb 2010 10:42:03 +0100

Changed in netcat-openbsd (Ubuntu):
status: Confirmed → Fix Released
Stefan Haller (haliner) wrote :

Yes, since lucid the package seems to be in main.

Thanks for uploading.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers