Netbook launcher stealing focus repeatedly

Bug #570659 reported by Martin Brook on 2010-04-27
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix Launcher
Medium
Didier Roche
netbook-launcher (Ubuntu)
Medium
Didier Roche
Lucid
Wishlist
Didier Roche

Bug Description

Binary package hint: netbook-launcher

netbook-launcher (1:2.1.18-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release:
    - remove duplicate home icon when download dir is set to home
      (LP: #574520)
    - fix when fallback try to respawn netbook-launcher (LP: #570659)

-----------------------
Ubuntu 10.04 release candidate.

Bug occurred following an uneventful upgrade via update-manager -d.

Login/launcher works as normal, but when I open an application, it appears briefly (2-3 seconds at most) and then disappears. The application is still running, it's as if I have just pressed 'show desktop'. If I alt+tab or select the running application's icon from the top of the screen, the window returns but again disappears after less than 3 seconds.

The running application's icon in the launcher has a spinning wheel displayed on it - I assume this is a new feature on 10.04.

If I log out and log in as a GNOME session, everything works fine.

Also, not sure if the following is related, but it seems relevant:

I went into a separate tty and entered 'ps -ax |grep netbook-launcher'. This shows two processes:
 * /usr/bin/netbook-launcher-efl
 * netbook-launcher
The former process sometimes appears twice. The latter process seems to be rapidly changing its PID; every time I run ps it has a different number.

Martin Brook (martin.brook) wrote :

Additional info I've just noticed. /var/log/messages and /var/log/syslog are full of messages like the following:

glxinfo[13954]: segfault at 0 ip 0804ad91 sp bfc7e8f0 error 4 in glxinfo[8048000+5000]

Martin Brook (martin.brook) wrote :

Doesn't occur if "Netbook edition 2D" session is selected at startup.

Didier Roche (didrocks) wrote :

Thanks for reporting this bug and help to make ubuntu better

Well, I didn't notice that even trying to the fallback but that can happen.

In fact, netbook-launcher (the 3D launcher using clutter) is testing for hardware acceleration capability and switch to the 2D launcher (efl) if you have software rendered. I guess that even in exiting it properly, gnome-session respawn it.
I have to change the algorithm then ;)

Changed in netbook-launcher (Ubuntu):
status: New → Triaged
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → Medium
ShaunS (shauns) wrote :

Hi,

I have the same issue. Tried reinstall but still the same.

Netbook-launcher steals focus away after 1 to 3 seconds.
Totally unusable.

I am using a 701 eeepc.

Thanks,
Shaun

Jason Kendall (coolacid) wrote :

Confirmed here too glxinfo segfaults if run from cmd in 2d as well.

Also seems GLX extension is missing when running other GLX tests.

Lenovo S10-2

Moritz Kobel (moritz-launchpad) wrote :

The same for me, also with a Lenovo S10-2.

Didier Roche (didrocks) wrote :

I'll try to fix that as an SRU. In the meanwhile, as the fallback is just run as you don't have compositing, you can choose the 2D session in gdm which will launch directly the fallback.

Didier Roche (didrocks) wrote :

Ok, I think I got why you encounter that issue, you should have a glx issue that make netbook-launcher-efl spawing an error and thus, not return 0.

There is two solution for that one:
- fake netbook-launcher always returning 0, whatever n-l-efl state is
- launch netbook-launcher-efl in sync and not as an async process.

The issue with the second solution is that the panel is waiting before timeouting as netbook-launcher doesn't say "I've finished my initialization".

Jason Kendall (coolacid) wrote :

I think this is only part of the problem. The fact that GLX related applications segfault still need to be addressed.

Since my S10-2 has Intel video card, and I noticed that it's trying to use the NVIDIA drivers I started with this:

http://ubuntuforums.org/showpost.php?p=9212078&postcount=10

This allowed xorg to at least start using the Intel Drivers for GLX - however, the applications still seg faulted when trying to run which lead me to this:

http://ubuntuforums.org/showpost.php?p=5409267&postcount=4

It turned out I did have two different libGL libraries:

/usr/lib/mesa
/usr/lib/fglrx

I removed /usr/lib/fglrx and modified /etc/ld.so.conf.d/GL.conf to point to the mesa drivers, however they didn't seem to really contain all the extensions required.

Thats as far as I got this past weekend.

Didier Roche (didrocks) wrote :

Right, can you open another bug against mesa for that task? basicall referencencing what you said above. What I'll do is just a workaround for your cases.

(I tried again and in my case, netbook-launcher is exiting with 0 when disabling compositing when it launched n-l-efl, hence the fact that it doesn't respawn and so, don't take any focus). So, the crash is probably where the issue is for you. I'm onlyl fixing the netbook-launcher part, hence the fact that the other bug should be opened.

Jason Kendall (coolacid) wrote :

Ok - I've solved my issues now:

After doing the above I found that fglrx package was still installed so:

sudo apt-get remove --purge fglrx

This still didn't work, so I reinstalled all the mesa drivers again:

sudo apt-get install libglw1-mesa mesa-utils libglu1-mesa libgl1-mesa-glx libgl1-mesa-dri --reinstall

forcing all my drivers back to normal for mesa

And now I can login with regular remix and run glxgears etc.

Jason Kendall (coolacid) wrote :

Sorry - didn't refresh between posts - i'll open another bug report for mesa.

Didier Roche (didrocks) on 2010-05-03
Changed in netbook-remix-launcher:
importance: Undecided → Medium
Didier Roche (didrocks) on 2010-05-03
Changed in netbook-remix-launcher:
assignee: nobody → Didier Roche (didrocks)
status: New → Fix Committed
Will (will-berriss) wrote :

I too have this bug, on the Acer Aspire One (bought in 2009) A110 Ab

So, what is the workaround exactly? (I am just using Netbook Edition 2D option at login for now)

Thanks.

Le samedi 08 mai 2010 à 19:51 +0000, Will a écrit :
> I too have this bug, on the Acer Aspire One (bought in 2009) A110 Ab
>
> So, what is the workaround exactly? (I am just using Netbook Edition 2D
> option at login for now)

If you launch only the 2D session, this is not the same bug. Here is
netbook-launcher respawning on the 3D session. You don't have it on the
2D one.

Will (will-berriss) wrote :

I didn't explain myself very well. Let me try again:

  I have the bug in 3D only.
  I am forced to use 2D because of the bug in 3D. I have no bug in 2D.
  I would like to use 3D though, as I prefer that layout.

Q. Is there a workaround that I can follow that will allow me to use 3D and not suffer the bug?

Thanks.

Didier Roche (didrocks) wrote :

Sorry, my bad.

Well, I have a fix that should work (I don't get the issue, so it can be hardly tell it really fix it). I'll try to push it soon.

Didier Roche (didrocks) wrote :
Changed in netbook-remix-launcher:
status: Fix Committed → Fix Released
Changed in netbook-launcher (Ubuntu Lucid):
status: New → Triaged
description: updated
Changed in netbook-launcher (Ubuntu Lucid):
importance: Undecided → Wishlist
assignee: nobody → Didier Roche (didrocks)

Accepted netbook-launcher into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in netbook-launcher (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed

After installing the package from lucid-proposed, running the following commands and restarting gdm, it works!

Commands [Source: http://ubuntuforums.org/showthread.php?t=1466531]
sudo apt-get purge nvidia*
sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
sudo update-alternatives --remove gl_conf /usr/lib/nvidia-current/ld.so.conf

Will (will-berriss) wrote :

Hi,

Well, it's not worked for me on my Acer Aspire One. :(

I enabled lucid-proposed in sources.list and then did an update, u and then U in aptitude
So I updated everything to proposed, which i didn't really want to do.

Anyway, I then rebooted and logged in using Netbook Edition and I still get the same issue. :(

I will now try Moritz's extra steps above and see if that helps.

HTH

Will (will-berriss) wrote :

Hallelujah, Moritz's steps fixed it! :)

All working now on the Acer Aspire One for me (I'm using it now to write this)

Thank you very much Didier, Martin and Moritz! :)

Martin Pitt (pitti) on 2010-05-11
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netbook-launcher - 1:2.1.18-0ubuntu1

---------------
netbook-launcher (1:2.1.18-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release:
    - remove duplicate home icon when download dir is set to home
      (LP: #574520)
    - fix when fallback try to respawn netbook-launcher (LP: #570659)
 -- Didier Roche <email address hidden> Sun, 09 May 2010 12:18:25 +0200

Changed in netbook-launcher (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick.

Changed in netbook-launcher (Ubuntu):
status: Triaged → Fix Released
IanW (launchpad-washuu) wrote :

This bug seems to have returned for me.

Hardware = Compaq (HP) 311c netbook with Nvidia Ion graphics & 1366x768 screen.
Software = Lucid UNE final + nvidia-current (fresh install).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers