netbook-launcher crashed with SIGSEGV in strlen()

Bug #441537 reported by Joey Stanford on 2009-10-03
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix Launcher
Undecided
Jason Smith
liblauncher
Undecided
Jason Smith
netbook-launcher (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: netbook-launcher

netbook launcher keeps crashing on the nb205. This might be a dup of bug 360999 and is directly related to bug 440947. This is the apport generated bug report

ProblemType: Crash
Architecture: i386
CheckboxSubmission: cbd66e76023689ba0d9f5f41745564b1
CheckboxSystem: b1865df84255b8716d3bcc269ff410d1
CrashCounter: 1
Date: Sat Oct 3 10:52:39 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/netbook-launcher
GConfNonDefault:
 /apps/netbook-launcher/disable_single_instance=false
 /apps/netbook-launcher/force_low_graphics=false
MachineType: TOSHIBA TOSHIBA NB205
Package: netbook-launcher 2.1.10-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=bdccab3e-7939-48a4-84bd-dde2782cfe7b ro quiet splash
ProcCmdline: netbook-launcher
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu5
 libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu7
 libdrm2 2.4.13-1ubuntu1
 xserver-xorg-video-intel 2:2.8.1-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
SegvAnalysis:
 Segfault happened at: 0x2178f1b <strlen+11>: cmp %ch,(%eax)
 PC (0x02178f1b) ok
 source "%ch" ok
 destination "(%eax)" (0x00000001) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: netbook-launcher
StacktraceTop:
 strlen () from /lib/tls/i686/cmov/libc.so.6
 g_uri_unescape_segment () from /lib/libglib-2.0.so.0
 g_uri_unescape_string () from /lib/libglib-2.0.so.0
 ?? () from /usr/lib/liblauncher-0.1.so.0
 launcher_folder_bookmarks_get_bookmarks ()
Tags: ubuntu-unr ubuntu-unr
Title: netbook-launcher crashed with SIGSEGV in strlen()
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 04/07/2009
dmi.bios.vendor: TOSHIBA
dmi.bios.version: V1.20
dmi.board.name: KAVAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 10
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvrV1.20:bd04/07/2009:svnTOSHIBA:pnTOSHIBANB205:pvrPLL20U-00P01D:rvnTOSHIBA:rnKAVAA:rvr1.00:cvnTOSHIBA:ct10:cvrN/A:
dmi.product.name: TOSHIBA NB205
dmi.product.version: PLL20U-00P01D
dmi.sys.vendor: TOSHIBA
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-11-generic

Joey Stanford (joey) wrote :

StacktraceTop:strlen () from /lib/tls/i686/cmov/libc.so.6
g_uri_unescape_segment () from /lib/libglib-2.0.so.0
g_uri_unescape_string () from /lib/libglib-2.0.so.0
load_places (bookmarks=<value optimized out>)
launcher_folder_bookmarks_get_bookmarks (

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Paul Larson (pwlars) on 2009-10-05
visibility: private → public
Neil J. Patel (njpatel) on 2009-10-05
Changed in netbook-remix-launcher:
assignee: nobody → Jason Smith (jassmith)
Jason Smith (jassmith) on 2009-10-06
Changed in liblauncher:
assignee: nobody → Jason Smith (jassmith)
status: New → Fix Committed
Changed in netbook-remix-launcher:
status: New → Fix Committed
David Barth (dbarth) wrote :

Fix available.

Changed in netbook-launcher (Ubuntu):
assignee: nobody → Loïc Minier (lool)
status: New → In Progress
Loïc Minier (lool) wrote :

Hey, I see this bug has both a liblauncher a netbook-launcher task, but I could only find the corresponding netbook-launcher commit. Could someone please confirm that I want lp:netbook-remix-launcher r457 and that I don't need anything else?

Thanks!

Loïc Minier (lool) wrote :

Could you please attach your .gtk-bookmarks?

Changed in netbook-launcher (Ubuntu):
assignee: Loïc Minier (lool) → nobody
LaserJock (laserjock) wrote :

Joey, Jason, Loïc : did this get fixed or no? I'm trying to clean up some of the older UNR bugs.

Download full text (3.5 KiB)

I don't have the same software installed to reproduce it any longer.
Also we've bumbed the rev there from the version that was crashing. I
say archive this bug unless there are any objections.

On Fri, Feb 26, 2010 at 09:52, LaserJock <email address hidden> wrote:
> Joey, Jason, Loïc : did this get fixed or no? I'm trying to clean up
> some of the older UNR bugs.
>
> --
> netbook-launcher crashed with SIGSEGV in strlen()
> https://bugs.launchpad.net/bugs/441537
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Liblauncher: Fix Committed
> Status in Ubuntu Netbook Remix Launcher: Fix Committed
> Status in “netbook-launcher” package in Ubuntu: In Progress
>
> Bug description:
> Binary package hint: netbook-launcher
>
> netbook launcher keeps crashing on the nb205. This might be a dup of bug 360999 and is directly related to bug 440947. This is the apport generated bug report
>
> ProblemType: Crash
> Architecture: i386
> CheckboxSubmission: cbd66e76023689ba0d9f5f41745564b1
> CheckboxSystem: b1865df84255b8716d3bcc269ff410d1
> CrashCounter: 1
> Date: Sat Oct  3 10:52:39 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/netbook-launcher
> GConfNonDefault:
>  /apps/netbook-launcher/disable_single_instance=false
>  /apps/netbook-launcher/force_low_graphics=false
> MachineType: TOSHIBA TOSHIBA NB205
> Package: netbook-launcher 2.1.10-0ubuntu1
> ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-11-generic root=UUID=bdccab3e-7939-48a4-84bd-dde2782cfe7b ro quiet splash
> ProcCmdline: netbook-launcher
> ProcEnviron:
>  LANG=en_US.UTF-8
>  SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
> RelatedPackageVersions:
>  xserver-xorg 1:7.4+3ubuntu5
>  libgl1-mesa-glx 7.6.0~git20090817.7c422387-0ubuntu7
>  libdrm2 2.4.13-1ubuntu1
>  xserver-xorg-video-intel 2:2.8.1-1ubuntu2
>  xserver-xorg-video-ati 1:6.12.99+git20090825.fc74e119-0ubuntu2
> SegvAnalysis:
>  Segfault happened at: 0x2178f1b <strlen+11>:   cmp    %ch,(%eax)
>  PC (0x02178f1b) ok
>  source "%ch" ok
>  destination "(%eax)" (0x00000001) not located in a known VMA region (needed writable region)!
> SegvReason: writing NULL VMA
> Signal: 11
> SourcePackage: netbook-launcher
> StacktraceTop:
>  strlen () from /lib/tls/i686/cmov/libc.so.6
>  g_uri_unescape_segment () from /lib/libglib-2.0.so.0
>  g_uri_unescape_string () from /lib/libglib-2.0.so.0
>  ?? () from /usr/lib/liblauncher-0.1.so.0
>  launcher_folder_bookmarks_get_bookmarks ()
> Tags:  ubuntu-unr ubuntu-unr
> Title: netbook-launcher crashed with SIGSEGV in strlen()
> Uname: Linux 2.6.31-11-generic i686
> UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video
> XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
> dmi.bios.date: 04/07/2009
> dmi.bios.vendor: TOSHIBA
> dmi.bios.version: V1.20
> dmi.board.name: KAVAA
> dmi.board.vendor: TOSHIBA
> dmi.board.version: 1.00
> dmi.chassis.asset.tag: *
> dmi.chassis.type: 10
> dmi.chassis.vendor: TOSHIBA
> dmi.chassis.version: N/A
> dmi.modalias: dmi:bvnTOSHIBA:bvrV1.20:bd04/07/2009:svnTOSHIBA:pnTOSHIBANB205:pvrPLL20U-00P01D:rvnTOSHIBA:rnKAVAA:rvr1.00:cvnTOSHI...

Read more...

Didier Roche (didrocks) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in netbook-launcher (Ubuntu):
status: In Progress → Fix Released
Changed in liblauncher:
status: Fix Committed → Fix Released
Changed in netbook-remix-launcher:
status: Fix Committed → Fix Released
To post a comment you must log in.