netbook-launcher crashed with SIGSEGV in IA__g_cclosure_marshal_VOID__OBJECT()

Bug #411530 reported by MikeK on 2009-08-10
462
This bug affects 80 people
Affects Status Importance Assigned to Milestone
CluTK
Critical
Neil J. Patel
Ubuntu Netbook Remix Launcher
Undecided
Unassigned
clutk (Ubuntu)
Critical
Unassigned
netbook-launcher (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: netbook-launcher

when attempting to switch desktop mode from classic desktop to Ubuntu Netbook Desktop... Seems to be in a loop "Starting File Manager".

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Mon Aug 10 12:26:49 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/netbook-launcher
Package: netbook-launcher 2.1.1-0ubuntu1
ProcCmdline: netbook-launcher
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
SegvAnalysis:
 Segfault happened at: 0x28473f: testb $0x1,0x39(%edx)
 PC (0x0028473f) ok
 source "$0x1" ok
 destination "0x39(%edx)" (0xaaaaaae3) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: netbook-launcher
StacktraceTop:
 ?? () from /usr/lib/libclutter-glx-1.0.so.0
 IA__g_cclosure_marshal_VOID__OBJECT (closure=0x917fcb0,
 g_type_class_meta_marshal (closure=0x917fcb0,
 IA__g_closure_invoke (closure=0x917fcb0, return_value=0x0,
 signal_emit_unlocked_R (node=<value optimized out>,
Title: netbook-launcher crashed with SIGSEGV in IA__g_cclosure_marshal_VOID__OBJECT()
Uname: Linux 2.6.31-5-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

MikeK (michael-j-kirschner) wrote :

StacktraceTop:?? () from /usr/lib/libclutter-glx-1.0.so.0
IA__g_cclosure_marshal_VOID__OBJECT (closure=0x917fcb0,
g_type_class_meta_marshal (closure=0x917fcb0,
IA__g_closure_invoke (closure=0x917fcb0, return_value=0x0,
signal_emit_unlocked_R (node=<value optimized out>,

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Neil J. Patel (njpatel) wrote :

Marking as invalid as the issue is in Clutk

Changed in netbook-remix-launcher:
status: New → Invalid
Changed in netbook-launcher (Ubuntu):
status: New → Invalid
Neil J. Patel (njpatel) wrote :

Fix the bug and made a 0.2.2 release of Clutk (www.launchpad.net/clutk/+downloads)

Changed in clutk:
assignee: nobody → Neil J. Patel (njpatel)
importance: Undecided → Critical
milestone: none → 0.2.2
status: New → Fix Released
Neil J. Patel (njpatel) wrote :

We need to update Clutk in Karmic to 0.2.2 to fix this.

Changed in clutk (Ubuntu):
importance: Undecided → Critical
status: New → Confirmed
Paul Larson (pwlars) on 2009-08-14
visibility: private → public
James Schriver (dashua) wrote :

I just rebuilt and installed with clutk 0.2.2 on a Dell Vostro A90 (Mini 9) and still receiving same crash and error while changing gtk themes consistently.

James Schriver (dashua) wrote :

Pardon my laziness. I rebuilt netbook launcer from source with the updated clutk and it's looking good. great work in the new UI. It looks really professional. There are many positive comments from the community to the screenshots I posted on the forums.

don hardaway (don-hardaway) wrote :

So when can we expect the new version to be in the cdimage and what version of netbook-launcher will indicate that it is in there?

Neil J. Patel (njpatel) wrote :

@dashua: thank you :)

@don: netbook-launcher was fine, your looking for an update to Clutk. The version that fixes the problem is 0.2.2. Hopefully it's updated first thing Monday morning (you'll be notifed through this bug when it is).

don hardaway (don-hardaway) wrote :

I looked in the manifest of todays cdimage to find clutk. Clutk is not listed as a file in the manifest. Is it contained within some other file?

On Sat, 2009-08-15 at 11:44 +0000, don hardaway wrote:
> I looked in the manifest of todays cdimage to find clutk. Clutk is not
> listed as a file in the manifest. Is it contained within some other
> file?
>
The clutk package provides libclutk-0.2-0.so, which is what the launcher
uses for it's display widgets. Just checking, the packages name is
libclutk-0.2-0, so that's what your looking for.

-- Neil

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clutk - 0.2.2-0ubuntu1

---------------
clutk (0.2.2-0ubuntu1) karmic; urgency=low

  * New upstream release.
    - Fixes crasher. (LP: #411530)

 -- Steve Kowalik <email address hidden> Mon, 17 Aug 2009 14:34:26 +1000

Changed in clutk (Ubuntu):
status: Confirmed → Fix Released

I installed this package and rebooted. Then when i was exiting
synaptic i got the brown screen of death again!

On Sat, Aug 15, 2009 at 6:57 AM, Neil J. Patel<email address hidden> wrote:
> On Sat, 2009-08-15 at 11:44 +0000, don hardaway wrote:
>> I looked in the manifest of todays cdimage to find clutk.  Clutk is not
>> listed as a file in the manifest.  Is it contained within some other
>> file?
>>
> The clutk package provides libclutk-0.2-0.so, which is what the launcher
> uses for it's display widgets. Just checking, the packages name is
> libclutk-0.2-0, so that's what your looking for.
>
> -- Neil
>
> --
> netbook-launcher crashed with SIGSEGV in IA__g_cclosure_marshal_VOID__OBJECT()
> https://bugs.launchpad.net/bugs/411530
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

don hardaway (don-hardaway) wrote :

I installed the attached file and rebooted. Then i launched synaptic and when exiting it i got the brown screen of death again!

don hardaway (don-hardaway) wrote :

The netbook-launcher crash i get now says it is an error 4 in libclutter-glx-1.0.so

netbook-launcher crashes so much (and over so many updated versions with "fixes") that it's totally unuseable. It crashes just by clicking on any icon, or just rebooting and waiting a few seconds or minutes. Hopefully fixed before release.

Neil J. Patel (njpatel) wrote :

The previous bug was fixed, this is another bug which is caused by the same issue as the previous one, just in another part of the code :) Apart from being unwell the past few days, I can assure you that I'm working on this and it'll be fixed way before release, hopefully today/over the weekend for an early-next-week release.

We only recently upgraded to Clutter-1.0 and, even though we were tracking the 0.9.x series, there have been some changes which are causing these crashes. However, these are all 'good things' as it is showing bugs in the code which may not have been seen otherwise.

Neil J. Patel (njpatel) wrote :

I think the libclutk deb (karmic) attached will fix the majority of these crashes. Would appreciate testing (just download and double-click to install).

Changed in clutk:
status: Fix Released → In Progress
Neil J. Patel (njpatel) on 2009-08-21
Changed in clutk:
milestone: 0.2.2 → 0.2.4
James Schriver (dashua) wrote :

Installed above package and receiving the same crash. New apport info uploaded.

Neil J. Patel (njpatel) wrote :

@dashua: Sorry I didn't mention this before, but just wanted to check, did you restart after installing?

don hardaway (don-hardaway) wrote :

I can not test your package. After doing an update the other day (i think it updated my Nvidia driver) every time i boot it just goes to a command line login---no desktop. Not sure how to fix this--maybe remove the Nvidia driver? If I can some how get the desktop to come up I can test the package.

Roman Brodylo (roman-brodylo) wrote :

I downloaded your pabove package but got this error from GDebi:
Error: Breaks existing package 'libclutk-dev' dependency libclutk-0.2-0 (= 0.2.2-0ubuntu1)

Can I "force" it somehow?

Karmic UNR on ASUS Eee PC 1000

unggnu (unggnu) wrote :

Just remove the libclutk-dev package. After that the installation should work I suppose.

xulio77 (juliojgd) wrote :

I've just downloaded and installed clutk-0.2.2+bzr88 . I rebooted.
Netbook-launcher dies like before. Worse, because now it's not giving option to "Report" or "Restart app" It simply dies, no info.
I'l try to collect crash report and upload it.

xulio77 (juliojgd) wrote :

I rebooted twice and now the patch is working.
netbook-launcher has not dead after a few hours of work.
I can't figure out why first reboot didn't work...

Roman Brodylo (roman-brodylo) wrote :

I can confirm that the Netbook Launcher now runs stable after installing your above libclutk.

Neil J. Patel (njpatel) wrote :

Thanks everyone! I've released clutk-0.2.4 which has these fixes in it. Hopefully should be in Karmic ASAP.

If we come across any more crashers of this type, then I believe the bugs will be in netbook-launcher itself rather than Clutk, so I'm marking fix-released on Clutk. Anyway, one down many more to go :)

Changed in clutk:
status: In Progress → Fix Released
Steve Kowalik (stevenk) on 2009-08-25
Changed in clutk (Ubuntu):
status: Fix Released → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package clutk - 0.2.4-0ubuntu1

---------------
clutk (0.2.4-0ubuntu1) karmic; urgency=low

  * New upstream release
    - Really fixes crasher. (LP: #411530)

 -- Steve Kowalik <email address hidden> Tue, 25 Aug 2009 14:16:35 +1000

Changed in clutk (Ubuntu):
status: Confirmed → Fix Released
sorokinlinux (sorokinlinux) wrote :

affected after startup gnome

Linux 2.6.31-6-generic #26-Ubuntu SMP Fri Aug 21 17:48:16 UTC 2009 i686 GNU/Linux
9.10 Alpha 4

Steve Kowalik (stevenk) wrote :

It wasn't fixed in Alpha 4, please update to the latest packages.

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers