netbook-launcher crashed with signal 5 in g_main_context_dispatch()

Bug #395468 reported by Alessandro Ranaldi on 2009-07-04
228
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Ubuntu Netbook Remix Launcher
Critical
Neil J. Patel
netbook-launcher (Ubuntu)
High
Neil J. Patel
Karmic
High
Neil J. Patel

Bug Description

Binary package hint: netbook-launcher

This was an automatic crash report, I didn't expirience something wrong.

ProblemType: Crash
Architecture: i386
Date: Sat Jul 4 12:16:36 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/netbook-launcher
Package: netbook-launcher 1.6.20-0ubuntu2
ProcCmdline: netbook-launcher
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-1.14-generic
Signal: 5
SourcePackage: netbook-launcher
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/libglib-2.0.so.0
 g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
 ?? () from /usr/lib/libglib-2.0.so.0
 g_main_loop_run () from /usr/lib/libglib-2.0.so.0
Tags: ubuntu-unr
Title: netbook-launcher crashed with signal 5 in g_main_context_dispatch()
Uname: Linux 2.6.31-1-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Alessandro Ranaldi (ciaolo) wrote :

StacktraceTop:gdm_run_queue (dummy=0x0) at gdm-queue.c:255
g_idle_dispatch (source=0xa454058, callback=0,
IA__g_main_context_dispatch (context=0x9cc8a88)
g_main_context_iterate (context=0x9cc8a88,
IA__g_main_loop_run (loop=0xa3780f0)

Changed in netbook-launcher (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Paul Larson (pwlars) wrote :

This is hitting a lot of people on UNR right now, and prevents successful shutdown. It is easy to reproduce just by doing a shutdown from livecd even.

visibility: private → public
Changed in netbook-launcher (Ubuntu):
importance: Medium → High
status: New → Triaged
Loïc Minier (lool) wrote :

Does this happen with anything else than shutdown?

Loïc Minier (lool) wrote :

It's likely this is due to the new gdm

Paul Larson (pwlars) wrote :

So far, just seem to be getting it on shutdown

svalovic (svalovic) wrote :

I have get this message right after loging in, not at the shutdown.

Carlos Costa (carloscosta) wrote :

I have the same problem, after to click at Switch User button.

I also experience the crash soon after logging in while doing nothing particular. With no apparent problems seen. Just the apport message.

daniel (bocardo+u) wrote :

add another crash on shutdown from the livecd (running on a dvdrw)

Martin Pitt (pitti) on 2009-08-07
Changed in netbook-launcher (Ubuntu Karmic):
assignee: nobody → Canonical Mobile Team (canonical-mobile)
MikeK (michael-j-kirschner) wrote :

at shutdown...

Jamie (jtroybailey) wrote :

i experience this when minimizing programs and shutting down

Steve Kowalik (stevenk) wrote :

The netbook-launcher in Karmic has been updated to a new version. Can people please try it and comment here whether or not it fixes the problem for them?

I have tried it yesterday and is still there. I'll try to download the
installer again later tonight

On Mon, 2009-08-10 at 10:00 +0000, Steve Kowalik wrote:
> The netbook-launcher in Karmic has been updated to a new version. Can
> people please try it and comment here whether or not it fixes the
> problem for them?
>

Steve Kowalik (stevenk) on 2009-08-11
Changed in netbook-launcher (Ubuntu Karmic):
assignee: Canonical Mobile Team (canonical-mobile) → Neil J. Patel (njpatel)
Neil J. Patel (njpatel) wrote :

I've switched the launcher over to using the SessionManager object on DBus to be signaled when the session is about to be quit. We need this to shutdown cleanly. The bug was caused by the GnomeClient code in libgnomeui crashing out during exit.

Changed in netbook-remix-launcher:
status: New → Fix Committed
importance: Undecided → Critical
assignee: nobody → Neil J. Patel (njpatel)
milestone: none → 2.0.4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package netbook-launcher - 2.1.1-0ubuntu2

---------------
netbook-launcher (2.1.1-0ubuntu2) karmic; urgency=low

  * Rename patch gio-new-api.patch to 60_gio-new-api.patch to make sure
    patches are applied in the intended order.
  * New patch, 61_r417-use-gnome-session-for-session-end-signal, from upstream
    r417; use gnome-session's SessionManager signal instead of GnomeClient;
    fixes crasher and a warning on exit; LP: #395468.
  * New patch, 62_r418-use-system-logout-dialog, from upstream r418; use
    system logout dialog instead of builtin one (until switching to f-u-s-a);
    fixes.

 -- Loic Minier <email address hidden> Thu, 13 Aug 2009 20:03:36 +0200

Changed in netbook-launcher (Ubuntu Karmic):
status: Triaged → Fix Released
Neil J. Patel (njpatel) on 2009-08-28
Changed in netbook-remix-launcher:
status: Fix Committed → Fix Released
tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers