Ubuntu

Please remove netbeans package from Ubuntu Oneiric universe repo

Reported by Yulia Novozhilova on 2011-08-08
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
netbeans (Ubuntu)
Undecided
Unassigned

Bug Description

Could you please remove both source netbeans package and all binary packages from Ubuntu Oneiric universe repository.
The current version of NetBeans IDE in the packages is out of date and there is no enough resources to support and update the packages. So it makes using NetBeans IDE buggy and unreliable. The users are strongly recommended to download latest NetBeans versions from netbeans.org.

Changed in netbeans (Ubuntu):
milestone: none → ubuntu-11.10
Matthias Klose (doko) wrote :

and FTBFS, see bug #755931

2011-09-08 12:51:13 INFO Removing candidates:
2011-09-08 12:51:13 INFO netbeans 6.9-0ubuntu2 in oneiric
2011-09-08 12:51:13 INFO libnb-apisupport2-java 6.9-0ubuntu2 in oneiric amd64
2011-09-08 12:51:13 INFO libnb-apisupport2-java 6.9-0ubuntu2 in oneiric armel
2011-09-08 12:51:13 INFO libnb-apisupport2-java 6.9-0ubuntu2 in oneiric i386
2011-09-08 12:51:13 INFO libnb-apisupport2-java 6.9-0ubuntu2 in oneiric powerpc
2011-09-08 12:51:13 INFO libnb-ide13-java 6.9-0ubuntu2 in oneiric amd64
2011-09-08 12:51:13 INFO libnb-ide13-java 6.9-0ubuntu2 in oneiric armel
2011-09-08 12:51:13 INFO libnb-ide13-java 6.9-0ubuntu2 in oneiric i386
2011-09-08 12:51:13 INFO libnb-ide13-java 6.9-0ubuntu2 in oneiric powerpc
2011-09-08 12:51:13 INFO libnb-java4-java 6.9-0ubuntu2 in oneiric amd64
2011-09-08 12:51:13 INFO libnb-java4-java 6.9-0ubuntu2 in oneiric armel
2011-09-08 12:51:13 INFO libnb-java4-java 6.9-0ubuntu2 in oneiric i386
2011-09-08 12:51:13 INFO libnb-java4-java 6.9-0ubuntu2 in oneiric powerpc
2011-09-08 12:51:13 INFO netbeans 6.9-0ubuntu2 in oneiric amd64
2011-09-08 12:51:13 INFO netbeans 6.9-0ubuntu2 in oneiric armel
2011-09-08 12:51:13 INFO netbeans 6.9-0ubuntu2 in oneiric i386
2011-09-08 12:51:13 INFO netbeans 6.9-0ubuntu2 in oneiric powerpc
2011-09-08 12:51:13 INFO Removed-by: Matthias Klose
2011-09-08 12:51:13 INFO Comment: FTBFS, requested removal, LP: #822753
2011-09-08 12:51:13 INFO 17 packages successfully removed.

Changed in netbeans (Ubuntu):
status: New → Fix Released

there's a lot of people that use netbeans on a regular basis, moving it out of the repositories has just messed with me and most of my classmates, we upgraded and can't install netbeans now, is this a permanent change?

Lighton Phiri (lighton-phiri) wrote :

A very shocking move indeed; why couldn't the the packages be updated with the latest version? In any case, at least I now know why I couldn't install Netbeans after upgrading to 11.10.

Vladimir Y (justvovus) wrote :

Agree with previous two speakers. I'm speechless! "This bug affects 1 person. " (and this is not bug) and you removing next day, but bugs that affect hundreds you are ignoring. Just one person what to remove and other need to have inconvenience after that.

Vladimir Y (justvovus) wrote :

Sorry, I didn't know that Yulia is maintainer of this package. So if there is no other way...((

adisharoon (alecdisharoon) wrote :

I disagree with this decision. If there are not enough resources to support and update the packages, then resources (whatever that may mean) should be re-allocated. It's difficult for me to understand how the resources exist to release a new major version of Ubuntu with new features every six months, but not to package an up-to-date Netbeans.

I'm sorry. NetBeans Team had to take this decision. It doesn't have enough resources to update and test netbeans packages anymore. Please use Linux installer from http://netbeans.org/downloads/index.html. It installs full version of the NetBeans IDE that lacks for many bugs that packages had.

Stefano Rivera (stefanor) wrote :

Yulia: Shouldn't you have blacklisted it? It returned in precise.

Stefano Rivera (stefanor) wrote :

Oh no, It's building again, I take that back.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers