Ubuntu

Copy broken in Eclipse when using glipper/klipper (requires 2x Ctrl+C to work)

Reported by Leon van der Ree on 2008-04-17
92
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Eclipse
Fix Released
Unknown
KDE Base
Fix Released
Medium
Netbeans Core
Fix Released
Low
eclipse (Ubuntu)
Undecided
Unassigned
glipper (Ubuntu)
Undecided
Unassigned
kdebase-workspace (Ubuntu)
Low
Unassigned
netbeans (Ubuntu)
Undecided
Unassigned
parcellite (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: glipper

I have difficulties with copying in Eclipse (and probably other applications as well, but use eclipse the most) when running glipper.

I often have to copy (press Ctrl+C) twice in order to real copy something and I don't think it is due to my keyboard (since the c works fine and ctrl+v always pastes (but sometimes something from my previous copy-action)

This is in Hardy with latest updates

Been using NetBeans for a year or so now and I love it.

But one thing that is sorely missing (or seems to be) is support for multiple
clipboards in the editor. I would like to be able to press CONTROL+SHIFT+V to
select which of the last 10 or so strings I've cut/copied and paste then it.
Currently NB supports pasting the last string. MS Word and most popular
programming editors I've used support multiple clipboards.

Moving to the 'other' subcomponent.

Leon van der Ree (lvanderree) wrote :

I can add to this that CTRL+X does cut, but doesn't paste, until I restore it (CTRL+Z) and again cut it.

So definitely not my keyboard but a problem with glipper.

Micke Karlsson (mickek) wrote :

I have the exact same behaviour in Hardy too. I also have experienced the bug in Eclipse only.

(I have installed all the latest updates)

Micke Karlsson (mickek) wrote :

I got the same error running klipper (KDE version of glipper). The Eclipse version I'm running now is exactly the same as before I upgraded to Hardy (I run it from a network share, i.e. not installed from the Ubuntu repository). I'm using Eclipse 3.3.2.

Leon van der Ree (lvanderree) wrote :

I am also using Eclipse 3.3.2, which I installed myself, not from the repository.

The Eclipse version from the repository is too old for the pdt-tools I use.

Dmitriy Geels (dmig) wrote :

I confirm this bug with Eclipse PDT versions 1.0.2 Release Build and 1.0.3 Stable Build.

Dmitriy Geels (dmig) wrote :

Good solution would be to rollback glipper to version 0.9x, which was in Gutsy.

Changed in glipper:
status: New → Confirmed
Michael Nagel (nailor) wrote :

i don't know if its related but:

glipper does not seem to work with netbeans.

testcase:
open gedit
type foo
copy foo to clipboard
type bar
copy bar to clipboard
paste (bar is inserted)
hit ctrl-alt-c or click the glipper icon
select foo (it gets bolded then)
paste (foo is inserted)

now open netbeans and do the same
it not the same, in the last step bar is inserted once again. glipper bolds foo, but hitting ctrl-c inserts the wrong value (bar)!

wimm (wim-machiels) wrote :

I can confirm this too. Glipper in Gutsy worked, but fails to copy the correct values in Hardy. I also use glipper the most with eclipse but I suspect it to fail in other apps as well. Sometimes it works, sometimes it doesn 't. Pretty annoying bug, since I really got used to the clipboard manager.

Did anyone found a workaround yet?

Micke Karlsson (mickek) wrote :

A workaround I have found very helpful is uninstalling Glipper and installing Parcellite. It is almost identical and works great!

http://parcellite.sourceforge.net

Dmitriy Geels (dmig) wrote :

Parcellite package is included in Intrepid repositories.
It is not freshest - 0.7, but can also be used.

kenden (kenden) wrote :

Thanks for the workaround!
Ctrl-C problems are gone in Eclipse after installing parcellite (from the intrepid repo) and uninstalling glipper.

Dmitriy Geels (dmig) wrote :

look at http://getdeb.net periodically, newer version packages of parcellite appear there.

I second this. Most editors and IDEs now support multiple clipboards and many developers rely on that feature for
productivity. This is one of the major blocking features for NetBeans over IDEs like IntelliJ.

Michael Nagel (nailor) wrote :

re-assigning to netbeans as this happens with parcellite clipboard manager too.

Michael Nagel (nailor) on 2009-03-02
Changed in eclipse:
status: New → Confirmed
wolfmanjm (morris-wolfman) wrote :

FWIW I had this problem with Ganymede and klipper especially with mouse selections. The fix for me was to turn OFF the klipper setting prevent empty clipboard. Now copy/paste with mouse works fine.

Felix Geyer (debfx) on 2009-07-28
summary: - copy broken in glipper (requires 2x Ctrl+C to work) (Hardy)
+ Copy broken in Eclipse when using glipper/klipper (requires 2x Ctrl+C to
+ work)
Changed in kdebase:
status: Unknown → Confirmed
Changed in eclipse:
status: Unknown → Confirmed
Felix Geyer (debfx) on 2009-07-28
Changed in kdebase-workspace (Ubuntu):
status: New → Confirmed
Changed in kdebase-workspace (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in eclipse (Ubuntu):
status: Confirmed → Triaged
Bazilio (bazilio-recast1) wrote :

I have same problem in eclipse with mouse selection.
And I confirm that turning off setting "prevent empty clipboard" in klipper solves the problem.
Using kubuntu jaunty, eclipse PDT.

I also think multiple clipboards are important. Unfortunately clipboard recorder from http://www.lw-works.com/ does not work in Netbeans. Netbeans is the only program I know where clipboard recorder is not working!

Jonathan Thomas (echidnaman) wrote :

Things should be fixed on the KDE side of things in KDE 4.4/Kubuntu 10.04.

Changed in kdebase-workspace (Ubuntu):
status: Triaged → Fix Released
crazy ivan (x-floc) wrote :

confirm problem : with ganymede and klipper 0.9.7
confirm workaround : turning off setting "prevent empty clipboard"
looking forward to new klipper backport or ubuntu10..

Changed in kdebase:
status: Confirmed → Fix Released
Changed in eclipse:
status: Confirmed → Fix Released
Changed in kdebase:
importance: Unknown → Medium

(In reply to comment #3)
> I also think multiple clipboards are important. Unfortunately clipboard
> recorder from http://www.lw-works.com/ does not work in Netbeans. Netbeans is
> the only program I know where clipboard recorder is not working!

+1 !!!
Any explanation on this ?
Maybe should be filled as a separate bug ?

Laszlo Pandy (laszlok) on 2011-04-21
Changed in glipper (Ubuntu):
status: New → Fix Released
Erick Wessels (erickpardus) wrote :

per dolorem ad veritatem

ERICK PARDUS

http://about.me/Erickpardus/

Also Parcellite 1.0.2rc5 does not work with netbeans 7.0.1 on Ubuntu 11.10
Please let me know if I should fill a separate bug for it and clipboard recorder not working on windows. Any explanation ?

Very glad this is being worked on !
Thank you very much !
really this clipboard recorder and similar tools not working was a major PITA

Why would this happen by the way ?

allan999 (allan-laal) wrote :

issue persists in Netbeans 7.2 Beta (build 201203120400) and Parcellite 0.9.2

issue persists in Netbeans 7.2 Beta (build 201203120400) and Parcellite 0.9.2

The lack of this feature costs me precious seconds every day. Please include it in 7.2 ! :)

Changed in netbeans:
importance: Unknown → Critical
status: Unknown → Confirmed
Maarten Bezemer (veger) wrote :

I use the Eclipse from the repositories and cannot reproduce this issue (anymore). The eclipse bugs report that indicated this issue is fixed is much older than the provided Eclispe in Ubuntu as well.
So I have marked eclipse (ubuntu) as fix released.

Changed in eclipse (Ubuntu):
status: Triaged → Fix Released

*** Bug 61083 has been marked as a duplicate of this bug. ***

*** Bug 204223 has been marked as a duplicate of this bug. ***

*** Bug 196829 has been marked as a duplicate of this bug. ***

Just to note that the problem is that different programs that manipulate the clipboard fail with NB - not that NB should provide such functionality

http://hg.netbeans.org/jet-main/rev/c3423559f4df

Shortcut is for now ctrl+alt+v.

<email address hidden>: http://www.lw-works.com/ page is broken and Parcellite has latest version from last year. I would file a bug in their report system.

Changed in netbeans:
status: Confirmed → Fix Released

v. Build 20120828-074acc2249ea

Changed in netbeans:
importance: Critical → Low
Thomas Hotz (thotz) on 2013-05-19
Changed in parcellite (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.