netbeans 6.0.1 assertion failure in ubuntu 8.04 alpha 6

Bug #199661 reported by tomd123 on 2008-03-07
2
Affects Status Importance Assigned to Milestone
netbeans (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: netbeans

netbeans 6.0.1-0ubuntu1
I used the synaptic package manager to install the netbeans package and everything seemed normal.
Ran this in the console since the menu link doesn't supply any information on why it doesn't run.
netbeans
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb5500767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb55008b1]
#2 /usr/lib/libX11.so.6(_XReply+0xfd) [0xb43cd29d]
#3 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb44c98ce]
#4 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb44a6067]
#5 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so [0xb44a6318]
#6 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/xawt/libmawt.so(Java_sun_awt_X11GraphicsEnvironment_initDisplay+0x2f) [0xb44a661f]
#7 [0xb5b4aecd]
#8 [0xb5b43edd]
#9 [0xb5b43edd]
#10 [0xb5b41249]
#11 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c40d]
#12 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x6310378]
#13 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c2a0]
#14 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so(JVM_DoPrivileged+0x363) [0x6272153]
#15 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/libjava.so(Java_java_security_AccessController_doPrivileged__Ljava_security_PrivilegedAction_2+0x3d) [0xb7b5c96d]
#16 [0xb5b4aecd]
#17 [0xb5b43d77]
#18 [0xb5b41249]
#19 /usr/lib/jvm/java-6-sun-1.6.0.04/jre/lib/i386/client/libjvm.so [0x621c40d]
java: xcb_xlib.c:82: xcb_xlib_unlock: Assertion `c->xlib.lock' failed.
/usr/share/netbeans/6.0.1/bin/../platform7/lib/nbexec: line 440: 21365 Aborted (core dumped) "/usr/lib/jvm/java-6-sun/bin/java" -Djdk.home="/usr/lib/jvm/java-6-sun" -classpath "/usr/share/netbeans/6.0.1/platform7/lib/boot.jar:/usr/share/netbeans/6.0.1/platform7/lib/org-openide-modules.jar:/usr/share/netbeans/6.0.1/platform7/lib/org-openide-util.jar:/usr/lib/jvm/java-6-sun/lib/dt.jar:/usr/lib/jvm/java-6-sun/lib/tools.jar" -Dnetbeans.system_http_proxy="DIRECT" -Dnetbeans.system_http_non_proxy_hosts="" -Dnetbeans.dirs="/usr/share/netbeans/6.0.1/nb6.0:/usr/share/netbeans/6.0.1/ide8:/usr/share/netbeans/6.0.1/java1:/usr/share/netbeans/6.0.1/apisupport1:/usr/share/netbeans/6.0.1/harness:" -Dnetbeans.home="/usr/share/netbeans/6.0.1/platform7" '-Dnetbeans.importclass=org.netbeans.upgrade.AutoUpgrade' '-Dnetbeans.accept_license_class=org.netbeans.license.AcceptLicense' '-Xmx363m' '-client' '-Xss2m' '-Xms32m' '-XX:PermSize=32m' '-XX:MaxPermSize=200m' '-Xverify:none' '-Dapple.laf.useScreenMenuBar=true' org.netbeans.Main --userdir "/home/tom/.netbeans/6.0" "--branding" "nb"

John Leach (johnleach) wrote :

Latest hardy updates fixed this for me. Anyone else?

Changed in netbeans:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers