NetBeans crashes on startup

Bug #1776724 reported by ais523 on 2018-06-13
This bug report is a duplicate of:  Bug #1760907: Netbeans 8.1 crash in splash screen. Edit Remove
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
netbeans (Ubuntu)
Undecided
Unassigned

Bug Description

When I load NetBeans (whether via the GUI or from a command line), the splash screen appears and loads as far as "Turning on modules..." (usually; very occasionally it gets stuck at "Reading module storage..." instead). The splash screen then freezes for approximately 11-12 seconds and then the entire program exits. Expected behaviour is that when I load NetBeans, the loading process finishes and then the application's main interface opens, without the process exiting.

I have two JREs installed, /usr/lib/jvm/java-8-openjdk-amd64/jre/bin/java and /usr/lib/jvm/java-11-openjdk-amd64/bin/java. The same behaviour of the splash screen occurs regardless of which JRE is pointed at via "/usr/bin/java".

I also have two versions of javac installed, /usr/lib/jvm/java-8-openjdk-amd64/bin/javac and /usr/lib/jvm/java-11-openjdk-amd64/bin/javac. The choice of javac that "/usr/bin/javac" points to does influence the results. I suspect that the difference is immaterial but am mentioning it just in case:

* When using the Java 8 version of javac, no message is printed when NetBeans exits this way; it simply exits to the command prompt (or the desktop if loaded via the GUI) without printing anything. The exit status is 2.
* When using the "java-11-openjdk-amd64" version of javac (which claims to be "javac 10.0.1" in its version info; thus I'm not clear on whether this is Java 10 or Java 11), the following messages are printed on standard output/error, before it exits with exit status 2 (I suspect these are unrelated to the crash, but including them just in case):
{{{
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.netbeans.ProxyURLStreamHandlerFactory (file:/usr/share/netbeans/platform18/lib/boot.jar) to field java.net.URL.handler
WARNING: Please consider reporting this to the maintainers of org.netbeans.ProxyURLStreamHandlerFactory
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
}}}

In an attempt to get more information about where the crash is occurring, I ran NetBeans with -J-verbose (thus causing the JVM to output which classes are loaded, perhaps indicating how far it got with initialisation before the crash); the resulting file is attached as netbeans-J-verbose.txt. Under this configuration, it consistently crashes almost immediately after loading sun.awt.X11.XSystemTrayPeer. (I've been testing with the Java 8 versions of java and javac.) This might or might not be a useful lead.

Are there any tests that might give more useful information than the limited information I have here?

This behaviour started immediately after an upgrade from Artful to Bionic. I'm running Cinnamon as my desktop.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: netbeans 8.1+dfsg3-4
ProcVersionSignature: Ubuntu 4.15.0-23.25-generic 4.15.18
Uname: Linux 4.15.0-23-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: X-Cinnamon
Date: Wed Jun 13 17:57:19 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2017-01-31 (497 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
PackageArchitecture: all
SourcePackage: netbeans
UpgradeStatus: Upgraded to bionic on 2018-06-13 (0 days ago)

ais523 (ais523) wrote :
ais523 (ais523) wrote :

The mention of the system tray made me think that it's possible the desktop environment was relevant, but I just tested and it isn't; I get the same behaviour on all of Cinnamon, MATE, and Ubuntu's version of Gnome 3.

ais523 (ais523) wrote :

I was wondering if there was something in my dotfiles which was causing the issue, so I tried again on a newly created user account. Unfortunately, that gave the same results as before.

However, I did manage to locate where NetBeans was sending its error output (.netbeans/8.1/var/log/messages.log). The file in question appears to contain a stack backtrace, which may well help to solve the problem; I've attached it to this bug report.

ais523 (ais523) wrote :

An Ask Ubuntu question that appears to be describing the same issue: https://askubuntu.com/questions/1036508/netbeans-8-1-wont-make-it-past-turning-on-modules-screen

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers