Problem with NFS and virtual IPs

Bug #552443 reported by James Gregory on 2010-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
NetTools
New
Unknown
net-tools (Ubuntu)
Undecided
Bernd Eckenfels
Nominated for Lucid by James Gregory

Bug Description

Binary package hint: net-tools

I'm trying to set up virtual IPs in Lucid in the same way I've done it in previous versions of Ubuntu, but I appear to be having problems. For some reason, Lucid is using the virtual IP as the 'primary' IP address, and all outbound packets come through that by default. That breaks connections to an NFS server because it is only set up to accept requests from the actual primary IP, not the virtual one.

I don't think this is an NFS issue, because a wget test to another server reveals it is also using the virtual IP as the 'primary' address.

A copy of the configuration file I'm using is attached to this bug report.

Changed in net-tools (Ubuntu):
assignee: nobody → Bernd Eckenfels (eckes)
Changed in net-tools:
status: Unknown → New
James Gregory (jamgregory) wrote :

Well, I might have fixed this but it seems a bit of an ugly workaround.

For the second interface, I've set the netmask to be 255.255.255.255. This seems to have forced net-tools to make it use the primary interface address.

Serge Hallyn (serge-hallyn) wrote :

Please reply if this is still an issue.

Changed in net-tools (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.