Incorrectly uses KiB, etc. for measuring bandwidth

Bug #119998 reported by Scott James Remnant (Canonical) on 2007-06-12
This bug report is a duplicate of:  Bug #240073: Ifconfig uses inconsistent units. Edit Remove
6
Affects Status Importance Assigned to Milestone
net-tools (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: net-tools

ifconfig reports the number of bytes transmitted and received on an interface, and then for humans rounds them to a larger figure by dividing by powers of 2 and presenting as KiB "kibibytes", MiB "mibibytes", etc.

This is bogus; bandwidth and traffic should be divided by powers of 10 and presented as kB "kilobytes", MB "megabytes", etc.

This allows for easier translation between traffic and bandwidth, into "kB/s" kilobytes-per-second and "MB/s" megabytes-per-second, by dividing by the numbers of seconds and not having to worry about strange multiples.

Related branches

net-tools (1.60-17ubuntu2) gutsy; urgency=low

  * Change units to be more consistent with other parts of Ubuntu, such
    as the desktop. LP: #119998.

 -- Scott James Remnant <email address hidden> Wed, 13 Jun 2007 08:24:28 +0100

Changed in net-tools:
status: Unconfirmed → Fix Released
Neal McBurnett (nealmcb) wrote :

The patch applied changed the names of the units, but not the divisors, as called for in the original description.

As noted at https://bugs.edge.launchpad.net/ubuntu/+source/net-tools/+bug/240073/ this change (e.g. labeling 2^30 as "GB" rather than the proper binary prefix "GiB") is inconsistent with the main international SI standards, and with the policy of most computing standards organizations. It also conflicts with ifconfig in Debian, Redhat, and upstream.

What desktop applications are displaying units this way?

Endolith (endolith) wrote :

Looks like this was fixed in Bug 240073 to use the standard 1000s-based units, which is the norm for communications.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers