ubuntu-desktop-minimal should not depend on mysql libs

Bug #1860620 reported by Casey Marshall
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
net-snmp (Ubuntu)
Incomplete
Undecided
Unassigned

Bug Description

After upgrading to 20.04 I decided to remove packages that I don't need or use.

I was surprised to find that mysql client, server and common packages were installed, as I could not remember having installed mysql -- I don't use it or develop for it...

When I removed them, ubuntu-desktop-minimal went along for the ride:

c@slate:~$ sudo apt-get purge -y mysql-client-core-5.7 mysql-common mysql-server-core-5.7
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package 'mysql-client-core-5.7' is not installed, so not removed
Package 'mysql-server-core-5.7' is not installed, so not removed
The following package was automatically installed and is no longer required:
  libgsound0
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  colord* gnome-control-center* libmysqlclient21* libsane* libsnmp30* mysql-common* ubuntu-desktop-minimal*
0 upgraded, 0 newly installed, 7 to remove and 0 not upgraded.
After this operation, 28.4 MB disk space will be freed.
(Reading database ... 381127 files and directories currently installed.)
Removing ubuntu-desktop-minimal (1.443) ...
Removing gnome-control-center (1:3.34.1-1ubuntu3) ...
Removing colord (1.4.4-1ubuntu1) ...
Removing libsane:amd64 (1.0.27-3.2ubuntu3) ...
Removing libsnmp30:amd64 (5.7.3+dfsg-5ubuntu6) ...
Removing libmysqlclient21:amd64 (8.0.18-0ubuntu5) ...
Removing mysql-common (5.8+1.0.5ubuntu2) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for gnome-menus (3.32.0-1ubuntu1) ...
Processing triggers for libglib2.0-0:amd64 (2.63.3-1) ...
Processing triggers for libc-bin (2.30-0ubuntu3) ...
Processing triggers for man-db (2.9.0-2) ...
Processing triggers for dbus (1.12.16-2ubuntu2) ...
Processing triggers for udev (244-3ubuntu1) ...
Processing triggers for desktop-file-utils (0.24-1ubuntu1) ...
(Reading database ... 380812 files and directories currently installed.)
Purging configuration files for mysql-common (5.8+1.0.5ubuntu2) ...
Purging configuration files for colord (1.4.4-1ubuntu1) ...

And, reinstalling ubuntu-desktop-minimal wants to brings them back, even with recommends and suggests turned off:

c@slate:~$ sudo apt install ubuntu-desktop-minimal --no-install-recommends --no-install-
--no-install-recommends --no-install-suggests
c@slate:~$ sudo apt install ubuntu-desktop-minimal --no-install-recommends --no-install-suggests
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  colord gnome-control-center libmysqlclient21 libsane libsnmp30 mysql-common
Suggested packages:
  colord-sensor-argyll gnome-user-share realmd libcanberra-gtk-module hplip
Recommended packages:
  gnome-online-accounts gnome-control-center-faces rygel | rygel-tracker sane-utils firefox hplip
The following NEW packages will be installed:
  colord gnome-control-center libmysqlclient21 libsane libsnmp30 mysql-common ubuntu-desktop-minimal
0 upgraded, 7 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/6,114 kB of archives.
After this operation, 28.4 MB of additional disk space will be used.
Do you want to continue? [Y/n]

This seems really wrong... and looks like a transitive dependency, as I don't see it in apt-get showpkg ubuntu-desktop-minimal.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: ubuntu-desktop-minimal 1.443
ProcVersionSignature: Ubuntu 4.15.0-74.84-generic 4.15.18
Uname: Linux 4.15.0-74-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair binder_linux ashmem_linux
ApportVersion: 2.20.11-0ubuntu15
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Wed Jan 22 19:26:53 2020
InstallationDate: Installed on 2018-08-26 (514 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-meta
UpgradeStatus: Upgraded to focal on 2020-01-23 (0 days ago)

Revision history for this message
Casey Marshall (cmars) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-meta (Ubuntu):
status: New → Confirmed
tags: added: rls-gg-incoming
Revision history for this message
Steve Langasek (vorlon) wrote :

this should be looked at by the Desktop Team.

Revision history for this message
Iain Lane (laney) wrote :

I’m not sure if depending on a library and -common (the initial apt log shows the client and server themselves were *not* installed) is a particular problem, but if so, this is coming from libsnmp35.

affects: ubuntu-meta (Ubuntu) → net-snmp (Ubuntu)
Revision history for this message
Casey Marshall (cmars) wrote :

Why does desktop depend on libsnmp35 though?

Revision history for this message
S.Toonen (s-toonen) wrote :

Isn't the question why libsnmp35 depends on libmysqlclient21?

I'm having the weird situation, that when I try to install zabbix-proxy-pgsql, it depends on libsnmp35 which depends on libmysqlclient21 which in turn installs mysql-common.

Revision history for this message
ElTouco72 (eltouco72) wrote :

Actually, ubuntu-destop and ubuntu-gnome-desktop depend also on unrelated components like Samba-libs which i wanted to remove.

I've noticed this since i upgraded from Ubuntu 18.04 LTS to 20.04 LTS

I could be a severe bug since if one does not pay attention before being asked to remove the libs it can break his system by removing important stuff.

sudo apt-get remove samba-libs
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libcdio-cdda2 libcdio-paranoia2 libcolord-gtk1 libgsound0 libldb2
  librygel-core-2.6-2 librygel-db-2.6-2 librygel-renderer-2.6-2
  librygel-renderer-gst-2.6-2 librygel-server-2.6-2 libtalloc2 libtevent0
  libwbclient0 python3-talloc rygel rygel-playbin rygel-tracker
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libgeonames-common libgeonames0 libtimezonemap-data libtimezonemap1
  ubuntu-system-service unity-control-center
Paquets suggérés :
  libcanberra-gtk-module
Les paquets suivants seront ENLEVÉS :
  gnome-control-center gvfs-backends libsmbclient samba-libs ubuntu-desktop
  ubuntu-desktop-minimal ubuntu-gnome-desktop
Les NOUVEAUX paquets suivants seront installés :
  libgeonames-common libgeonames0 libtimezonemap-data libtimezonemap1
  ubuntu-system-service unity-control-center
0 mis à jour, 6 nouvellement installés, 7 à enlever et 1 non mis à jour.
Il est nécessaire de prendre 6 053 ko dans les archives.
Après cette opération, 8 727 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] n
Annulation.

Revision history for this message
Lucas Kanashiro (lucaskanashiro) wrote :

The net-snmp dependency on default-libmysqlclient-dev was added because of this Debian bug:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=836312

It's needed to have mysql support. In Bionic we already have this change.

FWIW the mysql support was initially introduced in version 5.7.2~dfsg-1~0.1. It's unlikely we drop the mysql support, it could be considered a regression. Could any of you provide a good reason to not have mysql support in net-snmp?

Changed in net-snmp (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
ElTouco72 (eltouco72) wrote :

@Lucas Kanashiro

Do you know why samba-libs depends also on ubuntu-desktop ?

Revision history for this message
Sergio Durigan Junior (sergiodj) wrote :

@ElTouco72, samba-libs does not depend on ubuntu-desktop. You can verify the output of "apt show samba-libs", or do a "apt install --dry-run samba-libs".

You will see that samba-libs is part of the task "ubuntu-desktop", but that's a different thing.

tags: removed: rls-gg-incoming
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.