net-snmp merge for focal (v5.8)

Bug #1855943 reported by Rafael David Tinoco on 2019-12-11
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
net-snmp (Ubuntu)
Medium
Unassigned
Focal
Medium
Unassigned
pcs (Ubuntu)
Medium
Unassigned
Focal
Medium
Unassigned
pyagentx (Ubuntu)
Medium
Unassigned
Focal
Medium
Unassigned

Bug Description

According to:

https://merges.ubuntu.com/main.html?query=snmp&showProposed=true&showMergeNeeded=true

A merge from:

5.7.3+dfsg-5ubuntu6 to 5.8+dfsg-2

is possible and pcs-snmp:

https://bugs.launchpad.net/ubuntu/+source/pcs/+bug/1855568

requires this to migrate successfully.

Related branches

Changed in net-snmp (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)
description: updated

Sponsored your MP

There is an on going issue with this new version for dependent packages:

snmp walks from autopkgtests are failing with:

iso.3.6.1.4.1.8072.9999.9999 = No more variables left in this MIB View (It is past the end of the MIB tree)

because of "-V systemonly" in snmpd.conf file:

rocommunity public default -V systemonly
rocommunity6 public default -V systemonly

It can be reproduced with:

snmpwalk -v 2c -c public localhost

and mitigated by removing "-V systemonly" from snmpd.conf (for the affected autopkgtests).

Working on:

autopkgtest for pcs/0.10.2-1: amd64: Regression ♻ , arm64: Regression ♻ , armhf: Ignored failure, i386: Ignored failure, ppc64el: Regression ♻ , s390x: Regression ♻

autopkgtest for pyagentx/0.4.1-3: amd64: Regression ♻ , arm64: Regression ♻ , armhf: Regression ♻ , i386: Ignored failure, ppc64el: Regression ♻ , s390x: Regression ♻
Not considered

For pcs (with a tiny fix allowing local snmp walks):

autopkgtest [06:09:48]: test snmp: -----------------------]
autopkgtest [06:09:49]: test snmp: - - - - - - - - - - results - - - - - - - - - -
snmp PASS
autopkgtest [06:09:49]: @@@@@@@@@@@@@@@@@@@@ summary
status PASS
setup PASS
testsuite-ruby PASS
testsuite-python FAIL non-zero exit status 1
snmp PASS <- passes

Failures are timeout flaked tests and original autopkgtest passed:

autopkgtest [20:19:12]: test snmp: - - - - - - - - - - results - - - - - - - - - -
snmp FAIL non-zero exit status 1
autopkgtest [20:19:12]: @@@@@@@@@@@@@@@@@@@@ summary
status PASS
setup PASS
testsuite-ruby PASS
testsuite-python PASS <- passed
snmp FAIL non-zero exit status 1

So I imagine my fix is good for pcs.

Changed in pcs (Ubuntu Focal):
status: New → In Progress
Changed in pyagentx (Ubuntu Focal):
status: New → In Progress
Changed in net-snmp (Ubuntu Focal):
status: In Progress → Won't Fix
Changed in pcs (Ubuntu Focal):
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)
Changed in pyagentx (Ubuntu Focal):
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)
Changed in net-snmp (Ubuntu Focal):
assignee: Rafael David Tinoco (rafaeldtinoco) → nobody
Changed in pcs (Ubuntu Focal):
importance: Undecided → Medium
Changed in pyagentx (Ubuntu Focal):
importance: Undecided → Medium

For pyagentx:

autopkgtest [12:27:41]: test example: [-----------------------
2020-01-06 12:27:41,691 - pyagentx.updater - INFO - Updating : NetSnmpPlaypen (1.3.6.1.4.1.8072.9999.9999)
2020-01-06 12:27:41,691 - pyagentx.network - INFO - ==== Open PDU ====
2020-01-06 12:27:41,728 - pyagentx.network - INFO - ==== Ping PDU ====
2020-01-06 12:27:41,728 - pyagentx.network - INFO - ==== Register PDU ====
2020-01-06 12:27:41,728 - pyagentx.network - INFO - Registering: 1.3.6.1.4.1.8072.9999.9999
2020-01-06 12:27:41,728 - pyagentx.network - INFO - ==== Waiting for PDU ====
2020-01-06 12:27:42,660 - pyagentx.network - INFO - Received GET_NEXT PDU
2020-01-06 12:27:42,661 - pyagentx.network - INFO - Received GET_NEXT PDU
2020-01-06 12:27:42,661 - pyagentx.network - INFO - Received GET_NEXT PDU
iso.3.6.1.4.1.8072.9999.9999.1.0 = INTEGER: 1000
iso.3.6.1.4.1.8072.9999.9999.3.0 = STRING: "String for NET-SNMP-EXAMPLES-MIB"
autopkgtest [12:27:42]: test example: -----------------------]
autopkgtest [12:27:43]: test example: - - - - - - - - - - results - - - - - - - - - -
example PASS
autopkgtest [12:27:43]: @@@@@@@@@@@@@@@@@@@@ summary
example PASS

Since pyagentx-0.4.1 is not imported in git-ubuntu, I'll provide a debdiff attached to this case for this small fix. If pkg becomes more relevant we can choose to git-ubuntu import it eventually.

Spoke to the team, whitelisted:

https://code.launchpad.net/~rafaeldtinoco/usd-importer/+git/usd-importer/+merge/377177

And will do a merge request over vanilla debian gbp imported repo.

For now, the pyagentx fix can be reviewed in this MR:

https://code.launchpad.net/~rafaeldtinoco/+git/pyagentx/+merge/377178

Future fixes might be done using git-ubuntu approach after whitelist change is merged.

tags: added: update-excuse

Unsure if the "sed" changing /etc/snmp/snmpd.conf is intermittent or not. It definitely has been triggered during autopkgtest AND reason was that snmpd.conf wasn't changed before autopkgtests to run. Nevertheless, tests are passing now, pyagentx has moved on from excuses and pcs is being fixed because of other reason (https://bugs.launchpad.net/auto-package-testing/+bug/1828228).

Changed in pyagentx (Ubuntu Focal):
status: In Progress → Invalid
Changed in pcs (Ubuntu Focal):
status: In Progress → Invalid
Changed in net-snmp (Ubuntu):
assignee: Rafael David Tinoco (rafaeldtinoco) → nobody
Changed in pcs (Ubuntu Focal):
assignee: Rafael David Tinoco (rafaeldtinoco) → nobody
Changed in pyagentx (Ubuntu Focal):
assignee: Rafael David Tinoco (rafaeldtinoco) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package net-snmp - 5.8+dfsg-2ubuntu1

---------------
net-snmp (5.8+dfsg-2ubuntu1) focal; urgency=medium

  * Merge with Debian unstable (LP: #1855943). Remaining changes:
    - d/p/fix-check-hr-filesys-autofs.patch (LP #1843036)
    - Skip autofs entries when calling statfs (LP #1835818):
      - d/p/autofs-skip-autofs-entries.patch
      - d/p/autofs-fix-a-recently-introduced-bug.patch
        [Replaced former Non-upstream patches with clean cherry-pick)
    - d/p/mysql8-replace-bool.patch: fix build with mysql-8 (LP 1814270)
    - d/p/Link-libnetsnmptrapd-against-MYSQL_LIBS.patch: Link
      libnetsnmptrapd against MYSQL_LIBS.
    - Add apport hook.
      - d/control: add dh-apport to Build-Depends
      - d/rules: install the apport hook via debhelper
      - d/source.apport: apport hook
  * Dropped patches that are upstream and in Debian 5.8+dfsg-2:
    - d/p/put-paranthesis-around-macros-which-are-expressions.patch
      (LP #1843036)
    - Fix build with mysql-8 (LP #1814270):
      - d/p/mysql-options.patch: use mysql_options if no {my_,}load_defaults
        was found.
      - d/p/mysql-init.patch: handle the various mysql init functions.
      - d/p/mysql8-headers.patch: detect if my_global.h and my_sys.h are
        available.
      - d/p/my-load-defaults.patch: properly detect (and use)
        my_load_defaults().
    - d/p/snmptrapd_mysql_init: no need to drop this patch anymore
      (LP #1814254)
    - d/p/0001-swinst_apt.c-Fix-indexing-of-hrSWInstalledTable-to-s.patch
      (LP #1314760)

net-snmp (5.8+dfsg-2) unstable; urgency=medium

  * All MIB directory values removed and just use the default compile-time
    options, which is usually ok. Admins can add their own environment
    settings or options to change. Closes: #942151
  * Do not do parallel builds Closes: #942284
  * Correct sedscript CPPFLAGS and libnetsnmptrapd LDFLAGS
  * Also use default flags for restart on init scripts

net-snmp (5.8+dfsg-1) unstable; urgency=medium

  * New upstream release
    - snmplib: handle large amount of file descriptors Closes: #754955
    - BUG: 2815 Display UTF-8 characters again Closes: #898399
  * Update to Debian standards 4.3.0
  * Update debhelper to compat 12
  * snmpd/snmptrapd: Log only warning and above. Closes: #792623
  * snmpd/snmptrapd: Systemd unit logs to stdout
  * Build depend on non-versions libsensors Closes: #917444
  * Library soname updated to 35
  * snmpd: Change pidfile mode to 0644 Closes: #528103
  * Remove python modules Closes: #937131
  * Respect defaults for sysvinit Closes: #932775
  * Added snmpping.1 manpage
  * Reduce logging for subcontainer Closes: #684721
  * Do not enable DISMAN events Closes: #823201
  * Update to standards 4.4.1

 -- Rafael David Tinoco <email address hidden> Fri, 13 Dec 2019 03:27:52 +0000

Changed in net-snmp (Ubuntu Focal):
status: Won't Fix → Fix Released
Changed in net-snmp (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers