snmptrapd fails to build with MySQL 5.7

Bug #1565003 reported by Lars Tangvald on 2016-04-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
mysql-5.7 (Ubuntu)
Undecided
Unassigned
net-snmp (Ubuntu)
Undecided
Unassigned

Bug Description

MySQL 5.7 restricts which symbols are exported and useable from the outside.

The function load_defaults, using in apps/snmptrapd_sql.c is not exported from libmysqlclient20, so the build will fail.
However, the function my_load_defaults is exported, and has the same signature except for an extra flags parameter, which can be set to 0.

The attached patch should allow snmptrapd to build with MySQL 5.7

Lars Tangvald (lars-tangvald) wrote :

The attachment "patch.txt" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Robie Basak (racb) on 2016-04-06
tags: added: mysql-5.7-transition
Changed in net-snmp (Ubuntu):
status: New → Fix Committed
Changed in mysql-5.7 (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package net-snmp - 5.7.3+dfsg-1ubuntu4

---------------
net-snmp (5.7.3+dfsg-1ubuntu4) xenial; urgency=medium

  * Rebuild against libmysqlclient20.
  * d/p/my_load_defaults: use my_load_defaults instead of the
    libmysqlclient-internal load_defaults (LP: #1565003). Thanks to Lars
    Tangvald.

 -- Robie Basak <email address hidden> Tue, 05 Apr 2016 15:17:35 +0000

Changed in net-snmp (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers