dist-upgrade unsuccessful: "Could not install 'nessusd'"

Bug #68422 reported by Moritz Reiter on 2006-10-26
8
Affects Status Importance Assigned to Milestone
nessus-core (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: update-manager

dist-upgrade from Ubuntu 6.06 (Dapper Drake) to Ubuntu 6.10 (Edgy Eft) on amd64 architecture through update-manager did not succeed. Error message ist:

Could not install 'nessusd'

subprocess post-installation script returned error exit status 1

Previously it complained about a changed /etc/nessusd.conf and I chose to use the package version and overwrite the changed local file.

Moritz Reiter (mo-agrav) wrote :
Moritz Reiter (mo-agrav) wrote :
Moritz Reiter (mo-agrav) wrote :
description: updated
Moritz Reiter (mo-agrav) wrote :

I see that the upgrade as such does continue nevertheless. Probably only nessusd will be broken after it finished.

Michael Vogt (mvo) wrote :

Here is the error:

Setting up nessusd (2.2.8-1) ...
pps ...
Configuration file `/etc/nessus/nessusd.conf'
 ==> Modified (by you or by a script) since installation.
 ==> Package distributor has shipped an updated version.
   What would you like to do about it ? Your options are:
    Y or I : install the package maintainer's version
    N or O : keep your currently-installed version
      D : show the differences between the versions
      Z : background this process to examine the situation
 The default action is to keep your current version.
*** nessusd.conf (Y/I/N/O/D/Z) [default=N] ?
*** nessusd.conf (Y/I/N/O/D/Z) [default=N] ? y
irs ...
Installing new version of config file /etc/nessus/nessusd.conf ...
Installing new version of config file /etc/nessus/nessus-services ...
Restarting Nessus daemon:
Restarting Nessus daemon: WARN: The Nessusd configuration file does have a certificate. Have you run nessus-mkcert? (Nessusd might not start)
Restarting Nessus daemon: WARN: The Nessusd configuration file does have a certificate. Have you run nessus-mkcert? (Nessusd might not start)ERROR.
invoke-rc.d: initscript nessusd, action "restart" failed.
dpkg: error processing nessusd (--configure):
 subprocess post-installation script returned error exit status 1

Changed in nessus-core:
importance: Undecided → High
status: Unconfirmed → Confirmed
Mariano Mara (marplatense) wrote :

Happened to me too. It's i686 my machine. Upgrading from dapper to edgy.

Let me know if you need my log files, although they look a lot like the ones posted.

Przemek K. (azrael) wrote :

Edgy is EOL now. Does this bug appear in later supported versions? (Hardy, Intrepid, Jaunty, Karmic)

Changed in nessus-core (Ubuntu):
status: Confirmed → Incomplete
Launchpad Janitor (janitor) wrote :

[Expired for nessus-core (Ubuntu) because there has been no activity for 60 days.]

Changed in nessus-core (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers