ubuntu picking up wrong upstream for nesc

Bug #1830298 reported by Eric B. Decker on 2019-05-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nescc (Ubuntu)
Undecided
Unassigned

Bug Description

ubuntu (19.04) is picking up source code for the NesC tool from the wrong place.

1) The Nesc official repository is at https://github.com/tinyos/nesc.
1.1) The source force code is very old and no longer maintained. It has been superseeded by the github repository.

2) The current released version is 1.3.6.
3) The package name should be nesc (not nescc).
4) nesc does not depend on default-jre, nor perl, nor gcc-avr, nor gcc-msp430
5) nesc stands for Network Enhanced System C. Not Deeply Networked Systems.
6) 1.3.5 has issues, in particular it likes to throw an Internal Error which is fixed in 1.3.6.
7) there will be either a 1.3.7 or a 1.4.0 version released in the near future.

I'm am the current overseer though I wouldn't call myself a maintainer. While I know what I'm doing, I don't understand the nesc code.

Any questions feel free.

eric decker
<email address hidden>
tinyos maintainer.

Eric B. Decker (cire831) on 2019-05-24
description: updated
description: updated
Eric B. Decker (cire831) on 2019-05-24
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers