Broken package 0.30.2-3~ubuntu18.04.1

Bug #1826063 reported by Julien Langlois on 2019-04-23
This bug affects 25 people
Affects Status Importance Assigned to Milestone
neon27 (Ubuntu)

Bug Description

I think there might be a problem with this new neon27 package published for bionic:

The package now defines a dependency for libssl1.1 (>= 1.1.1) but not such version is available on Ubuntu 18.04:

Therefore, the package can not be installed and leads to a broken package situation

=== apt install libneon27 ===

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 libneon27 : Depends: libssl1.1 (>= 1.1.1) but 1.1.0g-2ubuntu4.3 is to be installed
E: Unable to correct problems, you have held broken packages.

Dimitri John Ledkov (xnox) wrote :

well, libssl1.1 >= 1.1.1 is available from bionic-proposed, but not yet from bionic-updates.

I guess we should not have yet published neon27 into bionic-updates, and should probably keep the update in bionic-proposed for now.

tags: added: regression-update
Changed in neon27 (Ubuntu):
status: New → Confirmed
importance: Undecided → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers