[SRU Patch Available] nemo: backports patches that fix some crashes

Bug #1903451 reported by Fantu
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nemo (Ubuntu)
Medium
Unassigned
Bionic
Medium
Fantu
Focal
Undecided
Fantu

Bug Description

[Impact]
There are some cases where nemo crash on umount for example https://bugs.launchpad.net/ubuntu/+source/nemo/+bug/1861968
this has occurred and has been reported by many users (even outside of here)
I also had this issue and like other users before know it is cause the fails of files copy running in another nemo window.
In case of some operation like copy it is significant, even more so with cutting operations.
This is solved by upstream patch https://github.com/linuxmint/nemo/commit/4ffea61b26033da1305ab8287058044065a1c101 in nemo 4.0.0 and also backported in 3.8.6.

I included also a small patch that solves another crash case (https://github.com/linuxmint/nemo/issues/2248):
https://github.com/linuxmint/nemo/commit/b19f8d2e60df82628bbf609522a6a5b20fa4e72c
Applied upstream in nemo 4.6.0

[Test Case]
For the crash on umount, simply umount something from nemo and nemo will crash (closing also any operation, like copy/cut running in it).

For the second patch keep mouse clicked when rename file/folder and press enter and nemo will crash.

[Where problems could occur]
The first patch about the crash on umount is easy to reproduce, many users already reported it after it caused problems with ongoing operations.
Patch is upstream for over 2 years and I have not found regressions about it from a fast search.

The second patch is rarer to happen but in some cases doing some operations quickly could happen so it seems useful to backport this too as it is a small patch with minimal impact and used upstream for a year already.

I did a patch for a SRU for bionic (in attachment).
I also build and tested it: https://launchpad.net/~fantonifabio/+archive/ubuntu/ubuntu-fixes
I used on my notebook (used regularly) and I have not seen regressions until now.

Revision history for this message
Fantu (fantonifabio) wrote :
tags: added: patch
Revision history for this message
Fantu (fantonifabio) wrote :

This is a fix for "Bug #1861968: Removal of a drive closes all windows and stops file transfers." but also for other crash cases (and there is different patch)

Changed in nemo (Ubuntu Bionic):
importance: Undecided → Medium
Fantu (fantonifabio)
summary: - [SRU bionic] backports patches that fix some crashes
+ [SRU Patch Available] nemo: backports patches that fix some crashes
Revision history for this message
Mathew Hodson (mhodson) wrote :

One crash was fixed in 4.0.0 and the other in 4.6.0.
---

nemo (4.6.4-1) unstable; urgency=medium

  * New upstream version 4.6.4

 -- Norbert Preining <email address hidden> Thu, 25 Jun 2020 11:02:02 +0900

Changed in nemo (Ubuntu):
importance: Undecided → Medium
status: New → Fix Released
Revision history for this message
Fantu (fantonifabio) wrote :

Since it was marked as "fix released" it is no longer visible among the open ones, I already know that the fixes applied by the patch are already solved in latest nemo version (in latest ubuntu version) but as wrote in first message I created for a SRU for Bionic (LTS version still supported) as I think is important enough to have fixed (mainly the older one).
The build is also has been tested for months now, is there some possibility that it will be considered?
Thanks for any reply and sorry for my bad english.

Fantu (fantonifabio)
description: updated
Iain Lane (laney)
Changed in nemo (Ubuntu Bionic):
assignee: nobody → Fantu (fantonifabio)
Changed in nemo (Ubuntu Focal):
assignee: nobody → Fantu (fantonifabio)
Changed in nemo (Ubuntu Bionic):
status: New → In Progress
Changed in nemo (Ubuntu Focal):
status: New → In Progress
Revision history for this message
Iain Lane (laney) wrote :

Let's use bug #1861968 for this

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers