sync with debian's servers

Bug #92155 reported by Eugenia Loli-Queru on 2007-03-14
8
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
Undecided
Unassigned

Bug Description

You are currently distributing an older, buggier version of ndiswrapper in the universe. Please sync with the debian servers to get the latest version 1.38. Thx.

Related branches

André Klitzing (misery) wrote :

Thanks for your bug report...

If you want this in Feisty you need to do a UVF exception request because feisty is in version freeze.

https://wiki.ubuntu.com/FreezeExceptionProcess

Changed in ndiswrapper:
status: Unconfirmed → Confirmed
Timo Aaltonen (tjaalton) wrote :

I'll do the merge, no guarantees that it'll get in.

Timo Aaltonen (tjaalton) wrote :

Oh, could you tell what bugs the current version has and how the new one should fix them?

Eugenia Loli-Queru (eloli) wrote :

I have a usb SIS wifi dongle that only works with the newer versions.

Timo Aaltonen (tjaalton) wrote :

ahaha.. the kernel has 1.38... Ubuntu does it a bit differently compared to Debian, so I'm not sure the merge is worth it.

Timo Aaltonen (tjaalton) wrote :

could you try if the version in http://users.tkk.fi/~tjaalton/dpkg/ works?

Eugenia Loli-Queru (eloli) wrote :

Do you mean that your kernels have ndiswrapper in them by default? You see, the first thing I did when I installed ubuntu was to install ndiswrapper from the repos using Synaptic. Could this mean that I overwrote the newer kernel module with an older package and that's what resulted in the problem? If that's the case, it's worth upgrading anyway, or removing the module from the repos... Since then I re-compiled ndiswrapper myself anyway, so I prefer to not touch it atm.. :D

Timo Aaltonen (tjaalton) wrote :

That's right:

/lib/modules/2.6.20-11-generic/kernel/ubuntu/misc/ndiswrapper/ndiswrapper.ko

You still need the utils. Modules don't seem to be available on the repos.

Andreas Gnau (rondom) wrote :

The utils (major version=1.9) have received some small bug fixes related to inf-file parsing between 1.30 and 1.38 (some drivers with strange inf-files didn't work).
Syncing with Debian would have the advantage of having these upstream bugs fixed, but this also solves bug 65779 which is fixed in debian. Another advantage is that users won't believe to be using 1.30 instead of 1.38, because the version of ndiswrapper-utils-1.9 is 1.30 and not 1.38.

Timo Aaltonen (tjaalton) wrote :

fixed with this upload:

 ndiswrapper (1.38-1ubuntu1) feisty; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     debian/control:
     - Update description to point out that the kernel source package is not required with the standard Ubuntu kernel.
     - Change the Maintainer address.
   * Closes many bugs (LP: #32275, #65779, #92155, maybe others)

Changed in ndiswrapper:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers