Ubuntu

new ndiswrapper version for feisty

Reported by Andreas Gnau on 2007-02-05
18
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
High
Unassigned

Bug Description

I think pushing the latest ndiswrapper into feisty before UpstreamVersionFreeze makes sense.

ndiswrapper releases a lot of versions regularly. This is because it runs with a lot of different hardware and drivers i.e. it's only a question of time until another bugfix or workaround is needed.

I think an exception for the ndiswrapper regarding UpstreamVersionFreeze makes sense. I know, at first it sounds insane to make an exception for a _kernel module_, but if you keep in mind that the user has to install a Windows driver manually and load ndiswrapper manually, too you can look at it from another perspective.
No ndiswrapper version is really stable and none will ever be. Let's say there are 10 bugs fixed per version and 9 new ones introduced (this is rather unrealistic) it still makes more sense to ship the newer version with ubuntu.

C de-Avillez (hggdh2) wrote :

for the record, current stable version for ndiswrapper is 1.37, released Feb 2nd. (http://sourceforge.net/project/showfiles.php?group_id=93482).

towsonu2003 (towsonu2003) wrote :

bumping up importance as per hardware functionality that updates would provide

Changed in ndiswrapper:
importance: Undecided → High
status: Unconfirmed → Confirmed
Linux Lover (obake) wrote :

I agree with a Andreas Gnau. ndiswrapper should be current as possible.

Matt Zimmerman (mdz) wrote :

Kernel team, please have a look at this and see if an update is appropriate

Changed in ndiswrapper:
importance: High → Medium
Changed in ndiswrapper:
assignee: nobody → ubuntu-kernel-team
importance: Medium → High
lor (astarventure) wrote :

ndiswrapper update is essential for intel mac users. latest core 2 duo models has not supported by madwifi-ng wifi card and it is needed to run windows driver. current 1.9 ndiswrapper hang up system but manually compiled 1.37 works perfect

Andreas Gnau (rondom) wrote :

lor, there are plenty of examples like that. Of course such issues won't end after the release of feisty, but I'm pretty sure a newer version would help. 1.38 brought recent improvements in inf-file parsing, some fixed issues regarding pcmcia-cards and some AVM-products (quite in popular Germany due to their Fritz!Boxes).... the list can be continued.

Jonathan Lange (jml) wrote :

It's perhaps worth noting that, on recent Macbooks, the currently packaged ndiswrapper raises a kernel panic on the most recent Feisty kernels (2.6.20-8 and 2.6.20-9) -- see bug 83224.

Kyle McMartin (kyle) wrote :

Fix committed to our git tree by Ben, should be uploaded shortly. Thanks for your patience.

Changed in ndiswrapper:
status: Confirmed → Fix Committed
Changed in ndiswrapper:
status: Fix Committed → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers