ndiswrapper-common: ndiswrapper script fails (debian bug 381544)

Bug #65779 reported by Carthik Sharma on 2006-10-12
4
Affects Status Importance Assigned to Milestone
ndiswrapper (Debian)
Fix Released
Unknown
ndiswrapper (Ubuntu)
Undecided
Unassigned

Bug Description

Originally reported using reportbug. Filing by proxy.

Original report follows:
From: Åsmund Hjulstad <email address hidden>
To: Ubuntu Bug Tracking System <email address hidden>
Subject: ndiswrapper-common: ndiswrapper script fails (debian bug 381544)
Date: Fri, 08 Sep 2006 20:01:25 +0200
X-Mailer: reportbug 3.21.2ubuntu1

Package: ndiswrapper-common
Version: 1.18-1ubuntu1
Severity: important

According to debian bug 381544, the ndiswrapper script in
ndiswrapper-common fails when /bin/sh points to dash.

As dash is required by ubuntu-desktop, this is a bit of a problem.

The solution is to run ndiswrapper with bash:

sudo bash -x /usr/sbin/ndiswrapper

(as pointed out by Marco Nenciarini)

The issue is resolved in debian package ndiswrapper 1.22-1 as of august
7th, and it would be really great to get it into the ubuntu packages.

-- System Information:
Debian Release: testing/unstable
  APT prefers edgy-updates
  APT policy: (500, 'edgy-updates'), (500, 'edgy')
Architecture: i386 (i686)
Shell: /bin/sh linked to /bin/dash
Kernel: Linux 2.6.17-7-generic
Locale: LANG=nb_NO.UTF-8, LC_CTYPE=nb_NO.UTF-8 (charmap=UTF-8)

-- no debconf information

Related branches

Andreas Gnau (rondom) on 2007-03-27
Changed in ndiswrapper:
status: Unconfirmed → Confirmed
Changed in ndiswrapper:
status: Unknown → Fix Released
Timo Aaltonen (tjaalton) wrote :

fixed with this upload:

 ndiswrapper (1.38-1ubuntu1) feisty; urgency=low
 .
   * Merge from debian unstable, remaining changes:
     debian/control:
     - Update description to point out that the kernel source package is not required with the standard Ubuntu kernel.
     - Change the Maintainer address.
   * Closes many bugs (LP: #32275, #65779, #92155, maybe others)

Changed in ndiswrapper:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.