package ndiswrapper-dkms 1.56-1 failed to install/upgrade: ndiswrapper kernel module failed to build

Bug #590090 reported by fd.svensson on 2010-06-05
250
This bug affects 49 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
Nominated for Maverick by judmeister
ndiswrapper (Ubuntu)
Medium
Julian Andres Klode
Nominated for Maverick by judmeister

Bug Description

I try'd to install but it did'nt work

ProblemType: Package
DistroRelease: Ubuntu 10.10
Package: ndiswrapper-dkms 1.56-1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Jun 5 11:41:20 2010
ErrorMessage: ndiswrapper kernel module failed to build
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
PackageArchitecture: all
PackageVersion: 1.56-1
SourcePackage: ndiswrapper
Title: package ndiswrapper-dkms 1.56-1 failed to install/upgrade: ndiswrapper kernel module failed to build

fd.svensson (fdsvensson) wrote :
judmeister (henders101) wrote :

I have the same issue. See attached make.log

Changed in ndiswrapper (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
kingr4t (kingr4t) wrote :

no comment

Eric Appleman (erappleman) wrote :

ndiswrapper-dkms package is an unnecessary dependency of ndiswrapper-common and causes module installation loops on 2.6.35 kernels.

iKapoy (spyzar) wrote :

Install new Kernels from

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-generic-pae linux-image-generic-pae linux-headers-generic-pae
sudo update-initramfs -u
sudo update-grub

Remove the Old Kernels and your kernels is 2.6.3x-xx

I try it to work now

iKapoy (spyzar) wrote :

1. sudo apt-get remove ndiswrapper-dkms
2. sudo apt-get remove dkms

Reboot

sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install linux-generic-pae linux-image-generic-pae linux-headers-generic-pae
sudo update-initramfs -u
sudo update-grub

Remove Old Kernels

Reboot

Try

Julian Andres Klode (juliank) wrote :

Here's my proposal A:
  (1) I fix ndiswrapper to handle kernel 2.6.35
  (2) Kernel provides ndiswrapper-modules
  (3) I change ndiswrapper-utils-1.9 to recommend ndiswrapper-modules | ndiswrapper-dkms

This way, all normal installations use the version shipped in Ubuntu's kernel,
but if needed (e.g., for custom kernels), the dkms version can be used.

Here's my proposal B:
  (1) I fix ndiswrapper to handle kernel 2.6.35
  (2) linux stops shipping a pre-built ndiswrapper

This way, dkms will be used always.

tags: added: kj-triage
Changed in linux (Ubuntu):
assignee: nobody → michael chen (chenmike007)
Changed in linux (Ubuntu):
status: New → Confirmed
Eric Appleman (erappleman) wrote :

I'd also like to point out that the most problematic aspect of the current arrangement is that ndiswrapper-dkms is a dependency of ndisgtk.

Julian Andres Klode (juliank) wrote :

This bug has been fixed in release 1.56-2 of the ndiswrapper package. See Bug #612968 for the sync request.

Changed in ndiswrapper (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ndiswrapper - 1.56-2

---------------
ndiswrapper (1.56-2) unstable; urgency=low

  * Only suggest ndiswrapper-dkms on Ubuntu
  * Add support for Linux 2.6.35 (LP: #590090)
  * Set Standards-Version to 3.9.1
 -- Julian Andres Klode <email address hidden> Wed, 04 Aug 2010 20:17:35 +0100

Changed in ndiswrapper (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Foshee (jeremyfoshee) wrote :

marking the kernel task invalid due to this appearing to only be an ndiswrapper issue. Removed erroneous assignee.

Please reopen for the kernel if there is further work needed in kernelspace.

Thanks!

~JFo

Changed in linux (Ubuntu):
assignee: michael chen (chenmike007) → nobody
status: Confirmed → Invalid
Ron Rhodes (owdronrhodes) wrote :

Despite the claim at #10 above that this bug has been fixed I still cannot connect to my wireless network when I boot with the latest 2.6.35-xx-generic kernel package and to go on line I have to boot using the 2.6.32-23-generic kernel package I was using in 10.04 when I upgraded on line to 10.10. This problem occurs in Ubuntu and Xubuntu and on two different computers.
What usually happens when I boot using the latest 2.6.35-xx-generic kernel package is that the Network Manager Applet tadpole swims in a circle for about 1 minute and then changes to the not connected indicator and the message "Wireless Connection Disconnected - you are now offline". Either when the the tadpole is showing or soon after it changes to the not connected indicator a crash is usually (but not always) reported with the message "Your system encountered a serious kernel problem", see Bug #623095. These crashes are titled "BUG: unable to handle kernel paging request at xxxxxxxx" with the "xxxxxxxx" varying from crash to crash.
Is there any further action I can take to enable progress towards a solution to this problem?

claudio (ctaccogna) wrote :

It's the same for me. i have an Alfa awus036h but the native Linux driver (rtl8187) sucks, so i use ndiswrapper. When i try to connect there's a system crash and the message that appear tells me that the kernel may become unstable. I'm desperate, cause i really need ndiswrapper to work!

Same problem with me.
Once I switch from 10.04 to 10.10 alfa edition. I ndiswrapper started not
working. But I can find the my WLAN driver in the hardware drivers list.
That was working once I activate from the hardware list. But after every
restart It was showing 'driver is installed but not currently used'. If I
deactivate and again activate that works.
Once I updated to 10.10 beta version ndiswrapper is getting crashed. I
updated with the new version of ndiswrapper still the same problem
occurs. ndiswrapper
files cannot installed be package manager, only way I installed the
ndiswrapper by opening with the ubuntu software center. Still sucks.

Even I found python and power manager is getting crashed.

On Mon, Sep 6, 2010 at 8:58 AM, claudio <email address hidden> wrote:

> It's the same for me. i have an Alfa awus036h but the native Linux
> driver (rtl8187) sucks, so i use ndiswrapper. When i try to connect
> there's a system crash and the message that appear tells me that the
> kernel may become unstable. I'm desperate, cause i really need
> ndiswrapper to work!
>
> --
> package ndiswrapper-dkms 1.56-1 failed to install/upgrade: ndiswrapper
> kernel module failed to build
> https://bugs.launchpad.net/bugs/590090
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “linux” package in Ubuntu: Invalid
> Status in “ndiswrapper” package in Ubuntu: Fix Released
>
> Bug description:
> I try'd to install but it did'nt work
>
> ProblemType: Package
> DistroRelease: Ubuntu 10.10
> Package: ndiswrapper-dkms 1.56-1
> ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
> Uname: Linux 2.6.32-22-generic x86_64
> NonfreeKernelModules: nvidia
> Architecture: amd64
> Date: Sat Jun 5 11:41:20 2010
> ErrorMessage: ndiswrapper kernel module failed to build
> InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64
> (20100419.1)
> PackageArchitecture: all
> PackageVersion: 1.56-1
> SourcePackage: ndiswrapper
> Title: package ndiswrapper-dkms 1.56-1 failed to install/upgrade:
> ndiswrapper kernel module failed to build
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/linux/+bug/590090/+subscribe
>

--
Thanks and regards,
Babilesh

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers