ndiswrapper 1.60-3~ubuntu16.04.1 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3

Bug #1724869 reported by Seth Forshee on 2017-10-19
82
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]

Currently the DKMS package fails to install in supported custom kernels that are based on 4.11 or 4.13. That includes the current 4.11 hwe-edge and the upcoming 4.13 hwe-edge kernels and some of the custom and cloud kernels as well.

[Test Case]

Install the DKMS package with the 4.13 hwe-edge kernel from -proposed. The package installation should proceed without any errors.

[Regression Potential]

Although new patches were added, the regression risk is very low since the new changes are conditionally compiled based on the kernel version.

Besides that the new package was tested with the following kernels in an amd64 environment:

- linux-generic 4.4
- linux-hwe 4.10
- linux-hwe-edge 4.11
- linux-hwe-edge 4.13 (from xenial-proposed)
- linux-azure 4.11
- linux-azure-edge 4.13 (which is in process of getting promoted to
  xenial-proposed)

[Original description]

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/n/ndiswrapper/20171018_120708_19fbd@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/n/ndiswrapper/20171018_121335_19fbd@/log.gz

Seth Forshee (sforshee) wrote :
tags: added: kernel-adt-failure
Julian Andres Klode (juliank) wrote :

I already added a task for xenial to bug 1706430 yesterday, let's not overcomplicate things.

Seth Forshee (sforshee) on 2017-10-25
tags: added: kernel-adt-failure-hwe-edge-4.11
removed: kernel-adt-failure
tags: added: kernel-adt-failure-hwe-edge-4.13
removed: kernel-adt-failure-hwe-edge-4.11
Marcelo Cerri (mhcerri) on 2017-10-27
description: updated
Brian Murray (brian-murray) wrote :

This bug has all the SRU information though and is already listed in the changelog so I'm unmarking this as a duplicate.

Changed in ndiswrapper (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello Seth, or anyone else affected,

Accepted ndiswrapper into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ndiswrapper/1.60-3~ubuntu16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Marcelo Cerri (mhcerri) on 2017-11-30
tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Brian Murray (brian-murray) wrote :

For this to be released you'll need to add some actual details about the verification which you performed.

Changed in ndiswrapper (Ubuntu Xenial):
status: Fix Committed → Incomplete
Robie Basak (racb) on 2017-12-06
tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-done-xenial
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ndiswrapper (Ubuntu):
status: New → Confirmed
NStorm (passnet) wrote :

Builds for x86_64, kernel 4.13.0-26-generic:
DKMS make.log for ndiswrapper-1.60 for kernel 4.13.0-26-generic (x86_64)
Чт янв 11 09:43:02 MSK 2018
make: вход в каталог «/usr/src/linux-headers-4.13.0-26-generic»
  AR /var/lib/dkms/ndiswrapper/1.60/build/built-in.o
  MKEXPORT /var/lib/dkms/ndiswrapper/1.60/build/crt_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.60/build/hal_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.60/build/ndis_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.60/build/ntoskernel_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.60/build/ntoskernel_io_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.60/build/rtl_exports.h
  MKEXPORT /var/lib/dkms/ndiswrapper/1.60/build/usb_exports.h
  MKSTUBS /var/lib/dkms/ndiswrapper/1.60/build/win2lin_stubs.h
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/crt.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/hal.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/iw_ndis.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/loader.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/ndis.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/ntoskernel.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/ntoskernel_io.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/pe_linker.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/pnp.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/proc.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/rtl.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/wrapmem.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/wrapndis.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/wrapper.o
  CC [M] /var/lib/dkms/ndiswrapper/1.60/build/usb.o
  AS [M] /var/lib/dkms/ndiswrapper/1.60/build/win2lin_stubs.o
  AS [M] /var/lib/dkms/ndiswrapper/1.60/build/lin2win.o
  LD [M] /var/lib/dkms/ndiswrapper/1.60/build/ndiswrapper.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC /var/lib/dkms/ndiswrapper/1.60/build/ndiswrapper.mod.o
  LD [M] /var/lib/dkms/ndiswrapper/1.60/build/ndiswrapper.ko
make: выход из каталога «/usr/src/linux-headers-4.13.0-26-generic»

# modinfo /lib/modules/4.13.0-26-generic/updates/ndiswrapper.ko
filename: /lib/modules/4.13.0-26-generic/updates/ndiswrapper.ko
license: GPL
version: 1.60
description: NDIS wrapper driver
author: ndiswrapper team <email address hidden>
srcversion: CC9F8E33CF3A11EB1B122E4
depends:
name: ndiswrapper
vermagic: 4.13.0-26-generic SMP mod_unload
parm: if_name:Network interface name or template (default: wlan%d) (charp)
parm: proc_uid:The uid of the files created in /proc (default: 0). (int)
parm: proc_gid:The gid of the files created in /proc (default: 0). (int)
parm: debug:debug level (int)
parm: hangcheck_interval:The interval, in seconds, for checking if driver is hung. (default: 0) (int)
parm: utils_version:Compatible version of utils (read only: 1.9) (charp)

1.60-3~ubuntu16.04.2 fixes this problem
but
only 1.60-3~ubuntu16.04.1 is available via apt update!

Julian Andres Klode (juliank) wrote :

Thanks NStrom and Martin, that should be enough for verification. Now it just needs someone to accept it.

Please consider moving away from ndiswrapper though and maybe get a new WiFi device - ndiswrapper is a dirty hack which is unmaintained upstream and really should not be used, especially now in 2018.

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ndiswrapper - 1.60-3~ubuntu16.04.2

---------------
ndiswrapper (1.60-3~ubuntu16.04.2) xenial; urgency=medium

  * Upload to xenial for kernel 4.11 and 4.13 (LP: #1724869)
    - 0006-Build-fixes-for-Linux-4.11.patch
    - 0007-Build-fixes-for-Linux-4.13.patch

 -- Marcelo Henrique Cerri <email address hidden> Fri, 27 Oct 2017 14:03:22 -0200

Changed in ndiswrapper (Ubuntu Xenial):
status: Incomplete → Fix Released

The verification of the Stable Release Update for ndiswrapper has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments