ndiswrapper-dkms 1.59-6: ndiswrapper kernel module failed to build [error: ‘struct net_device’ has no member named ‘trans_start’]

Bug #1627230 reported by EDVALDO BRAZ DO NASCIMENTO JUNIOR on 2016-09-24
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
High
Unassigned

Bug Description

.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: ndiswrapper-dkms 1.59-6
Uname: Linux 4.7.4-040704-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
DKMSKernelVersion: 4.7.4-040704-generic
Date: Sat Sep 24 00:31:03 2016
DuplicateSignature: dkms:ndiswrapper-dkms:1.59-6:/var/lib/dkms/ndiswrapper/1.59/build/wrapndis.c:707:16: error: ‘struct net_device’ has no member named ‘trans_start’
InstallationDate: Installed on 2016-09-16 (7 days ago)
InstallationMedia: It
PackageArchitecture: all
PackageVersion: 1.59-6
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: ndiswrapper
Title: ndiswrapper-dkms 1.59-6: ndiswrapper kernel module failed to build
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check
summary: ndiswrapper-dkms 1.59-6: ndiswrapper kernel module failed to build
+ [error: ‘struct net_device’ has no member named ‘trans_start’]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ndiswrapper (Ubuntu):
status: New → Confirmed
Changed in ndiswrapper (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Deon Rodden (glitch-m) wrote :

Same issue. Running Ubuntu 16.04, I tried to install the linux-generic-hwe-16.04-edge package which gets me the 4.8.x kernel (Dell Precision 5510 laptop, Skylake Xeon CPU) and got errors during the dkms portion of the kernel installation. First set of errors was related to virtualbox (this is not a vm but I have virtualbox installed on it) so I removed virtualbox and then errors about ndiswrapper showed up so I had to remove ndiswrapper-dkms package. Luckily my wireless driver does not depend on ndiswrapper.

Julian Andres Klode (juliank) wrote :

Duplicate of bug 1625089

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers