Feature Request: Support NDIS 6 (Windows Vista family) WiFi drivers

Bug #105013 reported by Michael B. Trausch on 2007-04-10
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)

Bug Description

Presently, Windows Vista family drivers (which use NDIS version 6) are not supported by Ubuntu using the ndiswrapper software. The particular WiFi solution that I have has a buggy native Linux driver, and, as far as I can tell, no pre-Vista drivers at all (this card is OEM for HP workstations).

Information on the card itself, though not directly relevant, can be found in bug 104382 if needed.

In any case, when an attempt is made to install the Vista driver, ndiswrapper complains of unknown symbols. The driver is an NDIS 6 driver, which is unsupported at present. Without having a pre-Vista driver available for this hardware, I am kind of stuck either running Windows Vista or putting up with intermittent and horribly slow functionality under Linux. While I would rather do the latter, the current lack of functionality prevents me from doing a lot of things (such as regularly scheduled rsync backups to my in-house server and printing on the LAN). Of course, I can do these things if I move the computer to an area with wires and use the wired connection.

I will be attaching the list of unknown symbols reported by ndiswrapper; hopefully, they can be of some assistance in finding out how to make them work.

Andreas Gnau (rondom) wrote :

Support for NDIS 6 drivers is being worked on, It doesn't have a very high priority, because Windows XP is still too popular to stop vendors from shipping XP-drivers. Help with development is definitely needed.

Marking this bug as Invalid for the time being because stable support for these drivers is far away.

Michael Trautsch: There _are_ Windows-XP-drivers for your card/chipset.

Changed in ndiswrapper:
status: New → Invalid

Andreas Gnau, on 09/27/2007 01:15 PM said:
> Michael Trautsch: There _are_ Windows-XP-drivers for your card/chipset.

If there are, they aren't on the web sites that I have looked at (from
the vendor of the card and the PC).

It's alright, though; I wound up just running wires. The only driver
that works correctly can't be used/controlled by NetworkManager. It's a
native one written by the company (and available on their site). The
(beta!) driver currently shipping with Ubuntu doesn't work at all unless
the PC has been in Windows Vista for an init first, though. Or using
the older Linux driver. But, all of that is just too much a hassle.

I'd love to help with development, if only I knew how on these issues.

Jarl (jarl-dk) on 2010-12-16
Changed in ndiswrapper (Ubuntu):
status: Invalid → New
Jarl (jarl-dk) wrote :

I am reopening this bug because it is more than 3 years siince it was marked invalid for the reason
"Marking this bug as Invalid for the time being because stable support for these drivers is far away."

So "far away" is now.

Further it seems that Windows XP have had some Serivice Packs published that makes Windows XP support NDIS6 interface (I am not sure), because when I download and use the latest XP driver for my wlan card my dmesg shows:

ndiswrapper (import:242): unknown symbol: ntoskrnl.exe:'IoUnregisterPlugPlayNotification'


Jarl (jarl-dk) wrote :

I figured out that my problem was caused by a bug (https://sourceforge.net/tracker/index.php?func=detail&aid=3093376&group_id=93482&atid=604452) in ndiswrapper (not lack of support for NDIS6), however my reason for opening the bug is stil valid I think.

Windows XP supporting NDIS6 was just a guess, sorry.


IKT (ikt) wrote :

Have added a bugwatch for the ndiswrapper sourceforge page, however I WOULD NOT recommend anyone hang around waiting for this to be implemented, all indications seem to be that progress is very slow, and I've seen no sign that they're even close to implementing full or even partial support.

I would recommend anyone looking at getting a wireless network card that works with linux or ubuntu look at this page:


and choose a network card that natively supports linux.

IKT (ikt) on 2011-03-04
Changed in ndiswrapper (Ubuntu):
status: New → Confirmed
Changed in ndiswrapper (Ubuntu):
importance: Undecided → Wishlist
zorgoth (freepskov) wrote :

The drivers for the Broadcom network card in the new Macbook Pros require NDIS 6 support to work with Ubuntu/ndiswrapper.

Michael B. Trausch, thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command, as it will automatically gather debugging information, in a terminal:
apport-collect 105013

Changed in ndiswrapper (Ubuntu):
status: Confirmed → Incomplete
Julian Andres Klode (juliank) wrote :

This will most likely never happen. Last upstream commit was 2014-01-24 and most cards these days have free drivers available, so there is probably no large incentive upstream to add this.

Julian Andres Klode (juliank) wrote :

And no, this bug report is not incomplete. It is confirmed. There's no need to gather debugging information on a feature request.

Changed in ndiswrapper (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.