Ubuntu

ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]

Reported by green-elephant999 on 2012-07-11
This bug affects 424 people
Affects Status Importance Assigned to Milestone
ndiswrapper (Ubuntu)
High
Unassigned
Declined for Raring by Mathieu Trudel-Lapierre
Declined for Saucy by Mathieu Trudel-Lapierre
Declined for Trusty by Mathieu Trudel-Lapierre
Precise
High
Mathieu Trudel-Lapierre
Quantal
High
Unassigned

Bug Description

WORKAROUND: https://launchpad.net/~crass/+archive/ndiswrapper

rebooted after an update in ubuntu12.10

ProblemType: Package
DistroRelease: Ubuntu 12.10
Package: ndiswrapper-dkms 1.57-1ubuntu1
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic x86_64
ApportVersion: 2.3-0ubuntu4
Architecture: amd64
DKMSKernelVersion: 3.5.0-4-generic
Date: Wed Jul 11 23:24:17 2012
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
PackageArchitecture: all
PackageVersion: 1.57-1ubuntu1
SourcePackage: ndiswrapper
Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build
UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)

green-elephant999 (gergarfe) wrote :
tags: removed: need-duplicate-check
summary: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
- build
+ build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ndiswrapper (Ubuntu):
status: New → Confirmed
Roger Olivé (bluemanro1991) wrote :

Happens to me too. The problem is in the ndiswrapper source, as the problem is present also when compiling manually "ndiswrapper-source".

Updating to the newer 1.58rc1 version fixes the bug. I managed to compile it through dkms using the same dkms.conf file from 1.57-1 (only changing the ndiswrapper version) and the updated source code. Upgrading the version in the repositories should be enough to get rid of this bug (and perhaps other bugs present in the same package which are related to the kernel version as well).

Steps to solve/workaround the problem:

1.Create the folder /usr/src/ndiswrapper-1.58/
2.Extract there the source code of the ndiswrapper module.
3.Copy the dkms.conf file from /usr/src/ndiswrapper-1.57/ to the /usr/src/ndiswrapper-1.58/ folder as well. Open it with a text editor and change the version of ndiswrapper listed there to 1.58.
4.Run these commands in your console in order to build and install the module using dkms:

sudo dkms add ndiswrapper/1.58
sudo dkms build ndiswrapper/1.58
sudo dkms install ndiswrapper/1.58

Try the module using "modprobe ndiswrapper" or add it to /etc/modules directly if you want it running every time at system startup.

Enjoy! ;)

Unfortunately, this workaround does not fix the issue for me- I tried this about 5 minutes ago, it proceeded to start building the module and then packed up, informing me that it couldn't find the binary package for ndiswrapper, so at the moment, I'm sorta lost. Any ideas?

Roger Olivé (bluemanro1991) wrote :

Can you post more information about the error? Make sure that you are using the right version of the source code. Only the dkms.conf must be preserved.

I used a clean install from 12.04, got the USB network card ( Siemens
Gigabit 108 ) running, upgraded to 12.10, and install of ndiswrapper-dkms
failed....

2012/10/19 Roger Olivé <email address hidden>

> Can you post more information about the error? Make sure that you are
> using the right version of the source code. Only the dkms.conf must be
> preserved.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1068300).
> https://bugs.launchpad.net/bugs/1023645
>
> Title:
> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions
>

Hi Roger - re your comment at #5, I followed your instructions down to the letter - except, since you didn't say where you'd gotten the rc source for ndiswrapper, someone from #ubuntu directed me to the source area on sourceforge - it's the version which is located here: http://sourceforge.net/projects/ndiswrapper/files/testing/

The tar.gz on that page is what I extracted to get the 1.58rc1 source code to do the work from.

If that is *not* the version you used for making this workaround - please let me know. Other than that, I'll post what pops up on the screen when I've tried to build for 3.5.0-17 and show you the log as well.

This will take a few minutes as I have to go back into the 35.0-17 kernel to build it - and I'm currently in 3.2.0-32 :)

Here is the output of my terminal when I attempted to build 1.58rc1 against 3.5.0-17-generic, and also in the same document, the contents of my make.log from the build.

Roger Olivé (bluemanro1991) wrote :

Yes, it is the same version I used to generate the module.

I don't see anything special in your make.log. It's very similar to the one generated by my computer. There are no errors. The compilation process looks fine, but however it doesn't seem to find the binary after the process...

I may know the origin of your problem, and if it's the case, then it's my fault because I didn't detail enough the steps to follow! ;)

I observed that inside the build folder, you have another folder called "driver", and the source files are inside that folder according to the log. I assume this is because you extracted the WHOLE tarball inside the "/usr/src/ndiswrapper-1.58/" path.

If I guessed it right, do the following: copy ONLY the content of this "driver" subfolder inside "/usr/src/ndiswrapper-1.58" directly. No subfolders. And forget the rest of the content provided by the ndiswrapper tarball. Only the sources from the driver subfolder and the dkms.conf must remain.

Then try to build the module again. Let me know if it works. If that's the case I will update the steps of the other post to make them easier to follow by other people. :)

There is actually an answer to this, which was provided by one of the guys from #kubuntu on freenode to myself last night, and which works a treat. This fixes the problem for me, and it's easier :)

Get the ndiswrapper 1.58rc1 source code and extract it somewhere
CD to whichever directory you put it in,
make
sudo make install

When it's finished, it'll be installed permanently, and you can sudo modprobe ndiswrapper to get it working.

From the minute I was given this information last night, by yofel, it took about 5 minutes to get my net up and working :)

Knut Wenzig (kwoid) wrote :

I can confirm #9 and #10: Installing ndiswrapper 1.58rc1 from sourceforge help.

Roger Olivé (bluemanro1991) wrote :

Yes, this would be the most straightforward solution.

However, I arranged it the other way (using dkms) to automatise the process when upgrading the kernel. Wouldn't it stop working if the Ubuntu team released, let's say, a 3.5.0-18 kernel update? Then make + make install would be necessary for every kernel upgrade.

The idea is that dkms handles the build process automatically each time you upgrade the kernel, so you don't have to worry about the module not working every time you boot after a new kernel install.

Correct me if I'm wrong, please. :)

Anyway, I'm glad you got it working!

You're not wrong, Roger, not by a long shot - the only reason I posted that is that it worked, so I thought of it as a secondary workaround to your workaround - I didn't mean to make it seem like it was better in any way, simply an alternative :D

Leonardo Donelli (learts92) wrote :

I confirm that the workaround proposed by Roger (post #3 + #9) works.
Remember, after extracting the ndiswrapper source, to copy *the contents* of the driver directory (and not the directory itself) in /usr/src/ndiswrapper-1.58/

Roger Olivé (bluemanro1991) wrote :

Well, I thought the posts were editable, but now I noticed I only can hide them... ;)

Anyway, to summarize, steps updated:

1.Download the latest tarball from http://sourceforge.net/projects/ndiswrapper/files/testing/
2.Create the folder /usr/src/ndiswrapper-1.58/
3.Extract there the source code of the ndiswrapper module found in the tarball. It is located in the "driver" subfolder. Copy only the contents of this directory, not the directory itself.
4.Copy the dkms.conf file from /usr/src/ndiswrapper-1.57/ to the /usr/src/ndiswrapper-1.58/ folder as well. Open it with a text editor and change the version of ndiswrapper listed there to 1.58.
5.Run these commands in your console in order to build and install the module using dkms:

sudo dkms add ndiswrapper/1.58
sudo dkms build ndiswrapper/1.58
sudo dkms install ndiswrapper/1.58

Try the module using "modprobe ndiswrapper" or add it to /etc/modules directly if you want it running every time at system startup.

I hope now the steps will be easier to follow by other people with the same problem.

Jan Abramek (janovov) on 2012-10-27
Changed in ndiswrapper (Ubuntu):
assignee: nobody → Jan Abramek (janovov)
assignee: Jan Abramek (janovov) → nobody
buzzmandt (buzzmandt) wrote :

Tried #16, no errors on all 3 commands, modprobe returned could not find error

#10 worked perfectly.

Thank you
Quantal kubuntu, netgear broadcomm, WNA3100(v1) Wireless-N 300 [Broadcom BCM43231]

Attishay (attishay) wrote :

This workaround solved he issue for me after I upgraded to Lubuntu 12.10 from 12.04 install. However, running the software updater caused it to revert back to ndis 1.57. Reinstalling the package manually as Ihad done the previous time solved it.

Julian Andres Klode (juliank) wrote :

I'll upload a new version of ndiswrapper to Debian experimental soon, and then request a sync.

Changed in ndiswrapper (Ubuntu):
assignee: nobody → Julian Andres Klode (juliank)

cool. thanks.

On Thu, Nov 8, 2012 at 10:16 AM, Julian Andres Klode <email address hidden>wrote:

> I'll upload a new version of ndiswrapper to Debian experimental soon,
> and then request a sync.
>
> ** Changed in: ndiswrapper (Ubuntu)
> Assignee: (unassigned) => Julian Andres Klode (juliank)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1071963).
> https://bugs.launchpad.net/bugs/1023645
>
> Title:
> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> Status in “ndiswrapper” package in Ubuntu:
> Confirmed
>
> Bug description:
> rebooted after an update in ubuntu12.10
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: ndiswrapper-dkms 1.57-1ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> ApportVersion: 2.3-0ubuntu4
> Architecture: amd64
> DKMSKernelVersion: 3.5.0-4-generic
> Date: Wed Jul 11 23:24:17 2012
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64
> (20091027.1)
> PackageArchitecture: all
> PackageVersion: 1.57-1ubuntu1
> SourcePackage: ndiswrapper
> Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed
> to build
> UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions
>

--

Nathanel Titane, B.D.I., Membre | ADIQ | Member
*
*
*TND*esigns | *G*raphic & *I*ndustrial *D*esign *S*olutions

514 . 583 . 7386

Hi,

Thks.

JF

________________________________________________________________________
Qui, 2012-11-08 às 15:16 +0000, Julian Andres Klode escreveu:

> I'll upload a new version of ndiswrapper to Debian experimental soon,
> and then request a sync.
>
> ** Changed in: ndiswrapper (Ubuntu)
> Assignee: (unassigned) => Julian Andres Klode (juliank)
>

Julio Fernandes (jtdtgm) wrote :

Hi,

Thks.

JF

Qui, 2012-11-08 às 04:38 +0000, Attishay escreveu:

> This workaround solved he issue for me after I upgraded to Lubuntu 12.10
> from 12.04 install. However, running the software updater caused it to
> revert back to ndis 1.57. Reinstalling the package manually as Ihad done
> the previous time solved it.
>

Changed in ndiswrapper (Ubuntu):
importance: Undecided → High
Changed in ndiswrapper (Ubuntu):
status: Confirmed → Fix Committed

Hola. Por desgracia para mí no entiendo ingles y la traducción online no es muy académica.
Por tanto me quedo sin saber el contenido del correo.
Saludos

> Date: Mon, 10 Dec 2012 14:28:50 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 1023645] Re: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> ** Changed in: ndiswrapper (Ubuntu)
> Status: Confirmed => Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1084455).
> https://bugs.launchpad.net/bugs/1023645
>
> Title:
> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> Status in “ndiswrapper” package in Ubuntu:
> Fix Committed
>
> Bug description:
> rebooted after an update in ubuntu12.10
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: ndiswrapper-dkms 1.57-1ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> ApportVersion: 2.3-0ubuntu4
> Architecture: amd64
> DKMSKernelVersion: 3.5.0-4-generic
> Date: Wed Jul 11 23:24:17 2012
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
> PackageArchitecture: all
> PackageVersion: 1.57-1ubuntu1
> SourcePackage: ndiswrapper
> Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build
> UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions

working very well with #16..................many thanks

Changed in ndiswrapper (Ubuntu):
status: Fix Committed → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ndiswrapper - 1.58~rc1-0ubuntu1

---------------
ndiswrapper (1.58~rc1-0ubuntu1) raring; urgency=low

  * New upstream release. (LP: #1023645)
   - add a patch to fix for 3.6+ kernels, maybe.
 -- Dmitrijs Ledkovs <email address hidden> Thu, 20 Dec 2012 22:44:06 +0000

Changed in ndiswrapper (Ubuntu Raring):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ndiswrapper (Ubuntu Precise):
status: New → Confirmed
Changed in ndiswrapper (Ubuntu Quantal):
status: New → Confirmed
Changed in ndiswrapper (Ubuntu Precise):
importance: Undecided → High
Changed in ndiswrapper (Ubuntu Quantal):
importance: Undecided → High
Barry O'Connor (oconnorbar) wrote :

Thanks Roger Olivé (bluemanro1991) your instructions worked like a charm!

sam penny (xanthraxoid) wrote :

Is this bugfix expected to make its way into an update to Quantal at some point? What's the likely timescale for that? (I'm not all that familiar with the ubuntu release process, sorry!)

Sam

Alaric Cundy (alaric-cundy) wrote :

I am not in control of these things - but I would hope so!

I keep getting messages to say that it is a duplicate of some other bug
that has already been reported, so it sounds as though it is being taken
seriously.

Alaric Cundy (<email address hidden> or <email address hidden>

Sent from a pure 'Open Source' environment: Ubuntu (Linux) 12.10 Operating System, Thunderbird e-mail client,
Libre Office, Firefox browser, Website management using SciTE (text editor) and bareFTP (File transfer)

On 18/01/13 16:27, sam penny wrote:
> Is this bugfix expected to make its way into an update to Quantal at
> some point? What's the likely timescale for that? (I'm not all that
> familiar with the ubuntu release process, sorry!)
>
> Sam
>

Hi. Just a quick comment - according to the schedule above, a fix has been released for raring ringtail to correct this bug. I've just upgraded to raring in order to bugsmash, and unfortunately, on the 3.8.0.1 kernel, this bug is still present. Ndiswrapper refuses to build on that kernel - I've had to drop back to 3.5.0.22 in order to get on the net. Julius - any chance you can have a look at this please? It would be great if I could run raring using what it's issued with :)

benard.gagnon (connex-bern) wrote :

Hi #16 step buid fail:

Kernel preparation unnecessary for this kernel. Skipping...

Building module:
cleaning build area....
make KERNELRELEASE=3.5.0-22-generic KVERS=3.5.0-22-generic...........
ERROR (dkms apport): binary package for ndiswrapper: 1.58 not found
Error! Build of ndiswrapper.ko failed for: 3.5.0-22-generic (i686)
Consult the make.log in the build directory
/var/lib/dkms/ndiswrapper/1.58/build/ for more information.

Just to note here, I am doing some bisect work on the mainline kernels trying to find a commit which broke a new wifi kernel driver (bug #1113048), and i've found the last of the mainline kernels where ndiswrapper would successfully build in dkms - and that is 3.8.0-030800rc3-generic.

While I was bisecting, I went up to rc4 and ndiswrapper breaks in that kernel, it refuses to build at all - rc3 and rc2 are both fine with building 1.58~rc1 and 1.58.

I sorta consider this a side effect of what I was doing with jsalisbury, but hey, if it helps, it helps :)

Kenny Strawn (kenny-strawn) wrote :

Seems like a pure case of ignorance on the assignee's part when it comes to changing the status in Raring... Apparently, there's a regression going on here in the latest kernel update.

Changed in ndiswrapper (Ubuntu Raring):
assignee: Julian Andres Klode (juliank) → nobody
assignee: nobody → Kenny Strawn (kenny-strawn)
assignee: Kenny Strawn (kenny-strawn) → nobody
Changed in ndiswrapper (Ubuntu Precise):
assignee: nobody → joão santanna guilherme (joaosguilherme-c)
Changed in ndiswrapper (Ubuntu Quantal):
assignee: nobody → joão santanna guilherme (joaosguilherme-c)
Tomas Clark (lascruces) wrote :

Looks like the same bug.

no longer affects: ndiswrapper (Ubuntu Raring)
Changed in ndiswrapper (Ubuntu):
status: Fix Released → Triaged
description: updated

Thanks for the update on status, Dave - if it helps, I've noticed something. I have a kernel on here, 3.8.0-2-generic, and i've got others up to 3.8.0-9-generic - there appears to be something going wrong with one of the macros inside the code. I've tried to build ndiswrapper from scratch, and get an error about ntoskernel.h, line 215, character 48 - informing me that INIT_WORK was passed 3 variables, but only takes 2.

I've examined that portion of the code, and it's not kernel limited, despite the fact that it's means as backwards compat, pre 2.6.20. I've tried to exclude it, and that's failed too - so i'm lost, bearing in mind i don't code much - and i'm not very good when I do.

The latest try I had at updating managed to get it to build as far as ndis.o, when it fails again. The results are in my attachment to this comment - enjoy :)

Daniel Letzeisen (dtl131) wrote :

@Thorsteinn: the reason I removed raring (and its 3.8 kernel) from this bug report was because it now suffers from a different bug, bug 1106051 . Also, it was hiding this bug reports from my searches as 'Fix Released' when it wasn't fixed in Precise and Quantal.

Anyway, I am curious whether the PPA works for users running Precise/Quantal with their standard kernels.

Changed in ndiswrapper (Ubuntu Precise):
assignee: joão santanna guilherme (joaosguilherme-c) → nobody
Changed in ndiswrapper (Ubuntu Quantal):
assignee: joão santanna guilherme (joaosguilherme-c) → nobody
Daniel Young (lienad216) wrote :

Hi, I'm running Quantal and haven't made any changes to the kernel or
whatever (don't know enough to do that). I added the repository mentioned
and ran 'sudo apt-get install ndiswrapper' from the terminal. The computer
returned something like no package found. Now, the computer does not boot,
the screen upon attempting to boot in recovery mode (from GRUB2's menu, in
the advanced options for Ubuntu) shows 'Kernel panic - not syncing: Fatal
exception in interrupt'. The trace showed just before it mentions
ndiswrapper, and a plethora of technical details.

I'm not certain if it was the ndiswrapper in the given repository or some
update to the original ndiswrapper, and, since i can't boot my computer at
all (livecd/usb doesn't work for some reason) i can't replicate this.

On Wed, Mar 13, 2013 at 7:34 AM, Dave Lentz <email address hidden>wrote:

> @Thorsteinn: the reason I removed raring (and its 3.8 kernel) from this
> bug report was because it now suffers from a different bug, bug 1106051
> . Also, it was hiding this bug reports from my searches as 'Fix
> Released' when it wasn't fixed in Precise and Quantal.
>
> Anyway, I am curious whether the PPA works for users running
> Precise/Quantal with their standard kernels.
>
> ** Changed in: ndiswrapper (Ubuntu Precise)
> Assignee: joão santanna guilherme (joaosguilherme-c) => (unassigned)
>
> ** Changed in: ndiswrapper (Ubuntu Quantal)
> Assignee: joão santanna guilherme (joaosguilherme-c) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1131202).
> https://bugs.launchpad.net/bugs/1023645
>
> Title:
> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> Status in “ndiswrapper” package in Ubuntu:
> Triaged
> Status in “ndiswrapper” source package in Precise:
> Confirmed
> Status in “ndiswrapper” source package in Quantal:
> Confirmed
>
> Bug description:
> WORKAROUND: https://launchpad.net/~crass/+archive/ndiswrapper
>
> rebooted after an update in ubuntu12.10
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: ndiswrapper-dkms 1.57-1ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> ApportVersion: 2.3-0ubuntu4
> Architecture: amd64
> DKMSKernelVersion: 3.5.0-4-generic
> Date: Wed Jul 11 23:24:17 2012
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64
> (20091027.1)
> PackageArchitecture: all
> PackageVersion: 1.57-1ubuntu1
> SourcePackage: ndiswrapper
> Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed
> to build
> UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions
>

Daniel Letzeisen (dtl131) wrote :

@Daniel Young: so it sounds like the PPA allowed you to install the ndiswrapper package, but whatever driver you loaded with ndiswrapper caused a kernel panic (that's known to happen with ndiswrapper).

I have a hard time believing all of the people reporting this bug really need/want ndiswrapper to begin with.

Well I can guarantee you, @Dave, I certainly do - at least until bug 1113048 concerning the "New" native driver for my wifi chip is fixed - the ar5523 module doesn't work on my wifi device, Siemens Gigaset USB 108 (129b:160c) - but ndiswrapper with the net5523 driver from atheros/windows, works perfectly. Ndiswrapper has been a god for me up to now, it's been the only thing keeping me on the internet for the last 8 years :)

Daniel Young (lienad216) wrote :

@Dave Oh.... So, if I manage to remove that driver I should be able to
start up my system again? Does ndiswrapper make a copy/store the loaded
driver anywhere? Or does it operate the driver off its original directory?
(I need to try using Windows or GRUB2 to delete the driver I suppose, since
for some reason neither LiveUSBs or LiveCD/DVDs can be booted by the BIOS)
As for needing ndiswrapper, before downloading it originally, i checked for
Linux support for the wireless device and there wasn't any (based from a
list of supported devices, i think the page was somewhere in Ubuntu/Linux's
WiFiDocs. The same page referred me to this package. If there are
alternatives, I would gladly consider giving them a try, since I haven't
enough experience in Linux to do anything but heed advice and ndiswrapper
hasn't exactly been cooperating.

On Wed, Mar 13, 2013 at 10:38 PM, Thorsteinn A. Malmjursson <
<email address hidden>> wrote:

> Well I can guarantee you, @Dave, I certainly do - at least until bug
> 1113048 concerning the "New" native driver for my wifi chip is fixed -
> the ar5523 module doesn't work on my wifi device, Siemens Gigaset USB
> 108 (129b:160c) - but ndiswrapper with the net5523 driver from
> atheros/windows, works perfectly. Ndiswrapper has been a god for me up
> to now, it's been the only thing keeping me on the internet for the last
> 8 years :)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1131202).
> https://bugs.launchpad.net/bugs/1023645
>
> Title:
> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> Status in “ndiswrapper” package in Ubuntu:
> Triaged
> Status in “ndiswrapper” source package in Precise:
> Confirmed
> Status in “ndiswrapper” source package in Quantal:
> Confirmed
>
> Bug description:
> WORKAROUND: https://launchpad.net/~crass/+archive/ndiswrapper
>
> rebooted after an update in ubuntu12.10
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: ndiswrapper-dkms 1.57-1ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> ApportVersion: 2.3-0ubuntu4
> Architecture: amd64
> DKMSKernelVersion: 3.5.0-4-generic
> Date: Wed Jul 11 23:24:17 2012
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64
> (20091027.1)
> PackageArchitecture: all
> PackageVersion: 1.57-1ubuntu1
> SourcePackage: ndiswrapper
> Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed
> to build
> UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions
>

Eric Smeets (ericsmeets) wrote :
Download full text (3.1 KiB)

Thank you for yours answers,

I ame ame novice in this, have xubuntu 12.10
had nevrer probs with xubunu 11.04 lts
is it possible to reinstal that last lts?
please let me know, i prefere ubuntu on windows or apple
but i'm not a computerscientific
thank you
grtz
Eric

Op 18-03-13 17:24, Daniel Young schreef:
> @Dave Oh.... So, if I manage to remove that driver I should be able to
> start up my system again? Does ndiswrapper make a copy/store the loaded
> driver anywhere? Or does it operate the driver off its original directory?
> (I need to try using Windows or GRUB2 to delete the driver I suppose, since
> for some reason neither LiveUSBs or LiveCD/DVDs can be booted by the BIOS)
> As for needing ndiswrapper, before downloading it originally, i checked for
> Linux support for the wireless device and there wasn't any (based from a
> list of supported devices, i think the page was somewhere in Ubuntu/Linux's
> WiFiDocs. The same page referred me to this package. If there are
> alternatives, I would gladly consider giving them a try, since I haven't
> enough experience in Linux to do anything but heed advice and ndiswrapper
> hasn't exactly been cooperating.
>
>
> On Wed, Mar 13, 2013 at 10:38 PM, Thorsteinn A. Malmjursson <
> <email address hidden>> wrote:
>
>> Well I can guarantee you, @Dave, I certainly do - at least until bug
>> 1113048 concerning the "New" native driver for my wifi chip is fixed -
>> the ar5523 module doesn't work on my wifi device, Siemens Gigaset USB
>> 108 (129b:160c) - but ndiswrapper with the net5523 driver from
>> atheros/windows, works perfectly. Ndiswrapper has been a god for me up
>> to now, it's been the only thing keeping me on the internet for the last
>> 8 years :)
>>
>> --
>> You received this bug notification because you are subscribed to a
>> duplicate bug report (1131202).
>> https://bugs.launchpad.net/bugs/1023645
>>
>> Title:
>> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
>> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>>
>> Status in “ndiswrapper” package in Ubuntu:
>> Triaged
>> Status in “ndiswrapper” source package in Precise:
>> Confirmed
>> Status in “ndiswrapper” source package in Quantal:
>> Confirmed
>>
>> Bug description:
>> WORKAROUND: https://launchpad.net/~crass/+archive/ndiswrapper
>>
>> rebooted after an update in ubuntu12.10
>>
>> ProblemType: Package
>> DistroRelease: Ubuntu 12.10
>> Package: ndiswrapper-dkms 1.57-1ubuntu1
>> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
>> Uname: Linux 3.0-3-generic x86_64
>> ApportVersion: 2.3-0ubuntu4
>> Architecture: amd64
>> DKMSKernelVersion: 3.5.0-4-generic
>> Date: Wed Jul 11 23:24:17 2012
>> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64
>> (20091027.1)
>> PackageArchitecture: all
>> PackageVersion: 1.57-1ubuntu1
>> SourcePackage: ndiswrapper
>> Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed
>> to build
>> UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)
>>
>> To manage notifications about this bug go to:
>>
>> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions
>...

Read more...

Daniel Letzeisen (dtl131) wrote :

@Daniel Young, IIRC ndiswrapper creates/changes files in /etc/modprobe.d/, so you may want to look there

@Eric Smeets: bots are fun, no?

Daniel Young (lienad216) wrote :

@Dave /etc/ is in the root folder right? Thanks for the tip, I'll try that
once have free time, probably after my finals.

On Tue, Mar 19, 2013 at 7:21 AM, Dave Lentz <email address hidden>wrote:

> @Daniel Young, IIRC ndiswrapper creates/changes files in
> /etc/modprobe.d/, so you may want to look there
>
> @Eric Smeets: bots are fun, no?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1131202).
> https://bugs.launchpad.net/bugs/1023645
>
> Title:
> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> Status in “ndiswrapper” package in Ubuntu:
> Triaged
> Status in “ndiswrapper” source package in Precise:
> Confirmed
> Status in “ndiswrapper” source package in Quantal:
> Confirmed
>
> Bug description:
> WORKAROUND: https://launchpad.net/~crass/+archive/ndiswrapper
>
> rebooted after an update in ubuntu12.10
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: ndiswrapper-dkms 1.57-1ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> ApportVersion: 2.3-0ubuntu4
> Architecture: amd64
> DKMSKernelVersion: 3.5.0-4-generic
> Date: Wed Jul 11 23:24:17 2012
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64
> (20091027.1)
> PackageArchitecture: all
> PackageVersion: 1.57-1ubuntu1
> SourcePackage: ndiswrapper
> Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed
> to build
> UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions
>

Andy Darby (andydarby) wrote :

I give up. I'm going back to Windows. After six months of struggling with ubuntu and having to reinstall drivers and trawl through code to rebuild unpronounceable packages I admit it is beyond me.

Jerry Miller (jerry-miller-v) wrote :

Andy, sorry to hear that.
I must admit that ubuntu is not the easiest of platforms, and there is so much jargon and assumed knowledge that it makes even simple problems difficult.
If it's just the ndiswrapper problem, you might want to have a look at my experience, described in
https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1132511

There is a new release of ndiswrapper (1.58) available at sourceforge (http://sourceforge.net/projects/ndiswrapper/)
I also found a copy on ubuntu's support site after I had already installedit.
It solves the problem that I was having in a couple of minutes. There's a copy of the tarball attached to the bug report, so you should be able to extract it and install it from there., or do your own search for a more current version.

Subsequently, my ubuntu kernel reverted to the 'currently supported' version (1.57 for ubuntu 12.10, which is what I am running), so I had to re-install. I've since updated my Synaptics package manager with a PPA (I forget what it stands for, but as you say, it's more unpronounceable stuff). It's supposed to tell the software installer not to overwrite v1.58 with v1.57. So far it's working, but if it were to revert back, I can re-install in a couple of minutes.

Go to the directory (folder) where you extract tarball and do
sudo make clean
sudo make
If there are no errors, then do
sudo make install
 and then
sudo modprobe ndiswrapper

I have no idea why a solution that seems so straight forward (v1.58) and has been around for months, hasn't been incorporated into the basic distribution, but that's something that others can answer.

Jerry

William Reid (reidservices) wrote :
Download full text (3.2 KiB)

I have a son-in-law who helps me with most of these issues; he's quite
knowledgeable. - Bill

Bill Reid

On Fri, Mar 22, 2013 at 4:00 PM, Jerry Miller <email address hidden>wrote:

> Andy, sorry to hear that.
> I must admit that ubuntu is not the easiest of platforms, and there is so
> much jargon and assumed knowledge that it makes even simple problems
> difficult.
> If it's just the ndiswrapper problem, you might want to have a look at my
> experience, described in
> https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1132511
>
> There is a new release of ndiswrapper (1.58) available at sourceforge (
> http://sourceforge.net/projects/ndiswrapper/)
> I also found a copy on ubuntu's support site after I had already
> installedit.
> It solves the problem that I was having in a couple of minutes. There's a
> copy of the tarball attached to the bug report, so you should be able to
> extract it and install it from there., or do your own search for a more
> current version.
>
> Subsequently, my ubuntu kernel reverted to the 'currently supported'
> version (1.57 for ubuntu 12.10, which is what I am running), so I had to
> re-install. I've since updated my Synaptics package manager with a PPA
> (I forget what it stands for, but as you say, it's more unpronounceable
> stuff). It's supposed to tell the software installer not to overwrite
> v1.58 with v1.57. So far it's working, but if it were to revert back, I
> can re-install in a couple of minutes.
>
> Go to the directory (folder) where you extract tarball and do
> sudo make clean
> sudo make
> If there are no errors, then do
> sudo make install
> and then
> sudo modprobe ndiswrapper
>
> I have no idea why a solution that seems so straight forward (v1.58)
> and has been around for months, hasn't been incorporated into the basic
> distribution, but that's something that others can answer.
>
> Jerry
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1158630).
> https://bugs.launchpad.net/bugs/1023645
>
> Title:
> ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
> build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]
>
> Status in “ndiswrapper” package in Ubuntu:
> Triaged
> Status in “ndiswrapper” source package in Precise:
> Confirmed
> Status in “ndiswrapper” source package in Quantal:
> Confirmed
>
> Bug description:
> WORKAROUND: https://launchpad.net/~crass/+archive/ndiswrapper
>
> rebooted after an update in ubuntu12.10
>
> ProblemType: Package
> DistroRelease: Ubuntu 12.10
> Package: ndiswrapper-dkms 1.57-1ubuntu1
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic x86_64
> ApportVersion: 2.3-0ubuntu4
> Architecture: amd64
> DKMSKernelVersion: 3.5.0-4-generic
> Date: Wed Jul 11 23:24:17 2012
> InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64
> (20091027.1)
> PackageArchitecture: all
> PackageVersion: 1.57-1ubuntu1
> SourcePackage: ndiswrapper
> Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed
> to build
> UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)
>
> To manage notificati...

Read more...

whatever you can fix will be liked;)

piotr zimoch (ebytyes) on 2013-05-16
Changed in ndiswrapper (Ubuntu):
status: Triaged → New
status: New → Incomplete
status: Incomplete → Opinion
status: Opinion → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Changed in ndiswrapper (Ubuntu Precise):
status: Confirmed → New
status: New → Incomplete
status: Incomplete → Invalid
status: Invalid → Confirmed
status: Confirmed → In Progress
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Daniel Letzeisen (dtl131) wrote :

@piotr: please do not play with the status of bugs. It will not get them fixed faster.

Changed in ndiswrapper (Ubuntu Precise):
status: Fix Released → Triaged
Changed in ndiswrapper (Ubuntu):
status: Fix Released → Triaged
Changed in ndiswrapper (Ubuntu Quantal):
status: Confirmed → Triaged
Markus Billich (samsy9) on 2013-07-18
Changed in ndiswrapper (Ubuntu):
status: Triaged → Fix Committed
Changed in ndiswrapper (Ubuntu Precise):
status: Triaged → Fix Committed
Changed in ndiswrapper (Ubuntu Quantal):
status: Triaged → Fix Committed
Changed in ndiswrapper (Ubuntu):
status: Fix Committed → Triaged
Changed in ndiswrapper (Ubuntu Precise):
status: Fix Committed → Triaged
Changed in ndiswrapper (Ubuntu Quantal):
status: Fix Committed → Triaged
prospero (prosperoelcazador) wrote :

en vez de discutir seria bueno aclarar la solucion
Building module:
cleaning build area....
make KERNELRELEASE=3.5.0-37-generic KVERS=3.5.0-37-generic......(bad exit status: 2)
ERROR (dkms apport): binary package for ndiswrapper: 1.58 not found
Error! Bad return status for module build on kernel: 3.5.0-37-generic (x86_64)
Consult /var/lib/dkms/ndiswrapper/1.58/build/make.log for more information.

Así se ve de mal en mi maquina

etcpp (rwkcf) wrote :

## Summary for Ubuntu 12.04 LTS 32-bit (kernel 3.8.0-31) ##

== Update repository cache and upgrade your OS ==
sudo update
sudo apt-get upgrade
sudo apt-get dist-upgrade

== Prepare build process ==
sudo apt-get install build-essential dkms

-> make sure ndiswrapper 1.57 is installed; have a look at:
     http://translate.google.com/translate?hl=en&ie=UTF8&prev=_t&sl=de&tl=en&u=http://wiki.ubuntuusers.de/WLAN/NdisWrapper

== Get sources in place ==
cd ~/tmp
wget http://downloads.sourceforge.net/project/ndiswrapper/stable/ndiswrapper-1.58.tar.gz
tar -xvf ndiswrapper-1.58.tar.gz

sudo mkdir /usr/src/ndiswrapper-1.58
sudo cp /tmp/ndiswrapper-1.58/driver/* /usr/src/ndiswrapper-1.58
sudo cp /usr/src/ndiswrapper-1.57/dkms.conf /usr/src/ndiswrapper-1.58

== Patch package version ==
sudo nano /usr/src/ndiswrapper-1.58/dkms.conf
-->patch line 2:
     -- PACKAGE_VERSION="1.57"
     ++ PACKAGE_VERSION="1.58"
    press:
     [ctrl] + x
     [enter]

== Remove previous ndiswrapper version ==
sudo dkms remove ndiswrapper/1.57 --all

== Build and Install ==
sudo dkms add ndiswrapper/1.58
sudo dkms build ndiswrapper/1.58
sudo dkms install ndiswrapper/1.58

== Test ==
modprobe ndiswrapper

== Remarks ==
All thanks go to Roger Olivé (post #3)

I put a "fixed" (I hope) version of ndiswrapper in my PPA:
https://launchpad.net/~mathieu-tl/+archive/sru-staging/+sourcepub/3710533/+listing-archive-extra

Use the following to install:

sudo add-apt-repository ppa:mathieu-tl/sru-staging
sudo apt-get update
sudo apt-get install ndiswrapper

And let me know if it builds and works fine for you. Unfortunately, I just don't have the necessary hardware to be able to test it here just yet.

Changed in ndiswrapper (Ubuntu Precise):
status: Triaged → In Progress
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Download full text (21.8 KiB)

Hi,

I attempted to install your fix but the install failed. It appears that
ndiswrapper was not in the PPA.

Documentation below.

Thank you for your help,
Andy

On Fri, 2013-12-06 at 20:23 +0000, Mathieu Trudel-Lapierre wrote:
> I put a "fixed" (I hope) version of ndiswrapper in my PPA:
> https://launchpad.net/~mathieu-tl/+archive/sru-staging/+sourcepub/3710533/+listing-archive-extra
>
> Use the following to install:
>
> sudo add-apt-repository ppa:mathieu-tl/sru-staging
> sudo apt-get update
> sudo apt-get install ndiswrapper
>
> And let me know if it builds and works fine for you. Unfortunately, I
> just don't have the necessary hardware to be able to test it here just
> yet.
>
> ** Changed in: ndiswrapper (Ubuntu Precise)
> Status: Triaged => In Progress
>
> ** Changed in: ndiswrapper (Ubuntu Precise)
> Assignee: (unassigned) => Mathieu Trudel-Lapierre (mathieu-tl)
>

andrew@andrew-pc:~$ sudo add-apt-repository ppa:mathieu-tl/sru-staging
[sudo] password for andrew:
Sorry, try again.
[sudo] password for andrew:
 Pre-testing potential SRU fixes prior to upload to -proposed
 More info: https://launchpad.net/~mathieu-tl/+archive/sru-staging
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmp0al5rx/secring.gpg' created
gpg: keyring `/tmp/tmp0al5rx/pubring.gpg' created
gpg: requesting key 28E03278 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp0al5rx/trustdb.gpg: trustdb created
gpg: key 28E03278: public key "Launchpad PPA for Matt Trudel" imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK
andrew@andrew-pc:~$ sudo apt-get update
Ign http://dl.google.com stable InRelease
Get:1 http://dl.google.com stable Release.gpg [198
B]
Get:2 http://dl.google.com stable Release [1,347
B]
Get:3 http://dl.google.com stable/main amd64 Packages [1,211
B]
Ign http://security.ubuntu.com saucy-security
InRelease
Ign http://archive.canonical.com saucy
InRelease
Ign http://extras.ubuntu.com saucy
InRelease
Ign http://ppa.launchpad.net quantal
InRelease
Ign http://us.archive.ubuntu.com saucy
InRelease
Get:4 http://dl.google.com stable/main i386 Packages [1,217
B]
Get:5 http://security.ubuntu.com saucy-security Release.gpg [933
B] ...

Andybrmn,

ndiswrapper for Saucy isn't in the PPA. I've only built the pacakge for Precise. Saucy already has ndiswrapper 1.58 which should already work properly for kernels 3.8 and above.

See https://launchpad.net/ubuntu/+source/ndiswrapper/1.58-2. You need to have the universe component enabled for Saucy.

Andybrmn (andybrmn) wrote :

Thank you very much for your help.

I no longer have need of wireless coms so you can drop me off the
problem list or direct me how to drop myself off.

Again thank you,
Andy

On Sat, 2013-12-07 at 05:15 +0000, Mathieu Trudel-Lapierre wrote:
> Andybrmn,
>
> ndiswrapper for Saucy isn't in the PPA. I've only built the pacakge for
> Precise. Saucy already has ndiswrapper 1.58 which should already work
> properly for kernels 3.8 and above.
>
> See https://launchpad.net/ubuntu/+source/ndiswrapper/1.58-2. You need to
> have the universe component enabled for Saucy.
>

le mouellic (mouellj) wrote :
Download full text (23.8 KiB)

Hi,

ndiswrapper-dkms 1.58 has fixed my problem about the application "ubuntu tweak" on xubuntu 12.10 when i closed it.
i have installed a pci wifi card before and uninstalled after without uninstalled the driver. May be is the cause of my problem.
Now i have upgraded on xubuntu 13.04 with ndiswrapper-dkms 1.58 installed and the problem hasn't appearred.
thank you for your help
best regards.

Joël LE MOUËLLIC

----- Mail original -----
De: "Andybrmn" <email address hidden>
À: <email address hidden>
Envoyé: Vendredi 6 Décembre 2013 22:04:16
Objet: Re: [Bug 1023645] Re: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build [error:‘struct kernel_stat’has no member named‘cpustat’]

Hi,

I attempted to install your fix but the install failed. It appears that
ndiswrapper was not in the PPA.

Documentation below.

Thank you for your help,
Andy

On Fri, 2013-12-06 at 20:23 +0000, Mathieu Trudel-Lapierre wrote:
> I put a "fixed" (I hope) version of ndiswrapper in my PPA:
> https://launchpad.net/~mathieu-tl/+archive/sru-staging/+sourcepub/3710533/+listing-archive-extra
>
> Use the following to install:
>
> sudo add-apt-repository ppa:mathieu-tl/sru-staging
> sudo apt-get update
> sudo apt-get install ndiswrapper
>
> And let me know if it builds and works fine for you. Unfortunately, I
> just don't have the necessary hardware to be able to test it here just
> yet.
>
> ** Changed in: ndiswrapper (Ubuntu Precise)
> Status: Triaged => In Progress
>
> ** Changed in: ndiswrapper (Ubuntu Precise)
> Assignee: (unassigned) => Mathieu Trudel-Lapierre (mathieu-tl)
>

andrew@andrew-pc:~$ sudo add-apt-repository ppa:mathieu-tl/sru-staging
[sudo] password for andrew:
Sorry, try again.
[sudo] password for andrew:
 Pre-testing potential SRU fixes prior to upload to -proposed
 More info: https://launchpad.net/~mathieu-tl/+archive/sru-staging
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmp0al5rx/secring.gpg' created
gpg: keyring `/tmp/tmp0al5rx/pubring.gpg' created
gpg: requesting key 28E03278 from hkp server keyserver.ubuntu.com
gpg: /tmp/tmp0al5rx/trustdb.gpg: trustdb created
gpg: key 28E03278: public key "Launchpad PPA for Matt Trudel" imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK
andrew@andrew-pc:~$ sudo apt-get update
Ign http://dl.google.com stable InRelease
Get:1 http://dl.google.com stable Release.gpg [198
B]
Get:2 http://dl.google.com stable Release [1,347
B]
Get:3 http://dl.google.com stable/main amd64 Packages [1,211
B]
Ign http://security.ubuntu.com saucy-security
InRelease
Ign http://archive.canonical.com saucy
InRelease
Ign http://ext...

Hi,

ndiswrapper-dkms 1.58 has fixed my problem about the application "ubuntu tweak" on xubuntu 12.10 when i closed it.
i have installed a pci wifi card before and uninstalled after without uninstalled the driver. May be is the cause of my problem.
Now i have upgraded on xubuntu 13.04 with ndiswrapper-dkms 1.58 installed and the problem hasn't appearred.
thank you for your help
best regards.

Joël LE MOUËLLIC

----- Mail original -----
De: "Launchpad Bug Tracker" <email address hidden>
À: <email address hidden>
Envoyé: Vendredi 6 Décembre 2013 05:50:40
Objet: [Bug 1023645] Re: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]

** Branch linked: lp:~mathieu-tl/ubuntu/precise/ndiswrapper/kernel3.8

--
You received this bug notification because you are subscribed to a
duplicate bug report (1257214).
https://bugs.launchpad.net/bugs/1023645

Title:
  ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to
  build [error: ‘struct kernel_stat’ has no member named ‘cpustat’]

Status in “ndiswrapper” package in Ubuntu:
  Triaged
Status in “ndiswrapper” source package in Precise:
  Triaged
Status in “ndiswrapper” source package in Quantal:
  Triaged

Bug description:
  WORKAROUND: https://launchpad.net/~crass/+archive/ndiswrapper

  rebooted after an update in ubuntu12.10

  ProblemType: Package
  DistroRelease: Ubuntu 12.10
  Package: ndiswrapper-dkms 1.57-1ubuntu1
  ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
  Uname: Linux 3.0-3-generic x86_64
  ApportVersion: 2.3-0ubuntu4
  Architecture: amd64
  DKMSKernelVersion: 3.5.0-4-generic
  Date: Wed Jul 11 23:24:17 2012
  InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027.1)
  PackageArchitecture: all
  PackageVersion: 1.57-1ubuntu1
  SourcePackage: ndiswrapper
  Title: ndiswrapper-dkms 1.57-1ubuntu1: ndiswrapper kernel module failed to build
  UpgradeStatus: Upgraded to quantal on 2012-07-08 (2 days ago)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/ndiswrapper/+bug/1023645/+subscriptions

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers