ndisgtk can't configure wireless network in kde

Bug #93808 reported by cowboy777 on 2007-03-19
12
Affects Status Importance Assigned to Milestone
ndisgtk
Medium
Julian Andres Klode
ndisgtk (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: ndisgtk

Using the latest ndiswrapper and ndisgtk for Feisty.
I'm able to add the "windows" network adapter by clicking on the <Install New Driver> button in the ndiskgtk dialog.
When I click on <Configure Network> nothing happens. I closed ndiskgtk and opened it from Konsole.
If I then click <Configure Network> an error is displayed:
sh: network-admin: not found
I've not been able to locate a package by that name.
The following ndis packages are installed:
ndisgtk 0.6-0ubuntu1
ndiswrapper-common 1.30-1ubuntu1
ndiswrapper-utils 1.1-5
ndiswrapperutils-1.1 1.1-5

You seem to be using Kubuntu. The button opens a Gnome application which is not shipped by Kubuntu (gnome-system-tools).

You can configure your wlan interface with kde tools.

Andreas Gnau (rondom) wrote :

How do other apps deal with such issues? What about greying out or hiding the button if network-admin isn't installed?

VF (vfiend) on 2007-04-20
Changed in ndisgtk:
status: Unconfirmed → Confirmed
Julian Andres Klode (juliank) wrote :

Try: "ndisgtk --kde"

Changed in ndisgtk:
assignee: nobody → juliank
importance: Undecided → Low
status: Unconfirmed → Confirmed
Changed in ndisgtk:
importance: Low → Medium
status: Confirmed → In Progress
Julian Andres Klode (juliank) wrote :

Fix:
 One .desktop file for kde where we call the program with --kde
 The other file for non-kde

Since I'm upstream now, I will fix this upstream tomorrow.

Changed in ndisgtk:
status: In Progress → Confirmed
Julian Andres Klode (juliank) wrote :

Fixed in trunk. Will be released as 0.7.1 soon.

Changed in ndisgtk:
status: Confirmed → Fix Committed
Julian Andres Klode (juliank) wrote :

0.7.1 Released

Changed in ndisgtk:
status: Fix Committed → Fix Released
Julian Andres Klode (juliank) wrote :

0.7.1-3ubuntu1 adds ndisgtk-kde.desktop, which calls ndisgtk with the --kde argument

Changed in ndisgtk:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers