ndisgtk doesn't install driver

Bug #45909 reported by Matthew Lange on 2006-05-21
10
Affects Status Importance Assigned to Milestone
Baltix
Medium
Mantas Kriaučiūnas
ndisgtk (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ndisgtk

Hi

After opening ndisgtk and using the option to "install new driver", and selecting a proper driver .inf file, it doesn't get added to the "Currently Installed Windows Drivers" list.

Edit: I had the drivers in my home directory, and it didn't work. I moved them to /etc/ndiswrapper/ and installed them by ndiswrapper -i /etc/ndiswrapper/bcmwl5.inf and now it shows up in ndisgtk. I'm not sure whether it was the directory change that made a difference, or whether it was the manual install of the driver.

description: updated
Mantas Kriaučiūnas (mantas) wrote :

There should be more user-friendly way to find this closed source network drivers installation/configuration tool, maybe name of menu launcher should be "Network drivers from Windows" not "Windows wireless drivers", because first word in launcher's name should reflect tool's main purpose, also ndiswrapper in not only for wireless drivers, look http://ndiswrapper.sf.net :
"Although ndiswrapper is intended for wireless network cards, other devices are known to work: e.g., USB to serial port device, *ethernet card*, home phone *network device*, etc."

Best decision would be to integrate ndisgtk into official network config tool - network-admin (from gnome-system-tools package), I think.

Btw, working ndisgtk tool ASAP should be included in Baltix GNU/Linux distro as default, I think

Alistair Crust (alistair.crust) wrote :

I think this may be linked to bug #59983

pirast (pirast) wrote :
Changed in ndisgtk:
assignee: nobody → pirast
status: Unconfirmed → In Progress
assignee: pirast → nobody
status: In Progress → Confirmed
pirast (pirast) wrote :

Fix commited by Paul Sladen :)

Changed in ndisgtk:
status: Confirmed → Fix Committed
pirast (pirast) on 2007-03-25
Changed in ndisgtk:
status: Fix Committed → Fix Released
Paul Sladen (sladen) wrote :

 ndisgtk (0.6-0ubuntu2) feisty; urgency=low
 .
   * Depend on ndiswrapper-utils-1.9 in order to make it possible to remove ndiswrapper-utils-1.1 from the archives
   * Change I to i in ndisgtk in order to work with ndiswrapper-utils-1.9
     (Closes LP #45909)

Przemek K. (azrael) on 2009-11-20
Changed in baltix:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers