ndisgtk can't remove installed driver

Bug #108656 reported by Ari on 2007-04-21
8
Affects Status Importance Assigned to Milestone
ndisgtk
Critical
Julian Andres Klode
ndisgtk (Ubuntu)
Undecided
Unassigned
Nominated for Dapper by Roelof

Bug Description

Binary package hint: ndisgtk

ndisgtk can install a new driver (although, curiously, it always reports the hardware is not present, i'll open another bug for that).

But ndisgtk can not remove the driver just installed. When hitting the "Remove button", it asks for confirmation, when I hit OK, the driver stays there. The only way I could remove it is in a terminal, with ndiswrapper -r driver_name

This was tested with feisty's ndiswrapper 1.38, and then with the newest ndiswrapper 1.42

My chipset is rt2500. The hardware is definitely there as can be see below:

 sudo lshw -C network

  *-network:1
       description: Wireless interface
       product: RT2500 802.11g Cardbus/mini-PCI
       vendor: RaLink
       physical id: a
       bus info: pci@02:0a.0
       logical name: ra0
       version: 01
       serial: 00:12:17:86:ad:3e
       width: 32 bits
       clock: 33MHz
       capabilities: bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ndiswrapper driverversion=1.42 firmware=Linksys,07/29/2004, 2.02.07.000 ip=192.168.1.200 latency=64 link=yes multicast=yes wireless=IEEE 802.11g
       resources: iomemory:f7efc000-f7efdfff irq:19

Thanks

Andreas Gnau (rondom) wrote :

Please provide a link to the driver.

Ari (ari-reads) wrote :

Here's the link to the ralink drivers:

http://files-upload.com/181160/wlan-drivers.tar.bz2.html

you have to wait 20secs for the actual link to show up.

The drivers work fine with ndiswrapper 1.42 in feisty (I'm using them now!) And I've used them for two years with breezy / dapper and edgy.

thanks

I can confirm this for drivers for the Negear WG311v3 as well. Immediatetly after my Feisty upgrade, I was actually showing two installed drivers (only one before upgrade), and neither could be removed (nor could I add anything). The GTK interface was basically just dead. I suspect this is related to broader ndiswrapper issues that are being reported in other bugs.

Julian Andres Klode (juliank) wrote :

The problem seems to be that we call ndiswrapper -e <driver> to remove drivers, instead of ndiswrapper -r <driver>.
Will fix this tomorrow in ndisgtk upstream.

Julian

Changed in ndisgtk:
assignee: nobody → juliank
importance: Undecided → High
status: Unconfirmed → Confirmed
Julian Andres Klode (juliank) wrote :

I think I am wrong.
I will look at this, and try to fix this if the problem is related to ndisgtk.

Changed in ndisgtk:
status: Confirmed → Fix Committed
status: Fix Committed → In Progress
Julian Andres Klode (juliank) wrote :

Fixed in trunk. (<email address hidden>)

Changed in ndisgtk:
status: In Progress → Fix Committed
Changed in ndisgtk:
status: Unconfirmed → Confirmed
Julian Andres Klode (juliank) wrote :

Fixed in 0.7.1

Changed in ndisgtk:
status: Fix Committed → Fix Released
Julian Andres Klode (juliank) wrote :

ndisgtk 0.7.1-3ubuntu1 has been uploaded to Gutsy. The bug has been fixed upstream in Version 0.7.1

Changed in ndisgtk:
status: Confirmed → Fix Released
Adam Niedling (krychek) wrote :

I'm reopening this bug because it's happening to me in updated Hardy. (Ndisgtk 0.8.2-1ubuntu1.) I have Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02) wlan card. I installed two different drivers because the first one wasn't the right one. Afterward I wasn't able to uninstall any of them. The right one was NETw4x32.INF, the wrong one was NETw4k32.INF
The next time I turned on my laptop I got everything from kernel panic to just some random freezes during boot time. Luckily one time it was able to boot and i was able to remove the whole ndiswrapper stuff. Now it's booting fine, but i don't have wifi though..

Changed in ndisgtk:
status: Fix Released → New
Julian Andres Klode (juliank) wrote :

Fixed in 0.8.3. Will be uploaded soon.

Changed in ndisgtk:
importance: High → Critical
status: Fix Released → Fix Committed
Adam Niedling (krychek) wrote :

Great, that was quick! :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ndisgtk - 0.8.3-1

---------------
ndisgtk (0.8.3-1) unstable; urgency=low

  * New upstream bugfix release
    - Fix removal of installed drivers (LP: #108656)
    - Use gksu/kdesu in desktop files
  * debian/rules:
    - Use su-to-root only if /etc/lsb-release does not exist or does not
      contain Ubuntu (Ubuntu has a /etc/lsb-release in base-files)

 -- Julian Andres Klode <email address hidden> Mon, 31 Mar 2008 16:25:31 +0100

Changed in ndisgtk:
status: New → Fix Released
Changed in ndisgtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers