Fix up ndctl upgrade from cosmic to disco

Bug #1804725 reported by Jeremy Bicha on 2018-11-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ndctl (Ubuntu)
High
Unassigned

Bug Description

I synced Debian's new ndctl package. It needs several pieces of work:

- Ubuntu had autopkgtests
- Ubuntu had a separate daxctl package. Debian either needs that package added or Breaks/Replaces added for the file move (from Ubuntu's perspective)
- Debian ships /usr/include/ndctl/libdaxctl.h in its libdaxctl-dev package. That sounds right to me but we need Breaks/Replaces for the file move
- Debian has a wrong Build-Depends on libuuid1 (the Build-Depends on uuid-dev is sufficient and better if the uuid soname is bumped.)
- Debian named its -dev packages wrongly. There is already a Debian bug for that issue and I already renamed them back for the Ubuntu package only at this time.
- Ubuntu's debian/copyright may be better.

I'm filing this bug in case I don't get around to handling these issues in Debian myself.

Jeremy Bicha (jbicha) on 2018-11-23
tags: added: disco
Jeremy Bicha (jbicha) on 2018-11-23
description: updated
Andreas Hasenack (ahasenack) wrote :

Other regressions include:
- standards version downgraded from 4.1.5 to 3.9.8
- lintian issues went from 1 in cosmic to 24 in disco (-I --pedantic, which is what was required to be clean before an AA would accept the package)

Also note that the new ndctl-monitor service won't start if you don't have the hardware available:
...
Setting up ndctl (63-1.2ubuntu1) ...
Job for ndctl-monitor.service failed because the control process exited with error code.
See "systemctl status ndctl-monitor.service" and "journalctl -xe" for details.
Processing triggers for man-db (2.8.4-3) ...
root@disco-ndctl:~# echo $?
0

But at least it doesn't fail dpkg.

Jeremy Bicha (jbicha) wrote :

I think I fixed the major issues now.

https://launchpad.net/ubuntu/+source/ndctl/63-1.2ubuntu2

I kept using Ubuntu's debian/copyright since the Debian version has several Lintian warnings and I think a full copyright review (and 3-way merge of the copyright files) would take a significant amount of time for this package.

Here are the remaining Lintian warnings. The systemd one is an upstream issue.

I: ndctl source: quilt-patch-missing-description avoid_modprobe_test.patch
P: ndctl source: debian-watch-does-not-check-gpg-signature
I: ndctl: systemd-service-file-missing-documentation-key lib/systemd/system/ndctl-monitor.service

I apologize for the extra headache that my upload caused you today. I need to be more careful in uploading new Debian packages over existing Ubuntu ones.

Changed in ndctl (Ubuntu):
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ndctl - 63-1.2ubuntu2

---------------
ndctl (63-1.2ubuntu2) disco; urgency=medium

  * Restore Ubuntu's autopkgtests (LP: #1804725)
  * Restore Ubuntu's README files
  * Restore Ubuntu's daxctl package
  * Add Breaks/Replaces for moved header file
  * Use Ubuntu package descriptions
  * Drop wrong direct Build-Depends on libuuid1
  * Also clean up test/test_dax_data created by tests
  * Bump Standards-Version to 4.2.1
  * Continue using Ubuntu's debian/copyright

 -- Jeremy Bicha <email address hidden> Fri, 23 Nov 2018 09:03:36 -0500

Changed in ndctl (Ubuntu):
status: Fix Committed → Fix Released
Andreas Hasenack (ahasenack) wrote :

Thanks for fixing it so quickly, much appreciated.

Jeremy Bicha (jbicha) wrote :

Andreas, I've pushed the fixes to Debian now too so we are in sync. Sorry again for my bad sync earlier.

Andreas Hasenack (ahasenack) wrote :

Thanks for this.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers