NCURSES not found while compiling VLC

Bug #1050341 reported by balagopalan gundeboiana

This bug report was converted into a question: question #208497: NCURSES not found while compiling VLC.

6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ncurses (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,
      Iam trying to compile latest VLC on my ubuntu machine using the help of http://wiki.videolan.org/UnixCompile.
NCURSES is installed in my machine, also when i try to do a apt-get it says newer version is already available

but when i do ./configure in my vlc folder.i get following error.

checking libtar.h presence... yes
checking for libtar.h... yes
checking for NCURSES... no
configure: error: Package tinfo was not found in the pkg-config search path.
Perhaps you should add the directory containing `tinfo.pc'
to the PKG_CONFIG_PATH environment variable
Package 'tinfo', required by 'ncursesw', not found.

any help is greatly appreciated.

regards,

description: updated
description: updated
description: updated
description: updated
Revision history for this message
Jason Conti (jconti) wrote :

This really appears to be more of a question than a bug report, so I am going to convert it into a question.

Looking at the output from configure, it appears that you need to install the package: libtinfo-dev

If you scroll down a bit in http://wiki.videolan.org/UnixCompile under the heading "The preferred method", there is a command:

sudo apt-get build-dep vlc

Which if you have the source repositories enabled (in software-properties-gtk make sure the Source Code box is ticked) should get you most of the libraries required to compile VLC.

Hope that helps.

Changed in ncurses (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions