please sync nbd-server from unstable to fix SIGSEGV

Bug #122544 reported by Pavel Mlčoch on 2007-06-27
48
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nbd (Ubuntu)
Medium
Oliver Grawert

Bug Description

crash alone in background

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Wed Jun 27 12:04:43 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /bin/nbd-server
NonfreeKernelModules: fglrx
Package: nbd-server 1:2.9.3-3ubuntu1
PackageArchitecture: i386
ProcCmdline: /bin/nbd-server
ProcCwd: /
ProcEnviron: PATH=/sbin:/bin:/usr/sbin:/usr/bin
Signal: 11
SourcePackage: nbd
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: nbd-server crashed with SIGSEGV
Uname: Linux mlcochff 2.6.22-7-generic #1 SMP Mon Jun 25 17:33:14 GMT 2007 i686 GNU/Linux
UserGroups:

Pavel Mlčoch (pavkamlc) wrote :

StacktraceTop:main (argc=) at nbd-server.c:1546
?? ()
?? ()
?? ()
?? ()

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nbd:
importance: Undecided → Medium
status: New → Incomplete
Scott Balneaves (sbalneav) wrote :

The problem is the testing of the variable "serve" when it's not initialized, owing to the default config file being empty (as it should be), and no comand line arguments.

The following patch fixes the problem:

--- nbd-2.9.3/nbd-server.c 2007-07-15 22:05:36.000000000 -0500
+++ nbd-2.9.3.1/nbd-server.c 2007-07-15 22:04:21.000000000 -0500
@@ -1527,7 +1527,7 @@
  * Main entry point...
  **/
 int main(int argc, char *argv[]) {
- SERVER *serve;
+ SERVER *serve=NULL;
        GArray *servers;
        GError *err=NULL;

@@ -1550,7 +1550,7 @@
        }

 /* We don't support this at this time */
- if (!(serve->port)) {
+ if (serve && !(serve->port)) {
                CLIENT *client;
 #ifndef ISSERVER
                /* You really should define ISSERVER if you're going to use

Changed in nbd:
status: Incomplete → Confirmed
Jan Claeys (janc) wrote :

Wouter Verhelst just told me that a nasty segfault bug in nbd-server should be fixed in his latest Debian package and asked me to signal this to the Ubuntu developers. You might want to merge from Debian...

http://packages.debian.org/changelogs/pool/main/n/nbd/nbd_2.9.6-1/changelog

 nbd (1:2.9.6-1) unstable; urgency=low

   * New upstream (brown paper bag) release, that really fixes the segfault
     this time.

 -- Wouter Verhelst <email address hidden> Thu, 19 Jul 2007 12:04:22 +0200

Martin Pitt (pitti) on 2007-08-08
Changed in nbd:
assignee: nobody → ogra
Oliver Grawert (ogra) wrote :

turning that into a sync request, full changelog since 2.9.3-3 below, archive team: please sync 2.9.6-1 from debian sid, all ubuntu changes are merged upstream.

----
nbd (1:2.9.6-1) unstable; urgency=low

   * New upstream (brown paper bag) release, that really fixes the segfault
     this time.

 -- Wouter Verhelst <email address hidden> Thu, 19 Jul 2007 12:04:22 +0200
nbd (1:2.9.5-1) unstable; urgency=low

   * New upstream release
     - Fixes segfault in nbd-server

 -- Wouter Verhelst <email address hidden> Tue, 17 Jul 2007 09:34:26 +0200
nbd (1:2.9.4-2) unstable; urgency=low

   * Generate dependencies for nbd-client-udeb, too

 -- Wouter Verhelst <email address hidden> Fri, 13 Jul 2007 03:58:33 +0200
nbd (1:2.9.4-1) unstable; urgency=low

   * New upstream release
     - Contains r258 proper
     - Contains fix for and re-enables inetd mode. Hi, LTSP! Closes: #317888
   * Modify debian/rules' clean: target to make lintian happy.

 -- Wouter Verhelst <email address hidden> Mon, 25 Jun 2007 20:51:30 +0100

Changed in nbd:
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :

synced

Changed in nbd:
status: In Progress → Fix Released
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers