Move to trash undoing fails when path contains Scandinavian letters

Bug #973620 reported by Jani Uusitalo on 2012-04-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Steps to reproduce:
1. touch ~/foo_åäö
2. In Nautilus, point at the file created in step 1
3. Right-click for context menu
4. Select Move to Trash
5. Press Ctrl-Z/Select Undo from the Edit menu

What happens:
Nothing

What I expect to happen:
For the file to recover from trash to ~.

What works:
* Undoing Move to Trash with files with no scandinavian letters in their path/filename.
* Recovering foo_åäö by opening Trash and selecting Recover from context menu.

More info:
* Could be that more characters, perhaps all non-ASCII characters render Nautilus' Undo impotent — I've only tested å, ä and ö.
* The Finnish translation for Desktop (~/Desktop) is Työpöytä, which means files moved to trash from Desktop can't be recovered. Nasty.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.4.0-0ubuntu1
Uname: Linux 3.3.0-030300rc4-generic x86_64
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
CheckboxSubmission: 09ae689090491ca53449589269e4bfd8
CheckboxSystem: edda5d4f616ca792bf437989cb597002
Date: Wed Apr 4 20:50:47 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: nautilus
UpgradeStatus: Upgraded to precise on 2011-11-21 (135 days ago)

Related branches

Jani Uusitalo (uusijani) wrote :
summary: - Move to trash undoing fails when path contains scandinavian letters
+ Move to trash undoing fails when path contains Scandinavian letters
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → High
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
status: New → Fix Released
Changed in nautilus (Ubuntu Precise):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.0-0ubuntu3

---------------
nautilus (1:3.4.0-0ubuntu3) precise; urgency=low

  * debian/patches/dont_wrap_labels_after_dots.patch:
    - don't wrap labels after a dot if they are followed by a number,
      the upstream code has a hack for 3 digit version numbers which
      doesn't really make sense (lp: #942539)
  * debian/patches/git_utf_undo.patch:
    - git patch, fix undo failing to restore files with non ascii chars
      (lp: #973620)
 -- Sebastien Bacher <email address hidden> Sun, 15 Apr 2012 11:46:05 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.