commit to fix "Don't hide Open With applications for subtypes of application/x-desktop" also removed "Open with" on directories

Bug #964186 reported by Doug McMahon on 2012-03-24
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

The context menu option to open folders with something other than nautilus, while not necessary , is a useful option for many users.

The question would be was that part of the commit needed to fix the handling of 'non-desktop' desktop files such as index.theme

At least here, reverting the view part of the commit suggests it wasn't, an open with context menu option & ability to fully view & open a .theme file from nautilus seem to co-exist fine.

So the purpose of this report is that, did the context menu option need to be removed?

Commit in question
http://git.gnome.org/browse/nautilus/commit/?id=b9c51fd4eb84a9f52ee4be1bf183fc516984130b

code change in question

--- a/src/nautilus-view.c
+++ b/src/nautilus-view.c
@@ -4491,9 +4491,8 @@ reset_open_with_menu (NautilusView *view, GList *selection)
file = NAUTILUS_FILE (node->data);
- other_applications_visible &=
- (!nautilus_mime_file_opens_in_view (file) ||
- nautilus_file_is_directory (file));
+ other_applications_visible &= (!nautilus_mime_file_opens_in_view (file) &&
+ !nautilus_file_is_nautilus_link (file));
}
default_app = NULL;

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.92-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic-pae 3.2.12
Uname: Linux 3.2.0-20-generic-pae i686
ApportVersion: 1.95-0ubuntu1
Architecture: i386
Date: Sat Mar 24 18:09:36 2012
GsettingsChanges: org.gnome.nautilus.window-state geometry '1164x575+58+24'
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120323)
ProcEnviron:
 TERM=xterm
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) on 2012-03-25
description: updated
tags: added: regression-release
Doug McMahon (mc3man) on 2012-03-25
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Tom Pino (metalsmith-rangeweb) wrote :

Effects me to the point that I am going to be switching to Thunar.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

Sorry, the above didn't post as intended
https://bugzilla.gnome.org/show_bug.cgi?id=672809

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.0-0ubuntu1

---------------
nautilus (1:3.4.0-0ubuntu1) precise-proposed; urgency=low

  * New upstream version
    - Fix a regression where "Open With" was hidden for folders (lp: #964186)
 -- Sebastien Bacher <email address hidden> Mon, 26 Mar 2012 19:53:09 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.