Desktop icons display comments from desktop file in label

Bug #961141 reported by Jean-Baptiste Lallement on 2012-03-21
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
High
Canonical Desktop Team
Precise
High
Canonical Desktop Team

Bug Description

Precise Desktop 20120321

When a desktop file is displayed on the desktop, the label of the icon contains the comment from the desktop file.

For example on a live session (but it is not specific to the live session and the defect also exists on installed systems) the label of the 'Install Ubuntu' icon in French is : "Installer Ubuntu 12.04 LTS Installer ce systeme de ..." (see screenshot)

Editing the label only show the actual label in the input field.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CasperVersion: 1.312
Date: Wed Mar 21 13:57:28 2012
GsettingsChanges:

LiveMediaBuild: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120321)
ProcEnviron:
 TERM=xterm
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jean-Baptiste Lallement (jibel) wrote :
Changed in nautilus (Ubuntu):
status: New → Triaged
importance: Undecided → High
Ján Jušniar (jkusniar) wrote :

Same goes for updated install of precise (not a live media)

description: updated
Changed in nautilus (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
tags: added: regression-release
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/961141

tags: added: localized-iso
Changed in nautilus (Ubuntu Precise):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.92-0ubuntu2

---------------
nautilus (1:3.3.92-0ubuntu2) precise; urgency=low

  * debian/patches/revert_desktop_comment.patch:
    - revert git commit to change the .desktop handling code which leaded
      to have the filename displayed with the comment field next to it
      (lp: #961141)
 -- Sebastien Bacher <email address hidden> Thu, 22 Mar 2012 19:34:17 +0100

Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Released
Barry Drake (b-drake) wrote :

I confirm that the fix works for me. Thank you.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers