CTRL+Scrolling with mouse causes nautilus to crash with SIGABRT in raise()

Bug #949591 reported by Kevin Guertin on 2012-03-08
32
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
Medium
Unassigned

Bug Description

Reproducible.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.91-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.94-0ubuntu2
Architecture: amd64
Date: Wed Mar 7 21:01:26 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 org.gnome.nautilus.window-state geometry '800x550+396+319'
 org.gnome.nautilus.window-state maximized true
 org.gnome.nautilus.window-state sidebar-width 241
 org.gnome.nautilus.window-state start-with-status-bar true
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcCmdline: nautilus -n
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: nautilus
StacktraceTop:
 raise () from /lib/x86_64-linux-gnu/libc.so.6
 abort () from /lib/x86_64-linux-gnu/libc.so.6
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? ()
Title: nautilus crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Kevin Guertin (leonivek) wrote :
Kevin Guertin (leonivek) on 2012-03-08
visibility: private → public

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x514bc0 "nautilus_view_handle_scroll_event", message=0x7fe9da1cca60 "code should not be reached") at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1860
 nautilus_view_handle_scroll_event (directory_view=<optimized out>, event=<optimized out>) at nautilus-view.c:9486
 nautilus_view_scroll_event (widget=0x1c40000, event=0x16de3a0) at nautilus-view.c:9501
 _gtk_marshal_BOOLEAN__BOXEDv (closure=0x12f5450, return_value=0x7fffbf2463d0, instance=0x1c40000, args=<optimized out>, marshal_data=<optimized out>, n_params=<optimized out>, param_types=0x12f5480) at /build/buildd/gtk+3.0-3.3.18/./gtk/gtkmarshalers.c:130
 _g_closure_invoke_va (closure=0x12f5450, return_value=0x7fffbf2463d0, instance=0x1c40000, args=0x7fffbf246478, n_params=1, param_types=<optimized out>) at /build/buildd/glib2.0-2.31.20/./gobject/gclosure.c:840

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.91-0ubuntu4

---------------
nautilus (1:3.3.91-0ubuntu4) precise; urgency=low

  * debian/patches/git_handle_ctrl_scroll.patch:
    - don't run into an assert on ctrl-scroll (lp: #949591)
  * debian/patches/zg_activity_logging.patch:
    - updated version from Siegfried Gevatter, should fix lp: #947489
 -- Sebastien Bacher <email address hidden> Thu, 08 Mar 2012 19:29:58 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Changed in nautilus:
importance: Unknown → Critical
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.