nautilus crashed with SIGSEGV in _log_zeitgeist_event_for_file_cb()

Bug #947489 reported by Daniel Winzen on 2012-03-05
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Medium
Siegfried Gevatter

Bug Description

Nautilus crashed while moving a file from trash to it's original folder.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.90-0ubuntu6
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic-pae 3.2.9
Uname: Linux 3.2.0-18-generic-pae i686
ApportVersion: 1.94-0ubuntu1
Architecture: i386
Date: Mon Mar 5 21:59:36 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 org.gnome.nautilus.window-state geometry '800x549+798+322'
 org.gnome.nautilus.window-state maximized true
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120201.1)
ProcCmdline: nautilus -n
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x80ef27c: mov 0x8(%eax),%eax
 PC (0x080ef27c) ok
 source "0x8(%eax)" (0x00000009) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 g_simple_async_result_complete () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: nautilus crashed with SIGSEGV in g_simple_async_result_complete()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom debian-tor dip lpadmin plugdev sambashare sudo

Related branches

visibility: private → public

StacktraceTop:
 _log_zeitgeist_event_for_file_cb (source_object=0xa066ba0, res=0x9f6ae50, user_data=0x9f66098) at nautilus-file-operations.c:235
 g_simple_async_result_complete (simple=0x9f6ae50) at /build/buildd/glib2.0-2.31.20/./gio/gsimpleasyncresult.c:747
 complete_in_idle_cb_for_thread (_data=0xa14de68) at /build/buildd/glib2.0-2.31.20/./gio/gsimpleasyncresult.c:816
 g_source_get_priority (source=0xb1b09c00) at /build/buildd/glib2.0-2.31.20/./glib/gmain.c:1445
 g_main_context_get_poll_func (context=0xb1b09c00) at /build/buildd/glib2.0-2.31.20/./glib/gmain.c:3710

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
summary: - nautilus crashed with SIGSEGV in g_simple_async_result_complete()
+ nautilus crashed with SIGSEGV in _log_zeitgeist_event_for_file_cb()
tags: removed: need-i386-retrace
Changed in nautilus (Ubuntu):
assignee: nobody → Siegfried Gevatter (rainct)
Siegfried Gevatter (rainct) wrote :

I'm unable to reproduce this bug, but I've pushed a couple fixes to lp:~rainct/nautilus/nautilus-zg that I guess should fix this.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.91-0ubuntu4

---------------
nautilus (1:3.3.91-0ubuntu4) precise; urgency=low

  * debian/patches/git_handle_ctrl_scroll.patch:
    - don't run into an assert on ctrl-scroll (lp: #949591)
  * debian/patches/zg_activity_logging.patch:
    - updated version from Siegfried Gevatter, should fix lp: #947489
 -- Sebastien Bacher <email address hidden> Thu, 08 Mar 2012 19:29:58 +0100

Changed in nautilus (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers