Can't navigate Nautilus sidepane via keyboard

Bug #940951 reported by nick rundy on 2012-02-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Steps to Reproduce:

1.) open Nautilus
2.) press TAB and notice that the focus (i.e., orange highlight) lands on "Devices" in the sidepane
3.) try to navigate the sidepane by using the up/down keys = nothing happens (the orange highlight stays on "Devices"

The sidepane cannot be navigated by using the up/down keys until after the user uses the mouse to click on an item in the sidepane.

I've attached a screenshot showing how the orange-highlight is trapped on "Devices"

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.90-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic 3.2.6
Uname: Linux 3.2.0-17-generic i686
ApportVersion: 1.93-0ubuntu2
Architecture: i386
Date: Sat Feb 25 09:01:44 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 org.gnome.nautilus.window-state geometry '834x681+194+86'
 org.gnome.nautilus.window-state sidebar-width 208
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
SourcePackage: nautilus
UpgradeStatus: Upgraded to precise on 2012-02-21 (3 days ago)

Related branches

nick rundy (nrundy) wrote :
Bence Lukács (lukacs-bence1) wrote :

It works for me on Precise.
Nautilus: 3.3.90

Changed in nautilus (Ubuntu):
status: New → Confirmed
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Confirmed on current precise in a guest session

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in nautilus:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.92-0ubuntu1

---------------
nautilus (1:3.3.92-0ubuntu1) precise; urgency=low

  * New upstream version:
    - Fix scrolling in compact view to work with latest GTK
    - Fix Ctrl+Scroll zooming to work with latest GTK
    - Don't hide Open With applications for subtypes
      of application/x-desktop (lp: #38434)
    - Add support for the "network" GVolume class identifier
    - Fix a crash at exit with certain extensions that keep refs of
      the NautilusFileInfos (lp: #449796)
    - Fix initial focus row when moving the focus into the Places
      sidebar (lp: #940951)
    - Fix Shift+Click selection when going back/forward in browsing
      history (lp: #953245)
    - Fix packing of desktop file box in properties view
    - Fix pathbar button sizing when a file watched by the pathbar
      changes name (lp: #952648)
    - Fix properties window not being able to shrink size (lp: #948524)
    - Remove unused --enable-profiler configure option
    - Let drag the dialog by the toolbar (lp: #953004)
  * debian/patches/git_handle_ctrl_scroll.patch:
    - dropped, the fix is in the new version
  * debian/patches/12_unity_launcher_support.patch:
    - use correct capitalization, list the source in potfiles so it's
      translatable (lp: #958517)
  * drop appindicator patch, the option was turned off and it creates work
 -- Sebastien Bacher <email address hidden> Tue, 20 Mar 2012 11:19:52 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.