nautilus crashed with SIGSEGV in do_unmount()

Bug #937824 reported by odnanref62 on 2012-02-21
94
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Critical
nautilus (Ubuntu)
High
Michael Terry
Precise
High
Michael Terry

Bug Description

To reproduce:
1) Get an SD card or similar *non-thumb* drive
2) Insert it
3) Copy some file to it
4) Delete said file
5) Click the unmount icon in nautilus
6) A dialog will appear; say you want to empty trash before unmounting

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.90-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.92-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Tue Feb 21 15:30:33 2012
ExecutablePath: /usr/bin/nautilus
GsettingsChanges:
 org.gnome.nautilus.window-state geometry '958x1024+332+26'
 org.gnome.nautilus.window-state maximized true
 org.gnome.nautilus.window-state sidebar-width 204
 org.gnome.nautilus.window-state start-with-status-bar true
ProcCmdline: nautilus
SegvAnalysis:
 Segfault happened at: 0x80efebe: mov 0x8(%esi),%eax
 PC (0x080efebe) ok
 source "0x8(%esi)" (0x00000009) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
UpgradeStatus: Upgraded to precise on 2012-02-19 (2 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

odnanref62 (odnanref62) wrote :

StacktraceTop:
 do_unmount (data=0x1) at nautilus-file-operations.c:2071
 empty_trash_job_done (user_data=0x920be70) at nautilus-file-operations.c:6323
 mainloop_proxy_free (proxy=0x9284ef8) at /build/buildd/glib2.0-2.31.18/./gio/gioscheduler.c:301
 g_source_set_callback_indirect (source=0xb6d03a10, callback_data=0xb6b4cf16, callback_funcs=0x1) at /build/buildd/glib2.0-2.31.18/./glib/gmain.c:1245
 ?? () from /tmp/tmpHo1Lzb/lib/i386-linux-gnu/libglib-2.0.so.0

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
summary: - nautilus crashed with SIGSEGV in g_main_context_dispatch()
+ nautilus crashed with SIGSEGV in do_unmount()
tags: removed: need-i386-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
importance: Medium → High
Changed in nautilus (Ubuntu Precise):
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
importance: Medium → Critical
Michael Terry (mterry) wrote :

I think I see why this is. A mismatch between a callback use and its definition.

Changed in nautilus (Ubuntu Precise):
assignee: nobody → Michael Terry (mterry)
status: Triaged → In Progress
Michael Terry (mterry) on 2012-02-27
description: updated
Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.3.90-0ubuntu3

---------------
nautilus (1:3.3.90-0ubuntu3) precise; urgency=low

  * debian/patches/21_fix_crash_during_unmount.patch:
    - Fix callback prototype to not crash when emptying trash during an
      unmount. LP: #937824
 -- Michael Terry <email address hidden> Mon, 27 Feb 2012 15:33:08 -0500

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in nautilus:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.