'Media contains photos' message right-justified

Bug #932126 reported by Steve Magoun on 2012-02-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
High
Sebastien Bacher
Precise
Low
Unassigned
Quantal
High
Sebastien Bacher

Bug Description

TESTCASE:
- browse a music player or phone or camera device
- notice that the "device bar" label is right justified
- with the update it's left justified

Full description:

The buttons+text nautilus adds to windows for devices containing media is laid out poorly (see attached screenshot)

To reproduce:
1) Plug in a phone or USB drive containing media
2) In a nautilus window, navigate to the device from step #1

Expected results:
The Nautilus window has a message that "These files are on a digital audio player" with an "Open Rhythmbox Music Player" button, and/or a message that "The media contains digital photos" with an "Open Shotwell Photo Manager" button. The messages are left-justified within the nautilus window

Actual results:
The messages+buttons are right-justified within the nautilus window, which looks awkward (see screenshot). There are a couple specific problems:
* There is no padding between the right edge of the message and the edge of the window, so the text is jammed against the edge of the window which doesn't match the layout of any other text
* For left-to-right languages, the button comes before the explanatory text so you have to start reading in the middle of the line then jump back to the beginning of the line
* There is a funny stair-step effect of buttons within the window; they are not vertically aligned to anything

A better layout might be to move the explanatory text to the left of the buttons, left-justify the text, right-justify the buttons, and leave a space between the buttons + text that can expand as necessary with the size of the window.

Steve Magoun (smagoun) wrote :
Vadim Rutkovsky (roignac) wrote :
Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New
Changed in nautilus:
status: New → Fix Released
Changed in nautilus (Ubuntu Precise):
status: Triaged → In Progress
milestone: none → precise-updates
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in nautilus (Ubuntu Precise):
status: In Progress → Fix Committed
description: updated
Chris Halse Rogers (raof) wrote :

Is this fixed in the 3.5.1 we have in Quantal?

tags: added: verification-needed

Hello Steve, or anyone else affected,

Accepted nautilus into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Sebastien Bacher (seb128) wrote :

@Chris: no, it will be fixed in 3.5.2, pitti said it's ok to wait until the next version since the fix is already in upstream git and we can't miss it

Steve Magoun (smagoun) wrote :

Layout is much better with nautilus 1:3.4.2-0ubuntu1 from precise-proposed. Thank you!

tags: added: verification-done
removed: verification-needed
Martin Pitt (pitti) on 2012-05-24
Changed in nautilus (Ubuntu Quantal):
assignee: nobody → Sebastien Bacher (seb128)
milestone: none → quantal-alpha-2
importance: Low → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.2-0ubuntu1

---------------
nautilus (1:3.4.2-0ubuntu1) precise-proposed; urgency=low

  * New upstream version:
    - Fix a crasher when entering "http" addresses manually in
      the location bar (lp: #957800)
    - Fix button packing for media content cluebar (lp: #932126)
    - Don't remove selection when clicking on a row out of name boundaries
  * debian/patches/dont_wrap_labels_after_dots.patch: refreshed
 -- Sebastien Bacher <email address hidden> Tue, 15 May 2012 15:47:43 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Sebastien Bacher (seb128) wrote :

It's fixed with 3.5.2 in quantal

Changed in nautilus (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.