Off-by-one error in count of copied files

Bug #930944 reported by David Raymond Christiansen on 2012-02-12
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Low
nautilus (Ubuntu)
Low
Unassigned

Bug Description

When copying files, the "x of y" display at the bottom shows x-1 instead of x. In other words, when copying three files, it will count from "0 of 3" to "2 of 3" instead of "1 of 3" to "3 of 3".

It is possible that this only happens on copies to SMB-mounted drives - that is the only situation where I've been able to make it go slow enough to see.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.5-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-14.23-generic 3.2.3
Uname: Linux 3.2.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Sun Feb 12 13:40:38 2012
InstallationMedia: Kubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
SourcePackage: nautilus
UpgradeStatus: Upgraded to precise on 2012-02-06 (5 days ago)

Related branches

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Vadim Rutkovsky (roignac) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at https://bugzilla.gnome.org/show_bug.cgi?id=673345

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in nautilus:
importance: Unknown → Low
status: Unknown → New
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Changed in nautilus:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.4.0-0ubuntu2

---------------
nautilus (1:3.4.0-0ubuntu2) precise; urgency=low

  * debian/patches/git_copy_off_by_one.patch:
    - "Off-by-one error in count of copied files" (lp: #930944)
  * debian/patches/git_no_freespace_cpu_look.patch:
    - correct free space calculation and avoid cpu loops (lp: #965493)
 -- Sebastien Bacher <email address hidden> Thu, 05 Apr 2012 17:26:23 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.