Nautilus has no Bookmark target until CTRL+D

Bug #920691 reported by Cefn on 2012-01-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

Running a stock Oneiric version of Nautilus. I find that dragging Folders into the left pane never creates a bookmark.

Previously, I think I could drag folders 'in between' other folders in the left pane, seeing a black line indicating where the new bookmark would be placed.

Now it's impossible to find a drag/drop target which creates a bookmark from a stock Oneiric until first running the keyboard shortcut CTRL+D to add an item. Once an item exists, a Bookmarks section appears in the Nautilus left pane, and then I can drag subsequent bookmarks under this heading.

For Bookmarks to be a usable feature, there should be some kind of GUI-based technique to create them. Currently it requires deep understanding of Nautilus keyboard shortcuts to begin with.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.1-0ubuntu3.2
ProcVersionSignature: Ubuntu 3.0.0-15.25-generic-pae 3.0.13
Uname: Linux 3.0.0-15-generic-pae i686
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Mon Jan 23 22:20:35 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Cefn (6-launchpad-net-cefn-com) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's not a bug though

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Cefn (6-launchpad-net-cefn-com) wrote :

It's not a duplicate of the other bug it was linked to, so I have removed that link.

This is a feature regression, is confusing and inconsistent, (perhaps this doesn't qualify it as a bug).

The other 'bug' relates to not being able to use bookmarks for moving files/folders around the filesystem by dragging them onto Nautilus bookmarks (which was is a deliberate choice by Gnome).

My 'bug' is that it's impossible to even ADD a bookmark by dragging, which is the feature Gnome chose to preserve in this discussion! It only applies to the FIRST bookmark. Once you have added one folder, then drag-to-link becomes possible under the Bookmarks heading.

Even accepting the Gnomic logic about the ambiguity of drag-to-link versus drag-to-move, they chose to favour drag-to-link.

Making it impossible to drag-to-link the FIRST bookmark isn't consistent with their logic. It's to do with the build of Ubuntu which makes Home, Desktop, Documents, Downloads not 'Bookmarks', but something different under 'Computer' - a collection of shortcuts which prevent drag-to-link, and facilitate drag-to-move.

As it turns out, you can't create new items under the Computer heading at all, I think. Quite a mess.

Cefn (6-launchpad-net-cefn-com) wrote :

Sebastien has added back the duplicate flag I removed, even though this is incorrect. Indeed this is the direct opposite of the other bug, if you take into account the feature discussion at Gnome, which split bookmark drag functionality into two. The one they decided to preserve is broken by the bug I'm reporting, at least for the first bookmark.

I'll leave it to the team to decide how to manage their bugs. If they want to flag a different bug as the same thing that's their business. I would say it's harder to manage code this way, though.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Sebastien Bacher (seb128) wrote :

> Sebastien has added back the duplicate flag I removed

that's because you remove the flag without comment

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in nautilus (Ubuntu):
status: New → Triaged
Changed in nautilus:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in nautilus (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.5.1-0ubuntu6

---------------
nautilus (1:3.5.1-0ubuntu6) quantal; urgency=low

  * debian/patches/git_no_assert_on_double_mount.patch: lp: #1007593
    "sidebar: don't forget to NULL slot pointer after volume is mounted"
  * debian/patches/git_bookmark_place_dnd.patch: lp: #874386, #920691
    "places-sidebar: allow dropping of files to bookmarks"
  * debian/patches/git_no_menubars_segfault.patch: lp: #1003771
    "window-menus: disconnect from GtkSettings notifications on finalize"
 -- Sebastien Bacher <email address hidden> Tue, 12 Jun 2012 21:28:08 +0200

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.