New DVD Burner not appearing.

Bug #90666 reported by Oumar Aziz OUATTARA on 2007-03-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
hal (Ubuntu)
Undecided
Unassigned
nautilus (Ubuntu)
Low
Unassigned

Bug Description

I have just bought a new DVD burner and installed it on my system, but Ubuntu doesn't show it in the computer place. When I insert a cd inside , it doesn't recognize it :( .

Oumar Aziz OUATTARA (wattazoum) wrote :

I forgot to mention that I have tried on edgy and Feisty .

Onkar Shinde (onkarshinde) wrote :

Which DVD burner is it?

Oumar Aziz OUATTARA (wattazoum) wrote :

lshw shows me that :

The New burner is :
--
TSSTcorpCD/DVDW SH-S182D
/0/e0000000/11.1/0/1

product: TSSTcorpCD/DVDW SH-S182D
bus info: ide@0.1
logical name: /dev/hdb
capabilities:
 ATAPI packet device
--
The old is :
--
DVDRW DRW-3S165
/0/e0000000/11.1/1/0

product: DVDRW DRW-3S165
bus info: ide@1.0
logical name: /dev/hdc
capabilities:
 ATAPI packet device
--

I succeeded in making the new one react by using eject on the only DVD icon in the computer place (which I assumed was the old dvd burner ) . It actually ejected my new dvd burner. Then, I tried to put a cd in the old one, and the cd was detected . Now I am confused. I have 2 burners and 1 icon. which burner is really bind to that icon ?

Chris Rose (chris-vault5) wrote :

If you don't link the CD icon to the physical drive, it makes sense. The icons you see are the CD's (hence the CD icon) and not the drive. If no CD / DVDs are in the drives, you should see no CD icons in the 'Computer' folder.

If you are unsure about which CD a drive is in, right click the CD icon, click 'Properties' then 'Drive' and it will show you the details of the drive.

Does that clear things up?

> If you don't link the CD icon to the physical drive, it makes sense. The
> icons you see are the CD's (hence the CD icon) and not the drive. If no
> CD / DVDs are in the drives, you should see no CD icons in the
> 'Computer' folder.

Thanks for your help .

When I have no cd inside , I still have an icon (empty drive). :(

I have tricked the system by inserting 2 cd at the same time. That
forced the creation of a second icon. then after I eject both cds, I
still have my 2 icons ( changed to empty drive ) . I haven't reboot yet
so I don't know if my problem is now really off.

But that means we should try to get every drive we find show in the
computer place, cause if we don't , the pc owner hasn't the mastery of
what is on his computer (that 's remind me the way windows uses to make
things ) .

Chris Rose (chris-vault5) wrote :

Thanks. With no CDs in the drives you should probably still see two icons in 'Computer'. Can you please attach the output of the lshal command?

Oumar Aziz OUATTARA (wattazoum) wrote :

Well, after I rebooted I returned to the old behavior : one icon "empty drive" .

Oumar Aziz OUATTARA (wattazoum) wrote :

I have take a look at lshal ( that's my first time :p ) and I have seen :

 storage.policy.desired_mount_point = 'dvdrecorder' (string)

for both drive, so I guess there is no way to have the two of them appear at the same time . is it an HAL bug ?

Please provide the missing information described here: https://wiki.ubuntu.com/DebuggingRemovableDevices.

the burner is not a removable device, I connected it directlly via IDE .

Most debugging steps described apply for your IDE burner too, please provide the missing debugging information (the easy case is enough).

Well, Here is what I have done, I didn't want to put off my IDE drive cause I would have to dismount my computer .
So I make the steps by inserting CDs .

In that case, I have inserted 2 CDs one after another , so I got two drives in the computer place. I'll reboot and send the case I'll insert 1 CDs in a drive by a time.

hum, here comes the second case . I put one cd the removed it and put it on the second drive. then I put another cd in the first drive and, in the computer place there were only one icon but with the new cd (ie in the first drive) then I removed the cd in the second drive and then a second icon (empty drive) appeared.

That's very unstable behaviour. The problem should be considered more seriously.

Should be the natural behaviour .

This is either a hal bug or a bug in nautilus, adding both tasks to notify the relevant people.

Pedro Villavicencio (pedro) wrote :

Still an issue with Gutsy?

After getting your comment yesterday, I downloaded the GUTSY live cd from September 25th.? I didn't have time to burn nor install it though.
Should I make the test with the LiveCD our should I install the whole distro ?
First case will be fast ,
Second one will require more time

Best regards

Sebastien Bacher (seb128) wrote :

Testing using the CD should be enough

With both the CD and Full clean install, I got the same behaviour ( I see just one drive )

Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in hardy?

Sebastien Bacher (seb128) wrote :

that's not a nautilus bug

Changed in nautilus:
assignee: chris-vault5 → nobody
status: Incomplete → Invalid
Bobby (robert-rankin-jr) wrote :

Seems to have been abandoned

Changed in hal:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers