Ubuntu

With appmenus context-menu shortcut options in nautilus do not work properly. E.g. I need to press R twice to select Rename and then hit Return to select it.

Reported by Costis on 2011-11-27
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
AppMenu GTK+
High
Unassigned
appmenu-gtk (Ubuntu)
Low
Canonical Desktop Experience Team
Precise
Low
Canonical Desktop Experience Team
gtk+3.0 (Ubuntu)
Low
Albert Astals Cid
Precise
Low
Unassigned
nautilus (Ubuntu)
Low
Unassigned
Precise
Low
Unassigned

Bug Description

* Impact: Many of the context-menu shortcut options in nautilus (e.g. Rename, Properties, etc.) do not work properly

* test case:
- run nautilus
- open the context menu for a file/folder
- hit R, Rename is selected not triggered

* Regression potential:
check that gtk menus still work correctly

Costis (ccostis) wrote :
Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

ok, so I can confirm that here, it doesn't seem to happen if I quit nautilus, unset UBUNTU_MENUPROXY and run nautilus again, it seems to be due to the appmenu usage then

Changed in indicator-appmenu:
importance: Undecided → Low
assignee: nobody → Ted Gould (ted)
Changed in indicator-appmenu (Ubuntu):
importance: Undecided → Low
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
summary: - Many of the context-menu shortcut options in nautilus (e.g. Rename,
- Properties) do not work properly. E.g. I need to press R twice to select
- Rename and then hit Return to select it.
+ With appmenus context-menu shortcut options in nautilus do not work
+ properly. E.g. I need to press R twice to select Rename and then hit
+ Return to select it.
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Ted Gould (ted) on 2012-02-20
affects: indicator-appmenu (Ubuntu) → appmenu-gtk (Ubuntu)
affects: indicator-appmenu → appmenu-gtk
Changed in appmenu-gtk:
importance: Low → High
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in appmenu-gtk (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

Confirmed for nautilus for the P and R shortcuts in Nautilus' context menu.

It doesn't seem to be a universal problem. For example it doesn't happen in Transmission's context menus.

Gao Shichao (xgdgsc) wrote :

I manually blacklisted nautilus in the source code and it's fine for me. I cannot understand why so few people has found this bug annoying. It's still present in Quantal. This bug should really be fixed in Quantal since nautilus is so essential to the system.

Changed in appmenu-gtk:
assignee: Ted Gould (ted) → Albert Astals Cid (aacid)
status: Confirmed → In Progress
Albert Astals Cid (aacid) wrote :

Fixed in Quantal in gtk-3 3.5.18-0ubuntu2

Changed in appmenu-gtk (Ubuntu Precise):
status: Confirmed → Invalid
Changed in appmenu-gtk (Ubuntu):
status: Confirmed → Invalid
Changed in nautilus (Ubuntu):
status: Triaged → Invalid
Changed in nautilus (Ubuntu Precise):
status: Triaged → Invalid
Changed in appmenu-gtk:
status: In Progress → Invalid
assignee: Albert Astals Cid (aacid) → nobody
Changed in gtk+3.0 (Ubuntu):
status: New → Fix Released
Changed in gtk+3.0 (Ubuntu):
assignee: nobody → Albert Astals Cid (aacid)
Gao Shichao (xgdgsc) on 2012-10-08
Changed in gtk+3.0 (Ubuntu Precise):
status: New → Confirmed
Changed in gtk+3.0 (Ubuntu Precise):
importance: Undecided → Low
Changed in gtk+3.0 (Ubuntu):
importance: Undecided → Low
Changed in gtk+3.0 (Ubuntu Precise):
status: Confirmed → In Progress
description: updated

Hello Costis, or anyone else affected,

Accepted gtk+3.0 into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gtk+3.0/3.4.2-0ubuntu0.6 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+3.0 (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
katsu (yoko-katsu) wrote :

verify condition: ubuntu 12.04.3 in virtualbox

----------------------------------
test case:
- run nautilus
- open the context menu for a file/folder
- hit R, Rename is selected not triggered
  (R key twise to select rename & doesn't change to rename mode)
----------------------------------

enable precise-proposed & install libgtk-3-0 package.

$ sudo apt-get install -t precise-proposed libgtk-3-0
upgrade libgtk-3-bin 3.4.2-0ubuntu0.5 3.4.2-0ubuntu0.6
upgrade libgail-3-0 3.4.2-0ubuntu0.5 3.4.2-0ubuntu0.6
upgrade libgtk-3-0 3.4.2-0ubuntu0.5 3.4.2-0ubuntu0.6
upgrade libgtk-3-common 3.4.2-0ubuntu0.5 3.4.2-0ubuntu0.6

----------------------------------
verification case:
- run nautilus
- open the context menu for a file/folder
- hit R(once)
- context menu disappear & change to rename mode.
----------------------------------

good works & thank you.

tags: added: verification-done
removed: verification-needed

The verification of the Stable Release Update for gtk+3.0 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.4.2-0ubuntu0.6

---------------
gtk+3.0 (3.4.2-0ubuntu0.6) precise; urgency=low

  * Merge fix from Albert Astals Cid to not hijack mnemonics for non-menubar
    menus (for example context menus). The standard gtk codepath performs more
    sanity checks that we need. Fixes, for example, the 'R' mnemonic in
    Nautilus (rename). (LP: #896740)

  [ Ritesh Khadgaray ]
  * debian/patches/git_bookmark_ellipsize.patch:
    - GtkFileChooserButton dialog stretched, when user has a really long name
      saved to bookmark (lp: #956855)
 -- Sebastien Bacher <email address hidden> Thu, 15 Nov 2012 15:36:06 +0100

Changed in gtk+3.0 (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers