No "parent folder" button in Nautilus

Bug #885592 reported by Stefan Löffler on 2011-11-03
250
This bug affects 53 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Medium
nautilus (Ubuntu)
Low
Unassigned

Bug Description

After update to oneiric, I don't see any easy way (read: toolbar button) to navigate to the parent folder. There is a menu entry, and there are keyboard shortcuts, but neither gives an easy way to quickly navigate up in the directory tree with the mouse (in particular if you want to go up two or three levels).

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic-pae 3.0.4
Uname: Linux 3.0.0-12-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Thu Nov 3 09:49:25 2011
SourcePackage: nautilus
UpgradeStatus: Upgraded to oneiric on 2011-10-17 (17 days ago)

Stefan Löffler (st.loeffler) wrote :
Alessandro Menti (elgaton) wrote :

You can click on the names of the parent folders (it's a breadcrumb system).

Stefan Löffler (st.loeffler) wrote :

I'm using the location bar in "location field mode" (http://linux.about.com/library/gnome/blgnome6n12b.htm). Sorry for not clarifying this earlier - I tried to remember where that setting was, but it appears to be gone from the preferences dialog :(.

FWIW, here is the corresponding part of gconf:

$ gconftool-2 -a /apps/nautilus/preferences
 executable_text_activation = ask
 enable_delete = false
 start_with_status_bar = true
 click_policy = double
 sidebar_cat_network_expander = true
 start_with_location_bar = true
 default_folder_viewer = icon-view
 media_autorun_x_content_open_folder = []
 sort_directories_first = true
 media_automount = true
 install_mime_activation = true
 show_directory_item_counts = local-only
 always_use_location_entry = true
 navigation_window_saved_geometry = 1443x760+475+290
 navigation_window_saved_maximized = false
 start_with_toolbar = true
 side_pane_view = places
 mouse_use_extra_buttons = true
 sidebar_cat_personal_expander = true
 show_advanced_permissions = false
 desktop_font = Ubuntu 11
 sidebar_width = 192
 date_format = locale
 confirm_trash = true
 always_use_browser = true
 show_icon_text = local-only
 sidebar_cat_devices_expander = true
 mouse_forward_button = 9
 toolbar_items = [Back,Forward,Up,StopReload,Search,LocationPathBar,ViewModeButton]
 media_automount_open = true
 media_autorun_never = false
 media_autorun_x_content_start_app = [x-content/software]
 mouse_back_button = 8
 clutter_test = 2
 show_image_thumbnails = local-only
 media_autorun_x_content_ignore = []
 start_with_sidebar = true
 thumbnail_limit = 0
 desktop_is_home_dir = false

Curiously, the "toolbar_items" entry contains "Up", but that seems to be ignored. So I guess this is a problem with not properly porting options in the update to oneiric?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nautilus (Ubuntu):
status: New → Confirmed
Earl Malmrose (earl) wrote :

Clicking breadcrumbs is a poor workaround for such an often used activity. First, most of time the parent breadcrumb is hidden, so you first need to click the reveal button before the parent button even shows up. This essentially doubles the number of clicks to navigate to the parent. Furthermore, the parent breadcrumb moves around, and isn't always in the same location. This also slows down up-navigation. Lack of a true parent-button is a huge step backwards in productivity.

Dave Gilbert (ubuntu-treblig) wrote :

Medium suggested by elgaton ; it seems to be a moderate impact on a core app - possibly specificly related to an option that's now hidden?

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

it's a low priority, the action has a menu item in the "go to" menu, a keybinding (alt-up) and you can click on the breadcumb buttons, that's not something hard to reach, the decision to drop the button also seems a GNOME one and should be reported in their bug tracker for discussion if you want it changed

Changed in nautilus (Ubuntu):
importance: Medium → Low
Pedro Villavicencio (pedro) wrote :

As Sebastien said this is a design decision and the bug needs to be send to bugzilla.gnome.org (product nautilus) where the nautilus developers can comment on it. Thanks.

Alessandro Menti (elgaton) wrote :

I've tried to set the "always_use_location_entry" Nautilus preference to "true" on a fresh Oneiric install (using gconftool-2) to provide the GNOME developers a way to reproduce the problem, but with no success (the breadcrumbs bar is always shown). I'll try to set all the preferences Stefan mentioned in the next hours.

It's been reported already; so, the best to do is give it attention at the reported location:
https://bugzilla.gnome.org/show_bug.cgi?id=662243

I agree that this is a real hindrance. I've switched my file manager to Thunar at the moment to get back the functionality.

Alessandro Menti (elgaton) wrote :

Added tracking.

Changed in nautilus:
importance: Undecided → Unknown
status: New → Unknown
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Matt Pharoah (mr-exuberant) wrote :

This is an EXTREMELY annoying bug for me. I like using the text location instead of breadcrumbs so that I can copy-paste file locations (which is especially useful now that Nautilus no longer has the "open location in terminal" option on the menu anymore), so there's no quick way to move to a parent directory using the mouse. The back button only works if you got to your current location via it's parent, which is often not the case. The designers kind of pulled a Vista on this one :(

Changed in nautilus:
importance: Unknown → Medium
status: Unknown → New

@alessandro-menti
gconftool-2 has no effect. The change must be done with dconf-editor (part of dconf-tools) to show or hide the text entry location bar by default. The key is in org.gnome.nautilus.preference . This is reproducible on a fresh Oneiric install.

flar (asegaert) wrote :

I made a patch to add the up button, which can be downloaded here:
http://ubuntuforums.org/showthread.php?t=1904510

tc7 (tc7) wrote :

Please add the parent folder icon back in. I understand there is a work-around/keyboard/mouse menu alternatives, but it was such a nice simple button!

Removing the up button was just a *stupid* idea. Good design is *not* trendy design.

Norbert (nrbrtx) wrote :

I think we also need Home and Reload buttons. So I opened new bug - https://bugs.launchpad.net/ubuntu/+source/nautilus/+bug/1007873.

Please create these buttons. You already have patch from flar, please add it to the trunk of Nautilus.
Users, which updated 10.04 to 12.04 will be very sad without these buttons.

Changed in nautilus (Ubuntu):
status: Triaged → Confirmed
Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Norbert (nrbrtx) on 2012-06-04
tags: added: precise

I want to add that, when saying 'stupid', I don't mean to be offensive to anybody but only want to point out that, sometimes, some design decisions may turn out as wrong decisions. 'Wrong' because a significant number of users are not happy with these changes.

Mih-hoehne (mih-hoehne) wrote :

I like the "up"_button because I don't like to change from keybord to mouse, back to keyboard, back to mouse,... when I'm cleaning up my files.

For me the "next"-/"previous"-Buttons are obsolete.

I also need the UP button more than any other button. Even better, the user should be able to customize the toolbar, choosing buttons and their location on the bar. Thanks!

Norbert (nrbrtx) on 2012-09-22
tags: added: quantal
Gabriel (misc-evotex) wrote :

Please see this:

https://bugzilla.gnome.org/show_bug.cgi?id=684857

They removed the "always-use-location-entry" option!!!

Adam Niedling (krychek) wrote :

I don't think this bug is still valid since there is no need for a parent button in the latest version of Nautilus in Ubuntu 13.04 since there are buttons for every directory upwards of the current directory that you're in at the moment. See screenshot.

summary: - No "parent folder" button
+ No "parent folder" button in Nautilus

Are you talking about breadcrumbs ?

Adam Niedling (krychek) wrote :

I don't know what they're called. But I attached a screenshot.

Yes, but these buttons are not new.

And there are still people (including me) who find the 'up buttton' very convenient

Michael P (crank) wrote :

This bug _is_ still present, and its a _real_ bug.

for example:
If you have logged in to a remote directory over SSH with nautilus, you will usually end in your homedirectory WITHOUT an easy solution to go up to /
Every morning when i log in at work i am bugged by this, every fucking morning.
bugged by some smartypants thinking:"i dont need it = noone needs it."

Yes, i know i can press alt+L and then manipulate the address bar as i like, or press alt+up, but hey, whats the point in designing a gui when its not fully useable without keyboard?
thats just bad design.

Johan Boule (johan-boule) wrote :

I just find it "amazing" there's are buttons for "Go to previous visited location" and "Go to next visited location", but no way to go one level up in the tree ... come on, it's a tree browser, not some web browser!

You don't understand, it's called 'user experience consistency', my computer file system and the web are the same thing ;)
(Sometimes, I'm really getting sick of all this pseudo-design/marketing bla bla.)

Gabriel (misc-evotex) wrote :

Makes me think of Apple when you tell them their phone loses call or the pictures have a violet aura, it's not the product, it's that you don't know how to use it ;-).

I agree, "up" is essential for a file mangager with a hiarchical (e.g. filesystem) datastructure below it.

Rocko (rockorequin) on 2016-02-04
tags: added: xenial
Changed in nautilus:
status: New → Confirmed
Norbert (nrbrtx) on 2017-09-08
tags: added: artful zesty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.