Nautilus Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

Bug #880938 reported by Wildjiji on 2011-10-24
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Didier Roche
Oneiric
Undecided
Unassigned

Bug Description

Gtk-CRITICAL error messages occur by "nautilus -n" command.

this bug reason is that undefined nautilus actions is given to arguments of gtk_action_set_visible function (in nautilus_desktop_window_constructed of nautilus-desktop-window.c).

undefined actions:
"Backgrounds and Emblems"
"Nautilus Manual"

[How To Reproduce]
1. nautilus -q
2. nautilus -n

[Actual Result]
following error messages are displayed.

(nautilus:3417): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

(nautilus:3417): Gtk-CRITICAL **: gtk_action_set_visible: assertion `GTK_IS_ACTION (action)' failed

[Expected Result]
No Gtk-CRITICAL error messages.

[How To Fix]
attached patch.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.1-0ubuntu1 [modified: usr/bin/nautilus]
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Tue Oct 25 00:38:35 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110531.1)
SourcePackage: nautilus
UpgradeStatus: Upgraded to oneiric on 2011-09-27 (27 days ago)

Related branches

Wildjiji (wildjiji) wrote :

The attachment "Fix patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

Thank you for your work there

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
assignee: nobody → Ted Gould (ted)
assignee: Ted Gould (ted) → nobody
dino99 (9d9) wrote :

This issue is heavily flooding xsession-errors log (about 50/80 Mb per 8 hours) on Precise i386 , so i'm hoping a fixed package asap. Importance is set to "Low" and is not "Assigned" yet, thats really a bad roadmap.

Dmitry Shachnev (mitya57) wrote :

This code comes from debian/patches/05_desktop_menu_export.patch, not from src/nautilus-desktop.window.c.

I've updated that patch and made it available at http://bazaar.launchpad.net/~mitya57/nautilus/ubuntu-fix-lp-880938/view/head:/debian/patches/05_desktop_menu_export.patch.

Sebastien Bacher (seb128) wrote :

Didier, could you include that to the upload you plan to do tomorrow?

Changed in nautilus (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu4

---------------
nautilus (1:3.2.1-0ubuntu4) precise; urgency=low

  [ Chow Loong Jin ]
  * Add upstream patch to workaround focus issues on typeahead:
    - debian/patches/git-0001-Workaround-focus-issues-on-typeahead.patch
    (LP: #879456)

  [ Dmitry Shachnev ]
   * debian/patches/05_desktop_menu_export.patch (updated):
    - Stop hiding actions that do not exist anymore (LP: #880938)

  [ Didier Roche ]
  * Remove duplicate files icon, still workarounding missing desktop file:
    (LP: #886428)
    - removed debian/nautilus.links
    - ship debian/nautilus-folder-handler.desktop, copy of nautilus.desktop
      with NoDisplay=true
    - debian/nautilus.install: install the new file
  * debian/patches/11_copy_skipping_pager.patch:
    - only skip pager for the unity session (LP: #868032)

nautilus (1:3.2.1-0ubuntu3) oneiric-proposed; urgency=low

  [ Didier Roche ]
  * debian/nautilus.links: provide a symlink to workaround missing desktop file
    from prefered mimeapps.list (LP: #876788)
 -- Didier Roche <email address hidden> Thu, 10 Nov 2011 09:37:51 +0100

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released

Hello Wildjiji, or anyone else affected,

Accepted nautilus into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: patch verification-needed
Wildjiji (wildjiji) wrote :

I installed Nautilus(1:3.2.1-0ubuntu3.1) from proposed repository.
And I could confirm that the issue is resolved.
Thank you for fix.

Pedro Villavicencio (pedro) wrote :

This is also working fine here.

Dmitry could you please do not change the tags without adding a comment ? Thanks.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu3.1

---------------
nautilus (1:3.2.1-0ubuntu3.1) oneiric-proposed; urgency=low

  [ Chow Loong Jin ]
  * Add upstream patch to workaround focus issues on typeahead:
    - debian/patches/git-0001-Workaround-focus-issues-on-typeahead.patch
    (LP: #879456)

  [ Dmitry Shachnev ]
   * debian/patches/05_desktop_menu_export.patch (updated):
    - Stop hiding actions that do not exist anymore (LP: #880938)

  [ Didier Roche ]
  * Remove duplicate files icon, still workarounding missing desktop file:
    (LP: #886428)
    - removed debian/nautilus.links
    - ship debian/nautilus-folder-handler.desktop, copy of nautilus.desktop
      with NoDisplay=true
    - debian/nautilus.install: install the new file
  * debian/patches/11_copy_skipping_pager.patch:
    - only skip pager for the unity session (LP: #868032)

nautilus (1:3.2.1-0ubuntu3) oneiric-proposed; urgency=low

  [ Didier Roche ]
  * debian/nautilus.links: provide a symlink to workaround missing desktop file
    from prefered mimeapps.list (LP: #876788)
 -- Didier Roche <email address hidden> Thu, 10 Nov 2011 09:37:51 +0100

Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers