Ubuntu

Many users upgrading from 11.04 or eariler will be unable to open trash; flash drives & if using Classic session places in nautilus

Reported by Doug McMahon on 2011-10-17
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Unity
Undecided
Unassigned
nautilus (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

For affected users:
1. install the new version from -proposed
2. logout/login and check that the entitle dissues aren't reproducable

This issue isn't really a nautilus one per se, have to start somewhere.

The issue is simple, updaters are quite likely to have this line in the [Default Applications] section of ~/.local/share/mimeapps.list
inode/directory=
If it is inode/directory=nautilus-folder-handler.desktop, which no longer exists, then things like trash & usb flash drives will open with the 1st. listed .desktop on the inode/directory= line in the [Added Associations] section which in many cases is a media player

Have just myself seen Edit: 40 such cases in a couple days
for users that are logging into gnome-fallback this can also extend to the places menu

In 11.10 & 12.04 this will mainly affect 10.10, 11.04 & 10.04 users who installed before 10.04.2
Maybe there is nothing to be done, eventually it will go away as installs with nautilus-folder.handler.desktop disappear
(it's possible that one of the other nautilus.desktop names that is also no longer used could be on that line to the same effect.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: nautilus 1:3.2.0-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: i386
Date: Mon Oct 17 14:56:31 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Doug McMahon (mc3man) wrote :
summary: Many users upgrading from 11.04 or eariler will be unable to open trash;
- flash drives & if using Classic session places iin nautilus
+ flash drives & if using Classic session places in nautilus
Doug McMahon (mc3man) wrote :

I've duplicated most of the users complaints -
opening trash from unity launcher
connecting usb drives
opening any mounted drice from the unity launcher
using the browser 'open containing folder dialog'

Doug McMahon (mc3man) wrote :

To duplicate the user experience
open ~/.local/share/applications/mimeapps.list

Under the [Default Applications] section add
inode/directory=nautilus-folder-handler.desktop

In the [Added Associations ] make sure some .desktop is on a similar line - to create least amount of personal trouble use this
inode/directory=firefox.desktop;

log out/in & try any of the above scenario's

related to this bug that affected 11.10
 Bug 797000

description: updated
Doug McMahon (mc3man) wrote :

Seen now almost a hundred of affected installs, starting to remind me of the issue in Maverick & Natty where the default for inode/directory could be changed. (though obviously this will affect a smaller number of users
In lieu of anything else or doing nothing you could consider adding a nautilus-home-folder.desktop back into /usr/share/applications or at least fixing the unity launcher in terms of trash & external drives

Omer Akram (om26er) wrote :

I subscribed didrocks as I believe he might have a say on this..

Omer Akram (om26er) wrote :

(I also believe he is not home and is in Orlando so the reply could take a while)

Didier Roche (didrocks) wrote :

This shouldn't be unity dealing with that, but either nautilus shipping the desktop file as a SRU (but this won't f(?ix the case for precise) and special casing this in glib (?) to handle the removed desktop file. I'm looking into this, thanks for notifying about this issue.

Didier Roche (didrocks) wrote :

ok, after having a serious look, it seems to me that GNOME dropped it in nautilus 3 because they don't support anymore the "nautilus showing desktop" mode and so don't need a .desktop file running nautilus --no-desktop.
Anyway, it seems that just running nautilus %U do the right thing this option on or off and exit nautilus when it's needed, so I think we should just use the nautilus desktop file again for this mimetype. (and transition people to it)

Changed in unity:
status: New → Invalid
affects: nautilus (Ubuntu) → glib2.0 (Ubuntu)
Didier Roche (didrocks) wrote :

finally, to get the minimal impact for this particular case, we'll push a symlink to nautilus to address this.

affects: glib2.0 (Ubuntu) → nautilus (Ubuntu)
Didier Roche (didrocks) on 2011-10-31
description: updated
Changed in nautilus (Ubuntu):
status: New → Fix Committed
Changed in nautilus (Ubuntu Oneiric):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Please upload this to precise, so that this can progress to -updates at some point.

tags: added: verification-needed

Hello Doug, or anyone else affected,

Accepted nautilus into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Doug McMahon (mc3man) wrote :

All good here -
The symlink was created on nautilus upgrade, tested with a new user where mimeapps.list was setup to dupe what an upgrade install would have.
Trash, usb drives opened fine, going to a Classic login Places opened fine.
No side issues found on a normal fresh install

tags: added: verification-done
removed: verification-needed
Dmitry Shachnev (mitya57) wrote :

After this update, "Files" entry is shown twice in Applications lens and in GNOME menu.

Doug McMahon (mc3man) wrote :

Dmitry Shachnev wrote >
After this update, "Files" entry is shown twice in Applications lens and in GNOME menu.
Atm the link seems better then having to continually advise many upgraders to edit ~/...mimeapps.list

If the duped "Files" is an issue then maybe just add a 'real' nautilus-folder-handler.desktop, it could be set to NoDisplay=true, it's Name= could be anything, doesn't matter. (Folders

(Not actually sure why users need to see Files , (nautilus.desktop), in the first place, unless that's some concession to gnome* sessions?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu4

---------------
nautilus (1:3.2.1-0ubuntu4) precise; urgency=low

  [ Chow Loong Jin ]
  * Add upstream patch to workaround focus issues on typeahead:
    - debian/patches/git-0001-Workaround-focus-issues-on-typeahead.patch
    (LP: #879456)

  [ Dmitry Shachnev ]
   * debian/patches/05_desktop_menu_export.patch (updated):
    - Stop hiding actions that do not exist anymore (LP: #880938)

  [ Didier Roche ]
  * Remove duplicate files icon, still workarounding missing desktop file:
    (LP: #886428)
    - removed debian/nautilus.links
    - ship debian/nautilus-folder-handler.desktop, copy of nautilus.desktop
      with NoDisplay=true
    - debian/nautilus.install: install the new file
  * debian/patches/11_copy_skipping_pager.patch:
    - only skip pager for the unity session (LP: #868032)

nautilus (1:3.2.1-0ubuntu3) oneiric-proposed; urgency=low

  [ Didier Roche ]
  * debian/nautilus.links: provide a symlink to workaround missing desktop file
    from prefered mimeapps.list (LP: #876788)
 -- Didier Roche <email address hidden> Thu, 10 Nov 2011 09:37:51 +0100

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Hello Doug, or anyone else affected,

Accepted nautilus into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Doug McMahon (mc3man) wrote :

Works fine here - resolves having that inode/dir line, doesn't show in Dash or gnome-shell apps

Doug McMahon (mc3man) wrote :

To add - tested in both 12.04 & 11.10

tags: added: verification-done
removed: verification-needed
Pedro Villavicencio (pedro) wrote :

Working fine here as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu3.1

---------------
nautilus (1:3.2.1-0ubuntu3.1) oneiric-proposed; urgency=low

  [ Chow Loong Jin ]
  * Add upstream patch to workaround focus issues on typeahead:
    - debian/patches/git-0001-Workaround-focus-issues-on-typeahead.patch
    (LP: #879456)

  [ Dmitry Shachnev ]
   * debian/patches/05_desktop_menu_export.patch (updated):
    - Stop hiding actions that do not exist anymore (LP: #880938)

  [ Didier Roche ]
  * Remove duplicate files icon, still workarounding missing desktop file:
    (LP: #886428)
    - removed debian/nautilus.links
    - ship debian/nautilus-folder-handler.desktop, copy of nautilus.desktop
      with NoDisplay=true
    - debian/nautilus.install: install the new file
  * debian/patches/11_copy_skipping_pager.patch:
    - only skip pager for the unity session (LP: #868032)

nautilus (1:3.2.1-0ubuntu3) oneiric-proposed; urgency=low

  [ Didier Roche ]
  * debian/nautilus.links: provide a symlink to workaround missing desktop file
    from prefered mimeapps.list (LP: #876788)
 -- Didier Roche <email address hidden> Thu, 10 Nov 2011 09:37:51 +0100

Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers