05_desktop_menu_export.patch adds duplicate lines

Bug #874847 reported by Dmitry Shachnev on 2011-10-15
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
nautilus (Ubuntu)
Low
Dmitry Shachnev
Oneiric
Low
Dmitry Shachnev
Precise
Low
Dmitry Shachnev

Bug Description

I'm currently working on fixing bug 814799 and bug 826771, and I noticed that the mentioned patch adds duplicate lines:

05_desktop_menu_export.patch, lines 120-121:
+ gtk_widget_hide (NAUTILUS_WINDOW (window)->details->statusbar);
+ gtk_widget_hide (NAUTILUS_WINDOW (window)->details->menubar);

lines 129-132:
+ /* Don't allow close action on desktop */
+ action = gtk_action_group_get_action (NAUTILUS_WINDOW (window)->details->main_action_group,
+ NAUTILUS_ACTION_CLOSE);
+ gtk_action_set_sensitive (action, FALSE);

These lines already exist in original nautilus_desktop_window.c (they are lines 71-72 and 74-77).

Related branches

Changed in nautilus (Ubuntu):
status: New → In Progress
assignee: nobody → Dmitry Shachnev (mitya57)
Sebastien Bacher (seb128) wrote :

Thank you for your bug report

Ted, you wrote that patch, could you look at it?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
Dmitry Shachnev (mitya57) wrote :

I've already said that I'm preparing some fixes for nautilus-desktop-window.c (first one is already available: http://bugzilla-attachments.gnome.org/attachment.cgi?id=199052).

So, I'll fix this in my branch (I hope it'll happen this week).

summary: - [packaging] 05_desktop_menu_export.patch adds duplicate lines
+ 05_desktop_menu_export.patch adds duplicate lines
description: updated
Changed in nautilus (Ubuntu):
assignee: Dmitry Shachnev (mitya57) → nobody
status: In Progress → Confirmed
tags: added: patch-needswork
Dmitry Shachnev (mitya57) wrote :

Can somebody else look at this? When I build Nautilus from bzr, it segfaults, so I can't test my code.

Dmitry Shachnev (mitya57) wrote :

Actually I got it working, the package is now available in ppa:matttbe/ppa thanks to Matthiew Baerts.

Changed in nautilus (Ubuntu):
assignee: nobody → Dmitry Shachnev (mitya57)
Sebastien Bacher (seb128) wrote :

bug #880938 is another issue in that code

Changed in nautilus (Ubuntu Oneiric):
importance: Undecided → Low

Hello Dmitry, or anyone else affected,

Accepted nautilus into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus (Ubuntu Precise):
status: Confirmed → Fix Committed
Changed in nautilus (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Dmitry Shachnev (mitya57) wrote :

> bug #880938 is another issue in that code
Patch that's attached there perfectly solves the problem (seems that those lines were removed in 3.x).

Also, I'm marking this as verification-done because the current version (http://bazaar.launchpad.net/~ubuntu-desktop/nautilus/ubuntu/view/head:/debian/patches/05_desktop_menu_export.patch) does no more add that lines.

tags: added: verification-done
removed: patch-needswork verification-needed
Changed in nautilus (Ubuntu Oneiric):
assignee: nobody → Dmitry Shachnev (mitya57)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu2

---------------
nautilus (1:3.2.1-0ubuntu2) oneiric-proposed; urgency=low

  [ Dmitry Shachnev ]
  * debian/patches/05_desktop_menu_export.patch (updated):
    - Destroy menubar on non-ubuntu sessions (LP: #826771)
    - Remove duplicate lines (LP: #874847)
  * debian/patches/17_dont_allow_new_tab_on_desktop.patch:
    - Don't allow "New tab" shortcut on desktop (LP: #814799)

  [ Martin Pitt ]
  * 05_desktop_menu_export.patch: Fix potential crash if $DESKTOP_SESSION is
    not set.
 -- Dmitry Shachnev <email address hidden> Tue, 25 Oct 2011 12:46:53 +0200

Changed in nautilus (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers