nautilus progress window marked skipped, not managed by gnome-shell

Bug #868032 reported by Michael Moorman on 2011-10-05
200
This bug affects 47 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Unknown
Medium
nautilus (Ubuntu)
Low
Didier Roche
Oneiric
Undecided
Unassigned

Bug Description

When running nautilus and doing a file transfer that brings up the file
operations window, I noticed that the window doesn't appear in the Alt+Tab
grouping for nautilus, and does not appear in the gnome-shell Windows activity
or even in the thumbnail for the workspace that the window resides in. This
makes it very difficult to find when there are many windows in the current
workspace, which is usually the case in my workflow.

test case:
1. install the new version (1:3.2.1-0ubuntu4) from -proposed
2. run gnome-shell
  2.1 make a copy
   -> you should see the copy dialog in the pager
3. run unity
  3.1 make a copy
  3.2 close all your nautilus windows
  3.3 click on the nautilus icon in the launcher -> it should enable you to launch a new nautilus window

Changed in gnome-shell:
importance: Unknown → Medium
status: Unknown → New
Michael Moorman (tensorpuddin) wrote :

Upstream pointed out the bug is Ubuntu-specific, and affects nautilus, not gnome-shell. The offending code is in the 11_copy_skipping_page.patch (http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/oneiric/nautilus/oneiric/view/head:/debian/patches/11_copy_skipping_pager.patch)

affects: gnome-shell (Ubuntu) → nautilus (Ubuntu)
summary: - gnome-shell does not manage the nautilus file operations dialog
+ nautilus progress window marked skipped, not managed by gnome-shell
Changed in nautilus (Ubuntu):
assignee: nobody → Didier Roche (didrocks)
importance: Undecided → Low
status: New → Confirmed
Changed in gnome-shell:
status: New → Unknown
Deejay_TNT (idaho) wrote :

I wonder why the priority is considered low. A really distracting bug.

Simon Hirscher (codethief) wrote :

So do I…

Nik (nik-gare) wrote :

If the window is minimised, it disappears completely, but the file transfer continues (I presume)
This is a fairly major bug, it should not be marked as low priority!

Julien Olivier (julo) wrote :

And I just found out today that once minimized there is no way to restore it either. That means that, even if you know you have a transfer going on, you have no way to know its progress or even stop it once minimized.

Julien Olivier (julo) wrote :

Just revert the offending patch and be done with it please.

pdf (pdffs) wrote :

Absolutely - this is absolutely ridiculous.

Sebastien Bacher (seb128) wrote :

Bug reports are not user forums, that's a known, confirmed issue, no need to spam people subscribed with comments which will not help to get the issue resolved

pdf (pdffs) wrote :

It's a confirmed issue set to low priority, but with medium impact - the incongruence is what prompted the additional comments. Particularly when the fix is simply to remove a completely unnecessary Ubuntu-specific patch.

Julien Olivier (julo) wrote :

Absolutely, there is a real problem with the way Ubuntu developpers manage bugs and treat bug reporters. I understand that it may take ages to fix a bug that actually needs work. But when the "fix" is to actually stop breaking perfectly functional debian packages, there is nothing that could justify that a bug stays opened for more than one month. Or, if there is anything preventing this bug from being fixed, people suffering from it would appreciate to be informed about the reasons why this is not fixed. You can't just ignore such an easy-to-fix bug for a month and expect people to wait and shut their mouth...

Didier Roche (didrocks) wrote :

@pdf: interesting that you know that it's an uncessary patch, did you look at why it was set before affirming this?

if you take some time to dig a little further, you will see:
  * debian/patches/11_copy_skipping_pager.patch:
    - after discussion with dx and design, the easier short-time solution is to
      have the copy dialog skipping the pager to be able to launch nautilus even
      with a copy operation in progress (bamf will handle that in the future
      nicely) (LP: #784804)

And if you open the linked bug, you will see as well that the issue it fixes for unity is not trivial (basically, if you perform a copy operation in unity and close the nautilus window, there is no way to get a new nautilus windows)
So, yeah thanks for the qualifier of "ridiculous" for this patch, that woul help if you take more time to have a better patch though rather than just stating something which isn't right.

Basically, I'll take some time to fix it tomorrow, which is NOT removing the patch, but only skipping the pager in the unity session. If you are up for that, patches are, as always, welcomed, and more constructive than having this behavior on a bug report.
Thanks.

Sebastien Bacher (seb128) wrote :

rants, not helpful guys, really.... you might be frustrated but that's not the way to solve those issues, there is just not enough contributors working on those packages to fix all the issues, no complaining, ranting, insulting will change that, you will just maybe manage to demovative the few contributors that try to be helpful to do less

@pdffs
> It's a confirmed issue set to low priority, but with medium impact -

it has a medium impact on a non default desktop environment, that's not an issue under unity or unity-2d or kde or xfce...

> the incongruence is what prompted the additional comments. Particularly when the fix is simply to remove a completely unnecessary Ubuntu-specific patch.

that's wrong, as pointed before and detailed by Didier the patch fixes and issue in the default desktop environment

@julo

> there is a real problem with the way Ubuntu developpers manage bugs and treat bug reporters.

the problem is maybe the low ration of maintainer compared to the number of softwares and users. Take a step back there, the system you are using is made by people, who often work crazy number of hours in a week on in their evenings, on a product you get for free, are you complaining that those people just don't work hard enough to your taste? Do you think it's right of fair to hit harder on them because the result is not perfect? Do you think it's going to "solve" all the problems?

> You can't just ignore such an easy-to-fix bug for a month and expect people to wait and shut their mouth...

The statements you do there are just wrong, the fix is required for the default Ubuntu desktop so it's not as easy as dropping it, the default desktop is what most of the current desktop team is running which explains why we sometime not notice issues happening in other variants, we would welcome help maintaining GNOME and gnome-shell though and we would welcome patches for those "easy-to-fix" bugs gnome-shell users run into, what about stepping up and trying to help rather than complain that other don't give enough of their time?

Julien Olivier (julo) wrote :

@seb

I respect your work, and don't *ask* for anything other than just a bit more communication. I would *never ever* ask for anyone to do anythin faster for free, but I think it's just more respectful to just drop a line to explain why this can't be done quickly. Now you've just explained it and it makes sense. If my rant made you be more verbose about the problem then it was worth it.

Thanks for your work, and sorry for the noise.

Sebastien Bacher (seb128) wrote :

> but I think it's just more respectful to just drop a line to explain why this can't be done quickly

right, that's also a manpower issue, my "launchpad desktop bugs" imap folder which tracks only the desktop components I'm subscribed to got 123 emails today. Desktop packages simply receive some hundred emails a day, we can't just reply to every single issue reported or we wouldn't have time for fixing anything or doing any update and yet it would still maybe not be enough to reply to everything

pdf (pdffs) wrote :

@didrocks - thanks for the explanation, I'll look at producing a patch for this. I must admit, I didn't search the changelog, but commenting the patches themselves (as Debian do) makes this round-trip a lot more accessible and clear.

@seb128 - a quick post to say this patch was related to #784804, rather than, 'shut up, stupid users' would have avoided all this additional noise (and saved you half a dozen more emails in that mailbox).

'Fixing' Nautilus rather than Unity seems like an odd choice (well, so does Unity as a whole, but we won't get into that), but I understand there was likely significant pressure to continue rushing Unity, and no time to fix the issue properly.

Michael Moorman (tensorpuddin) wrote :

@pdf - The actual bug in my book is that Nautilus still has a separate window for file transfers. I think the file transfer should be converted to a gnome-shell notification, which obviates the need for handling its window. I don't know if the Nautilus devs intend to do that though, or how Unity would handle such a thing.

We should all keep it respectable in here for the hard work put in by the devs, and properly thank didrocks for writing a patch.

Julien Olivier (julo) wrote :

Actually the real problem is that Nautilus is supposed to use the notification area for file transfers but doesn't on Ubuntu. See bug #849733.

Michael Moorman (tensorpuddin) wrote :

Fixing that bug would be a solution for now, but ideally a real solution wouldn't use the deprecated notification area at all, but integrate it into the shell somehow.

pdf (pdffs) wrote :

@julo - They're separate bugs that exacerbate each other. If one worked, the other would not be such a problem. That said, I've tried building 3.2.1 with all Debian/Ubuntu patches removed, and I still get no notification, so #849733 must either be an upstream bug (the linked issue from bug #849733 only mentions testing with 3.1.0), or a packaging/dependency error. I've commented on that bug to the effect that it's not a duplicate, and will update any further progress relating to lack of notification there.

@tensorpuddin - Nautilus has been updated to conditionally use the new persistent notifications introduced by gnome-shell (a la Empathy, et al), so clicking the notification should display a nice progress list attached to the notification area, if it was working.

Didier Roche (didrocks) on 2011-11-10
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu4

---------------
nautilus (1:3.2.1-0ubuntu4) precise; urgency=low

  [ Chow Loong Jin ]
  * Add upstream patch to workaround focus issues on typeahead:
    - debian/patches/git-0001-Workaround-focus-issues-on-typeahead.patch
    (LP: #879456)

  [ Dmitry Shachnev ]
   * debian/patches/05_desktop_menu_export.patch (updated):
    - Stop hiding actions that do not exist anymore (LP: #880938)

  [ Didier Roche ]
  * Remove duplicate files icon, still workarounding missing desktop file:
    (LP: #886428)
    - removed debian/nautilus.links
    - ship debian/nautilus-folder-handler.desktop, copy of nautilus.desktop
      with NoDisplay=true
    - debian/nautilus.install: install the new file
  * debian/patches/11_copy_skipping_pager.patch:
    - only skip pager for the unity session (LP: #868032)

nautilus (1:3.2.1-0ubuntu3) oneiric-proposed; urgency=low

  [ Didier Roche ]
  * debian/nautilus.links: provide a symlink to workaround missing desktop file
    from prefered mimeapps.list (LP: #876788)
 -- Didier Roche <email address hidden> Thu, 10 Nov 2011 09:37:51 +0100

Changed in nautilus (Ubuntu):
status: Confirmed → Fix Released

Hello Michael, or anyone else affected,

Accepted nautilus into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in nautilus (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed
Julien Olivier (julo) wrote :

It works perfectly for me. Thanks!

tags: added: verification-done
removed: verification-needed
pdf (pdffs) wrote :

Thanks for the rapid fix guys, appreciated.

Michael Moorman (tensorpuddin) wrote :

@julo @pdf Okay, thanks for pointing out that bug. I'll follow #849733

@pitti This bug seems to be fixed now, thank you.

@didirocks Thanks again for the patch.

Colin Law (colin-law) wrote :

I have taken the liberty of changing this back to incomplete as it seems to be fixed in Unity but not Unity-2d.
To replicate, in Unity-2d:
Open nautilus and start a file copy operation going.
Note that the nautilus launcher now shows two markers for the two windows, but Alt-Tab does not show the progress window and clicking the launcher icon again also only shows the main window rather than both.

Using nautilus 1:3.2.1-0ubuntu2 and unity-2d 4.14-0ubuntu1~bzr780 (from daily ppa) on Oneiric.

Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Incomplete
Sebastien Bacher (seb128) wrote :

the unity-2d is another issue, you should open a bug on unity-2d about it

Changed in nautilus (Ubuntu Oneiric):
status: Incomplete → Fix Committed
Sebastien Bacher (seb128) wrote :

What DESKTOP_SESSION environment variable do you have on unity-2d?

Colin Law (colin-law) wrote :

DESKTOP_SESSION is ubuntu-2d
I saw the note at the end of comment #11 that a specific test was being made for unity, and thought that the problem may be that this did not include 2d.

Sebastien Bacher (seb128) wrote :

the patch checks for "ubuntu" or "ubuntu-2d" sessions...

Colin Law (colin-law) wrote :

OK, for the record, posted as bug #891169 on unity-2d.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.2.1-0ubuntu3.1

---------------
nautilus (1:3.2.1-0ubuntu3.1) oneiric-proposed; urgency=low

  [ Chow Loong Jin ]
  * Add upstream patch to workaround focus issues on typeahead:
    - debian/patches/git-0001-Workaround-focus-issues-on-typeahead.patch
    (LP: #879456)

  [ Dmitry Shachnev ]
   * debian/patches/05_desktop_menu_export.patch (updated):
    - Stop hiding actions that do not exist anymore (LP: #880938)

  [ Didier Roche ]
  * Remove duplicate files icon, still workarounding missing desktop file:
    (LP: #886428)
    - removed debian/nautilus.links
    - ship debian/nautilus-folder-handler.desktop, copy of nautilus.desktop
      with NoDisplay=true
    - debian/nautilus.install: install the new file
  * debian/patches/11_copy_skipping_pager.patch:
    - only skip pager for the unity session (LP: #868032)

nautilus (1:3.2.1-0ubuntu3) oneiric-proposed; urgency=low

  [ Didier Roche ]
  * debian/nautilus.links: provide a symlink to workaround missing desktop file
    from prefered mimeapps.list (LP: #876788)
 -- Didier Roche <email address hidden> Thu, 10 Nov 2011 09:37:51 +0100

Changed in nautilus (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Ali Raeini (aliqasemi) wrote :

I have the same problem using ubuntu 12.04, running compiz+unity

123vier (flowrist) wrote :

Bug still occuring using 12.10, standard ubuntu config with compiz, unity and ATI graphics card.

Yes, problem still occuring using 13.10 - saucy. And latest version kernel: 3.11.6

Dave Vree (hdave) wrote :

This still happens to me with Unity on Ubuntu 13.10.

Markcortbass (markcortbass) wrote :

I confirm this problem still occuring using 13.10...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.